Subject: How about this? (Re: Standardizing inline PGP for e-mail?)

From: [email-masked]
Date: Mon, 27 Jan 2003 10:17:54 -0600

How about this variation:

Add an X-header to the message.  Everybody not "in the know" will 
certainly ignore it.  It serves the same purpose as the original proposal, 
allowing those that are "in the know" to decode the message automatically 
or otherwise take action without having to parse the body to discover the 
existance of inline PGP.

If the purpose of this is to trigger automatic decoding, have something 
like
        X-PGP-autodecrypt: true

also, a value of false can explicitly tell the MUA not to automatically 
decrypt.

--John

"Michael Young" <[email-masked]>
Sent by: [email-masked]
01/24/03 12:53 PM

        To:     <[email-masked]>
        cc: 
        Subject:        Re: let's look...  Re: Standardizing inline PGP for e-mail?

From: "David Shaw" <[email-masked]>
> On Fri, Jan 24, 2003 at 11:08:25AM -0500, Michael Young wrote:
> > David Shaw wrote:
> > > I think in general that creating a new subtype of text to solve this
...
> I think we've seen in this thread that the "lite" form is not
> displayed at all in agents that don't support it.

That's an overstatement.  Several MUAs handled it just fine (and
mutt is clearly going to be changed in the process, so it will also).
(The only failure I saw was Outlook XP, but I may have missed something.)

But, I missed that you were talking specifically about the subtype idea...

> Thomas' original suggestion to use UTF8 encoding along with text/plain
> works very nicely on several levels.  First, it works without forcing
> the MUA author to do anything.  Second, in most cases even if MUA "A"
> does it slightly wrong (say, not doing the UTF8), MUA "B" can still
> handle it.  It's simple.  It works.  Where is the problem?

The main reason we went down the subtype path was that Ned balked at
using text/plain with extra tags.  (Thomas suggested the tags to let
in-the-know MUAs take automatic action, and Ned balked there, too.)
Experimenting with subtypes was a fine idea, but it hasn't been a
complete success.  I'm happy to back off to text/plain, and I'm happy
with the extra tags.

---

From: [email-masked]
Date: Tue, 28 Jan 2003 07:36:31 -0800

On Mon, 27 Jan 2003 08:17:54 -0800 [email-masked] wrote:
>Add an X-header to the message.  

or possibly a simple generic solution {*if * it would work}
on the user end,
to just preface the pgp clearsigned message with:

below is a clearsigned pgp message,

and so, try to 'fool' the e-mail client that the message begins and ends
with plain text.

am including a test clearsigned message in-line below, followed by an end plaintext,

clearsigned test

this ends the pgp message test,

vedaal

Concerned about your privacy? Follow this link to get
FREE encrypted email: https://www.hushmail.com/?l=2 

Big $$$ to be made with the HushMail Affiliate Program: 
https://www.hushmail.com/about.php?subloc=affiliate&l=427