Subject: [payload] RFC 3190 channel order registration

From: Thomas Edwards <[email-masked]>
Date: Wed, 18 Apr 2018 23:14:05 +0000

RFC 3190 “RTP Payload Format for 12-bit DAT Audio and 20- and 24-bit Linear Sampled Audio” has an fmtp parameter “channel-order”.

RFC 3190 says:

“a=fmtp:<payload type> channel-order=<convention>.<order>

   The first component of the value, <convention>, specifies the type of
   channel assignment convention used.  This allows for conventions
   other than AIFF-C and DV to be defined in the future.  This document
   defines only one convention for use in the channel-order parameter:

      DV”

SMPTE is interested in registering a new channel order convention, based on SMPTE ST 2110-30.

I don’t see any entries in the IANA SDP Parameters registry, nor any explanation in RFC 3190 on how to register new channel order conventions.

Thanks!

-Thomas

--
Thomas Edwards
FOX Networks Engineering & Operations
VP Engineering & Development
[email-masked]
+1-310-369-6696
10201 W Pico Blvd
Los Angeles, CA 90035

---

From: "Ali C. Begen" <[email-masked]>
Date: Wed, 18 Apr 2018 16:20:44 -0700

If that is the case, I guess we can revise the RFC.

On Wed, Apr 18, 2018 at 4:14 PM, Thomas Edwards <[email-masked]>
wrote:

> RFC 3190 “RTP Payload Format for 12-bit DAT Audio and 20- and 24-bit
> Linear Sampled Audio” has an fmtp parameter “channel-order”.
>
>
>
> RFC 3190 says:
>
>
>
> I don’t see any entries in the IANA SDP Parameters registry, nor any
> explanation in RFC 3190 on how to register new channel order conventions.
>
>
>
> Thanks!
>
>
>
> -Thomas
>
>
>
> --
>
> Thomas Edwards
>
> _______________________________________________
> payload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/payload
>
>