Subject: Re: [pm-dir] Performance metrics doctors generated email - new version.

From: "MORTON JR., ALFRED (AL)" <[email-masked]>
Date: Mon, 4 Mar 2013 10:59:25 -0500

pm-dir,

This weekend, I experimented with preparing a google doc 
to track drafts and reviews.  I ended-up using a Google Spreadsheet,
which seems to be nicely suited to the task and adds features
that not possible a static document table. I have just updated
the table with the yesterday's script results, adding two new drafts.

https://docs.google.com/spreadsheet/ccc?key=0AmKrqWIOBsprdGZqMnB6dmx5bFJvVUhta3VLSjl3SkE&usp=sharing

"everyone" with the link above should be able to view the sheet.

"anyone" in pm-dir who sends me their gmail address (or new address
prepared for this purpose) will have the editing rights shared with 
them, and can volunteer to review drafts, enter status, etc.

Hopefully, the words in "quotes" above will be true, subject to testing
which begins now.

Al
your faithful PMDir Admin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of MORTON JR., ALFRED (AL)
> Sent: Thursday, February 21, 2013 7:36 AM
> To: Yaakov Stein
> Cc: [email-masked]
> Subject: Re: [pm-dir] Performance metrics doctors generated email - new
> version.
> 
> 
> Not Google Tasks (which I haven't investigated),
> just a Google doc with the table:
> draft-name + reviewer + status + date
> 
> Which all reviewers can edit WYSIWYG
> I'll own the doc and share it with the everyone in the
> directorate (who actually does reviews :-) ).
> 
> And, that doc won't be ready till after the draft deadline!
> 
> Al
> 
> > -----Original Message-----
> > From: Yaakov Stein [mailto:[email-masked]]
> > Sent: Thursday, February 21, 2013 2:07 AM
> > To: MORTON JR., ALFRED (AL)
> > Cc: [email-masked]
> > Subject: RE: [pm-dir] Performance metrics doctors generated email - new
> > version.
> >
> > Sorry for perhaps not catching on,
> > but are you suggesting setting up a single account for all of the
> > directorate
> > and using "Google Tasks" to aggregate the review statuses ?
> >
> > While this could work, I think there are perhaps better options.
> >
> > The simplest would be just maintaining a table with draft-name +
> reviewer
> > + status + date
> > on a wiki.
> >
> > As a reviewer for several academic journals I know they have tools
> > (much too advanced for our present needs)
> > that select the most appropriate reviewer(s), send them emails,
> > receive their acceptance/rejection of the task,
> > send email reminders when the due date approaches,
> > input the review, etc.
> >
> > Y(J)S
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Carlos Pignataro (cpignata)
> > Sent: Wednesday, February 20, 2013 17:00
> > To: MORTON JR., ALFRED (AL)
> > Cc: Benoit Claise (bclaise); [email-masked]; Paul Aitken (paitken);
> Alan
> > DeKok
> > Subject: Re: [pm-dir] Performance metrics doctors generated email - new
> > version.
> >
> >
> > On Feb 20, 2013, at 9:36 AM, "MORTON JR., ALFRED (AL)"
> <[email-masked]>
> > wrote:
> >
> > > Ok Benoit,
> > > I have a version of the doc going, but probably won't finish
> > > till after the revised deadline expires...
> > >
> > > Before going further, it would be useful to know if anyone
> > > in the directorate objects to using or establishing a gmail
> > > account in order to register their review assignments and status.
> > >
> >
> > No objection. I think it's a great solution.
> >
> > Thanks,
> >
> > -- Carlos.
> >
> > > regards,
> > > Al
> > >
> _______________________________________________
> pm-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pm-dir

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 5 Mar 2013 10:31:57 +0000

Hi Al,

I am [email-masked] on Google. 

However, this is an address which I usually use for personal communication, and I am not very enthusiastic either about mixing personal and professional communications, or about creating another gmail instance of myself. So I need to ask - what are the advantages / extra capabilities offered by Google Spreadsheet relative to using a wiki page? 

Thanks and Regards,

Dan

> Sent: Monday, March 04, 2013 5:59 PM
> To: Yaakov Stein; [email-masked]
> Cc: Alan DeKok ([email-masked])
> This weekend, I experimented with preparing a google doc to track drafts
> and reviews.  I ended-up using a Google Spreadsheet, which seems to be
> nicely suited to the task and adds features that not possible a static
> document table. I have just updated the table with the yesterday's
> script results, adding two new drafts.
> 
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of MORTON JR., ALFRED (AL)
> > Subject: Re: [pm-dir] Performance metrics doctors generated email -
> > new version.
> >
> >
> > Not Google Tasks (which I haven't investigated), just a Google doc
> > with the table:
> > I'll own the doc and share it with the everyone in the directorate
> > (who actually does reviews :-) ).
> >
> > > Subject: RE: [pm-dir] Performance metrics doctors generated email -
> > > new version.
> > >
> > > directorate and using "Google Tasks" to aggregate the review
> > > statuses ?
> > >
> > > (much too advanced for our present needs) that select the most
> > > appropriate reviewer(s), send them emails, receive their
> > > acceptance/rejection of the task, send email reminders when the due
> > > date approaches, input the review, etc.
> > >
> > > Y(J)S
> > >
> > > From: [email-masked] [mailto:[email-masked]] On
> > > Behalf Of Carlos Pignataro (cpignata)
> > > Subject: Re: [pm-dir] Performance metrics doctors generated email -
> > > new version.
> > >
> > >
> > > > I have a version of the doc going, but probably won't finish till
> > > > after the revised deadline expires...
> > > >
> > > > Before going further, it would be useful to know if anyone in the
> > > > directorate objects to using or establishing a gmail account in
> > > > order to register their review assignments and status.
> > > >
> > >

---

From: "MORTON JR., ALFRED (AL)" <[email-masked]>
Date: Tue, 5 Mar 2013 09:22:43 -0500

Hi Dan,

A couple weeks back I posted this:

> > I'd prefer a solution where:
> >   - everyone can view the page
> >   - directorate reviewers can edit the page
> >   - all editing is WYSIWYG
> >   - no collisions between editors
> >    (if two people are editing, they can see each other and
> >     pressing save does not overwrite a nested editing session)
> >
> > Unfortunately, the last two points are beyond Trac's capability.
> > I think that I could create a doc on Google Drive that
> > would meet all the above criteria.

The editing collision aspect is important, because when I
posted the link yesterday, several people viewed the page
anonymously within a few minutes (as owner with the page on
my screen, I could see this). If they had all been 
editing the Wiki Trac page, over-write collisions would be likely.

I established a gmail account to work on a doc with 
Matt Mathis, and I haven't received any spam in that account
as a result of having access to a shared doc or now 
creating a doc. In fact, the only mail I receive is when 
Matt Responds to or Resolves a comment. If you don't use the 
Comment feature, I don't think you'll get any mail at all
related to this page.

Hope this helps, I will share editing with you now.
Al

> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2013 5:32 AM
> To: MORTON JR., ALFRED (AL); Yaakov Stein; [email-masked]
> I am <snip>@gmail.com on Google.
> 
> However, this is an address which I usually use for personal
> communication, and I am not very enthusiastic either about mixing personal
> and professional communications, or about creating another gmail instance
> of myself. So I need to ask - what are the advantages / extra capabilities
> offered by Google Spreadsheet relative to using a wiki page?
> 
> Thanks and Regards,
> 
> Dan
> 
> 
> 
> 
> 
>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 08 Mar 2013 12:01:38 +0100

On 5/03/2013 11:31, Romascanu, Dan (Dan) wrote:
> However, this is an address which I usually use for personal communication, and I am not very enthusiastic either about mixing personal and professional communications,
Same situation here.
Anyway, I'm [email-masked]

Regards, Benoit
> or about creating another gmail instance of myself. So I need to ask - what are the advantages / extra capabilities offered by Google Spreadsheet relative to using a wiki page?
>
> Thanks and Regards,
>
> Dan
>
>
>
>
>
>

---

From: Paul Aitken <[email-masked]>
Date: Fri, 08 Mar 2013 12:15:18 +0000

Benoit, Dan, Al,

> I am not very enthusiastic either about mixing personal and 
> professional communications, 

> Same situation here.

Could we create a single shared gmail account exclusively for PM dir?

P.

---

From: "MORTON JR., ALFRED (AL)" <[email-masked]>
Date: Fri, 8 Mar 2013 08:41:53 -0500

> From: Benoit Claise [mailto:[email-masked]]
> Sent: Friday, March 08, 2013 6:02 AM
> To: Romascanu, Dan (Dan)
> Cc: MORTON JR., ALFRED (AL); Yaakov Stein; [email-masked]; Alan DeKok
> ([email-masked])
> > I am [email-masked] on Google.
> >
> and professional communications,
> Same situation here.
> Anyway, I'm [email-masked]
>
>Regards, Benoit

You won't receive pm-dir-related email in that account,
unless you add a comment and someone replies to or resolves the
comment. So, just edit, and when you want to comment on something,
send e-mail to pm-dir and your personal/business line should
remain intact, AFAICT.

I've just shared the editing privileges with you, and you 
won't get a welcome message :-)  but you'll need to sign-in
to edit the sheet (it's a sufficiently functional spread-sheet). 
https://docs.google.com/spreadsheet/ccc?key=0AmKrqWIOBsprdGZqMnB6dmx5bFJvVUhta3VLSjl3SkE&usp=sharing

Al

---

From: "MORTON JR., ALFRED (AL)" <[email-masked]>
Date: Fri, 8 Mar 2013 08:58:08 -0500

It's an interesting idea, and it would allow a limited number
of people to edit in parallel, where the limit is unknown.

Also unknown (to me) is how Google will respond to many different
browsers, ipaddrs, etc. using the same account. It could raise a
flag and get blocked, because it might look like account theft to 
Google.

FYI - I plan to make a backup copy of the sheet on every Monday
I think of it, in case our sheet is somehow defiled or deleted.

Al

> Of Paul Aitken
> Sent: Friday, March 08, 2013 7:15 AM
> To: [email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Fri, 08 Mar 2013 18:03:54 +0100

Thanks.
That works for me.

Regards, Benoit