Subject: [pm-dir] Fwd: Re: Performance metrics doctors generated email

From: Benoit Claise <[email-masked]>
Date: Thu, 23 May 2013 23:45:55 +0200

Dear pm-dir,

Some more help from Fred.
All the drafts containing "performance metrics", along with the specific 
section.
That should help identifying the drafts that are important to review.

Regards, Benoit

---

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Thu, 23 May 2013 20:14:32 -0400

Nice, a few paragraphs from the draft provide enough context 
to see if the use of "performance metric" is something the Directorate
should consider.  Thanks Fred.

As I've said in the past, if we were running Fred's script weekly,
we would need to consider only on the diffs from last week,
so we can add new reviewer assignments.  Since this benefits me
the most, I'd be willing to add the differencing lines to the script...

Without carping on too long here, we have quite a few outstanding assignments
and drafts needing volunteers to review:
https://docs.google.com/spreadsheet/ccc?key=0AmKrqWIOBsprdGZqMnB6dmx5bFJvVUhta3VLSjl3SkE#gid=0

regards,
Al

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Benoit Claise [[email-masked]]
Sent: Thursday, May 23, 2013 5:45 PM
To: [email-masked]
Cc: Fred Baker
Subject: [pm-dir] Fwd: Re:  Performance metrics doctors generated email

Dear pm-dir,

Regards, Benoit

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Fri, 24 May 2013 04:07:14 +0000

I'm not sure what you're asking for. If by "Fred's script" you mean the script that Benoit runs, have at it. If you mean the script I ran this morning, it's actually two. I have attached a small perl script I wrote some years ago and find useful; I think of it as a "paragraph grep". It's arguments are

get-refs <file> [-nc] [-word]* [word]*
      The file is a text file
      -nc means to observe case; by default it is case-agnostic
      -<word> means that if the word is present in a paragraph, do NOT export the paragraph 
      <word> means that if the word is present in a paragraph, DO export the paragraph 

It basically prints out paragraphs (in the 1-or-more 60-column line sense) that contain one or more of the <words> and none of the -<words>. A word, by the way, may contain an arbitrary amount of white space including line feeds.

With this in hand, I then wrote

#!/bin/csh
foreach draft ($*)
     echo $draft
     echo ' '
     get-refs $draft 'performance metric'
end

It would be simple enough to pipe that into a file and take a diff -c -w against the previous week's version.

> https://docs.google.com/spreadsheet/ccc?key=0AmKrqWIOBsprdGZqMnB6dmx5bFJvVUhta3VLSjl3SkE#gid=0

------------------------------------------------------
8 issues in virtual infrastructure
http://dcrocker.net/#fallacies

---

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Fri, 24 May 2013 08:18:35 -0400

> -----Original Message-----
> From: Fred Baker (fred) [mailto:[email-masked]]
...
> against the previous week's version.

Yes, that's what I was thinking more or less, running on Benoit's host that
generates weekly e-mail to the pm-dir list.

thanks,
Al