Subject: [pm-dir] Fwd: New Version Notification - draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-07.txt

From: Benoit Claise <[email-masked]>
Date: Wed, 23 Oct 2013 15:14:28 +0200

Hi Alan,

Can you please let us know if you're fine with the new version of the draft.
My DISCUSS is at 
https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics/ballot/#benoit-claise
I want to make sure that your PM-DIR feedback is taken into account.
On my side, I believe that the RFC 6390 template is not specific enough. 
For example the metric name doesn't even mention it's specific to RTP. 
Same thing for the metric description.

Regards, Benoit

-------- Original Message --------
Subject: 	New Version Notification - 
draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-07.txt
Date: 	Mon, 30 Sep 2013 23:22:41 -0700
From: 	<[email-masked]>
To: 	<[email-masked]>, 
<[email-masked]>, 
<[email-masked]>, <[email-masked]>, 
<[email-masked]>

A new version (-07) has been submitted for draft-ietf-xrblock-rtcp-xr-discard-rle-metrics:
http://www.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-07.txt

Sub state has been changed to AD Followup from Revised ID Needed

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics/

Diff from previous version:
http://www.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

IETF Secretariat.

.

---

From: Benoit Claise <[email-masked]>
Date: Wed, 23 Oct 2013 16:04:15 +0200

Hi Varun,

I believe that the RFC 6390 is actually important.

Regards, Benoit
> Hi Benoit,
>
> Thanks for the review and catching the error, comments below:
>
> In 
> http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-07
> I can add RTP in the following way in
>   a.  Run-length encoding (RLE) of Discarded RTP Packets Metric
> * Metric Description: Instances of RTP packets discarded over the
>        	    period covered by this report.
> OR, I could remove the RFC6390 template altogether, Alan's comment 
> from his original PM-DIr review email (July 2013)
> suggested that it was not needed, copy-pasting it below:
>> Other than a normative reference to “discard” the definition of this 
>> block does not require an RFC6390 metric template as it refers to a 
>> sufficiently detailed definition in RFC3611.
>
> Which of the above option would be preferred?
>
> In 
> https://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-bytes-discarded-metric-00
> updated template  will be:
>   a.  RTP Payload Bytes Discarded Metric
>         *  Metric Name: RTP Payload Bytes Discarded Metric
>         *  Metric Description: Total number of RTP payload bytes discarded over the
>            period covered by this report.
>
> Cheers,
> Varun
>
> On Oct 23, 2013, at 4:14 PM, Benoit Claise wrote:
>
>> Hi Alan,
>>
>> On my side, I believe that the RFC 6390 template is not specific 
>> enough. For example the metric name doesn't even mention it's 
>> specific to RTP. Same thing for the metric description.
>>
>> Regards, Benoit
>>
>>
>> until the htmlized version and diff are available attools.ietf.org  <http://tools.ietf.org>.
>>
>> IETF Secretariat.
>>
>> .
>>
>>
>>
>

---

From: Varun Singh <[email-masked]>
Date: Wed, 23 Oct 2013 16:45:35 +0300

Hi Benoit,

In http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-07
I can add RTP in the following way in 
 a.  Run-length encoding (RLE) of Discarded RTP Packets Metric
	 	*  Metric Description: Instances of RTP packets discarded over the
      	   period covered by this report.
OR, I could remove the RFC6390 template altogether, Alan's comment from his original PM-DIr review email (July 2013)
suggested that it was not needed, copy-pasting it below:
> Other than a normative reference to “discard” the definition of this block does not require an RFC6390 metric template as it refers to a sufficiently detailed definition in RFC3611.

In https://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-bytes-discarded-metric-00

Cheers,
Varun

On Oct 23, 2013, at 4:14 PM, Benoit Claise wrote:

> My DISCUSS is at https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-discard-rle-metrics/ballot/#benoit-claise
> On my side, I believe that the RFC 6390 template is not specific enough. For example the metric name doesn't even mention it's specific to RTP. Same thing for the metric description.
> 
> Regards, Benoit
> 
> 
> Subject:	New Version Notification - draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-07.txt
> To:	<[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
>

---

From: Alan Clark <[email-masked]>
Date: Wed, 23 Oct 2013 10:17:30 -0400

Hi Benoit

My comments related to RFC 6390 compliance for drafts have largely been that
RFC 6390 must be applied if the draft defines a metric but does not
necessarily need to be applied if the draft simply reports a metric that is
defined elsewhere. The objective should be to make sure that there is a
single RFC 6390 compliant definition of a metric - sometimes having multiple
definitions of the same thing can lead to divergent descriptions and
confusion.

I¹ll review the rle-metrics draft and send comments today

Alan

On 10/23/13 10:04 AM, "Benoit Claise" <[email-masked]> wrote:

>>> Other than a normative reference to ³discard² the definition of this block
>>> does not require an RFC6390 metric template as it refers to a sufficiently
>>> detailed definition in RFC3611.
>>  
>>  
>> 
>>  
>>  
>>> For example the metric name doesn't even mention it's specific to RTP. Same
>>> thing for the metric description.
>>>  
>>>  Regards, Benoit
>>>  
>>> 
>>>  
>>>  From:  <[email-masked]> <mailto:[email-masked]>
>>>  To:  <[email-masked]> <mailto:[email-masked]>
>>> , <[email-masked]>
>>> <mailto:[email-masked]> ,
>>> <[email-masked]> <mailto:[email-masked]> ,
>>> <[email-masked]> <mailto:[email-masked]> ,
>>> <[email-masked]> <mailto:[email-masked]>
>>>  
>>>  
>>> A new version (-07) has been submitted for
>>> draft-ietf-xrblock-rtcp-xr-discard-rle-metrics:
>>> until the htmlized version and diff are available at tools.ietf.org
>>> <http://tools.ietf.org> .
>>> 
>>> IETF Secretariat.
>>> 
>>> .
>>> 
>>>  
>>>  
>>>  
>>>  
>>>  
>>>  
>>>  
>>>  
>>>  
>>>  
>>>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 28 Oct 2013 16:57:28 +0100

Alan, Benoit,

what is the status of this?

Thanks,

Gonzalo

On 23/10/2013 4:17 PM, Alan Clark wrote:
> Hi Benoit
> 
> My comments related to RFC 6390 compliance for drafts have largely been
> that RFC 6390 must be applied if the draft defines a metric but does not
> necessarily need to be applied if the draft simply reports a metric that
> is defined elsewhere. The objective should be to make sure that there is
> a single RFC 6390 compliant definition of a metric - sometimes having
> multiple definitions of the same thing can lead to divergent
> descriptions and confusion.
> 
> I’ll review the rle-metrics draft and send comments today
> 
> Alan
> 
> 
>         OR, I could remove the RFC6390 template altogether, Alan's
>         comment from his original PM-DIr review email (July 2013)
>          
>             Other than a normative reference to “discard” the definition
>             of this block does not require an RFC6390 metric template as
>             it refers to a sufficiently detailed definition in RFC3611.
> 
> 
>          
> 
>          
>          
>              On my side, I believe that the RFC 6390 template is not
>             specific enough. For example the metric name doesn't even
>             mention it's specific to RTP. Same thing for the metric
>             description.
>              
>              Regards, Benoit
>              
> 
>              
>             <mailto:[email-masked]>   
>              To:  <[email-masked]>
>             <mailto:[email-masked]> ,
>             <[email-masked]>
>             <mailto:[email-masked]>
>             , <[email-masked]>
>             <mailto:[email-masked]> ,
>             <mailto:[email-masked]>     
>              
>              
>             until the htmlized version and diff are available at
>             tools.ietf.org <http://tools.ietf.org> .
> 
>             IETF Secretariat.
> 
>             .
> 
>              
>              
>              
>              
>              
>              
>              
>              
>              
>              
>              
>

---

From: Alan Clark <[email-masked]>
Date: Mon, 28 Oct 2013 12:16:27 -0400

Gonzalo

It is waiting for me - and I'll get it done asap

Regards

Alan

On 10/28/13 11:57 AM, "Gonzalo Camarillo" <[email-masked]>
wrote:

>>             Other than a normative reference to ³discard² the definition

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 28 Oct 2013 17:17:05 +0100

Thanks for your quick answer, Alan!

Gonzalo

---

From: Alan Clark <[email-masked]>
Date: Mon, 28 Oct 2013 15:17:13 -0400

Varun

We would like to proliferate the use of RFC 6390 and hence, as this draft
already has a template then I'd recommend keeping it and updating the
wording as you suggested - to include "RTP" in Appendix A in the metric
title, name and description

Regards

Alan

>>>         Which of the above option would be preferred?
https://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-bytes-discarded-metri>>>
c
>>> -00
https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-discard-rle-metr>>>
i
>>> cs/ballot/#benoit-claise
http://www.ietf.org/internet-drafts/draft-ietf-xrblock-rtcp-xr-discard-rle-m>>>
e
>>> trics-07.txt
https://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-discard-rle-metr>>>
i
>>> cs/
http://www.ietf.org/rfcdiff?url2=draft-ietf-xrblock-rtcp-xr-discard-rle-metr>>>
i
>>> cs-07
> _______________________________________________
> pm-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pm-dir

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 28 Oct 2013 20:28:34 +0100

Thanks!

Gonzalo

On 28/10/2013 8:20 PM, Varun Singh wrote:
> Thanks Alan for the review and the clarification.
> I’ll update both the drafts as suggested and submit it on 4th November when the submission reopens.
> 
> Cheers,
> Varun
> 
> On 28 Oct 2013, at 21:17, Alan Clark <[email-masked]> wrote:
> 
>> Varun
>>

---

From: Varun Singh <[email-masked]>
Date: Mon, 28 Oct 2013 21:20:03 +0200

Cheers,
Varun