Subject: [pm-dir] Review of XRBlock RTCP XR Bytes Discarded Metric

From: Vinayak Hegde <[email-masked]>
Date: Sun, 2 Feb 2014 19:34:32 +0530

Draft link :
http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-bytes-discarded-metric-01

Comments:
Conforms to RFC 6390 metric reporting template

In Section 3 you state:

   'E' bit is set to '1' if it reports bytes discarded due to early
   arrival and is set to '0' if it reports bytes discarded due to late
   arrival.  If a duplicate packet is received and discarded, these
   duplicate packets are ignored and not reported.  In case both early
   and late discarded packets shall be reported, two Bytes Discarded
   report blocks MUST be included.

In a measurement it is likely to have both types of discarded packets,
early as well as late arrival, why not just multiplex one BDR block with
both types (use two bits instead of 1 bit) and another 32-bit block for the
number of packets. What has been your experience when doing measurements ?

Thanks
Vinayak

---

From: Varun Singh <[email-masked]>
Date: Sun, 2 Feb 2014 23:52:07 +0200

Hi Vinayak,

Thank you for the review, comments inline

Regards,
Varun

----
http://www.netlab.tkk.fi/~varun

On 2.2.2014, at 16.04, Vinayak Hegde <[email-masked]> wrote:

> Draft link : http://tools.ietf.org/html/draft-ietf-xrblock-rtcp-xr-bytes-discarded-metric-01
> 
> Comments:
> In a measurement it is likely to have both types of discarded packets, early as well as late arrival, why not just multiplex one BDR block with both types (use two bits instead of 1 bit) and another 32-bit block for the number of packets. What has been your experience when doing measurements ?

Depending on the use case and the measurement interval, an endpoint may see both early and late discards. For example in congestion control of real-time video, the feedback is sent often (at max multiples of RTT) and it is unlikely both types of discards would occur simultaneously. For congestion control, we’ve not seen much reason to multiplex the report blocks. As I see it, the main application for this measurement block is reporting overuse when congestion occurs and helps the sender calculate the goodput. 

Is there a specific use-case that would benefit from multiplexed reporting? 

It was discussed in the WG before: brief glance at the archive revealed two mails (search for E-flag or bit):
http://www.ietf.org/mail-archive/web/xrblock/current/msg00550.html
http://www.ietf.org/mail-archive/web/xrblock/current/msg00583.html