Subject: [pm-dir] Fwd: Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)

From: Benoit Claise <[email-masked]>
Date: Thu, 06 Feb 2014 06:08:41 -0800

PM-Dir,

I believe that we need a little bit of consistency regarding the naming 
convention for the perf. metrics.
Specifically because those xrblock perf. metrics should be the basis for 
an IETF registry.
Feedback?

Regards, Benoit

-------- Original Message --------
Subject: 	Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: 
(with DISCUSS)
Date: 	Wed, 5 Feb 2014 22:20:33 -0800
From: 	Benoit Claise <[email-masked]>
To: 	The IESG <[email-masked]>
CC: 	<[email-masked]>, 
<[email-masked]>

Benoit Claise has entered the following ballot position for
draft-ietf-xrblock-rtcp-xr-qoe-13: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-xrblock-rtcp-xr-qoe/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

The metric names in the registry are not specific enough: payload type,
calculation identifier metric, segment type, and potentially MOS. I guess
they should say something about RTP. Let me file this DISCUSS while I
double-check with the performance metric directorate.

.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 7 Feb 2014 10:16:23 -0500

Hi Benoit,
it's not clear what registry you are asking about:

The IANA section of this draft references and existing registry for
RTCP-XR metrics (defined in RFC 3611), which has attribute names
and long-form attribute names for the "MOS Metrics block".

Also, there's a new registry of calculation algorithms defined in
the IANA section:

   o  Initial assignments are as follows:

Name             Name Description                  Reference    Type
=========   ===================================   ==========    ====
P564       ITU-T P.564 Compliant Algorithm        [P.564]        Voice
G107       ITU-T G.107                            [G.107]        Voice
TS101_329  ETSI TS 101 329-5 Annex E              [ETSI]         Voice
JJ201_1    TTC JJ201.1                            [TTC]          Voice
G107_1     ITU-T G.107.1                          [G.107.1]      Voice
P862       ITU-T P.862                            [P.862]        Voice
P862_2     ITU-T P.862.2                          [P.862.2]      Voice
P863       ITU-T P.863                            [P.863]        Voice
P1201_1    ITU-T P.1201.1                     [P.1201.1]      Multimedia
P1201_2    ITU-T P.1201.2                     [P.1201.2]      Multimedia
P1202_1    ITU-T P.1202.1                     [P.1202.1]         Video
P1202_2    ITU-T P.1202.2                     [P.1202.2]         Video

Which one of these, or other naming convention are you talking about?
Al

From: pm-dir [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, February 06, 2014 9:09 AM
To: [email-masked]
Subject: [pm-dir] Fwd: Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)

PM-Dir,

I believe that we need a little bit of consistency regarding the naming convention for the perf. metrics.
Specifically because those xrblock perf. metrics should be the basis for an IETF registry.
Feedback?

Regards, Benoit

-------- Original Message --------
Subject:

Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)

Date:

Wed, 5 Feb 2014 22:20:33 -0800

From:

Benoit Claise <[email-masked]><mailto:[email-masked]>

To:

The IESG <[email-masked]><mailto:[email-masked]>

CC:

<[email-masked]><mailto:[email-masked]>, <[email-masked]><mailto:[email-masked]>

DISCUSS:

.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 10 Feb 2014 21:57:04 -0800

Hi Al,

I meant the different "metric name" entries in Appendix A of the draft.
Qin Wu, in cc, agreed to improve those.
We should avoid collisions with the exist XR block defined metrics.

Regards, Benoit
> *From:*pm-dir [mailto:[email-masked]] *On Behalf Of *Benoit 
> Claise
> *Sent:* Thursday, February 06, 2014 9:09 AM
> *To:* [email-masked]
> *Subject:* [pm-dir] Fwd: Benoit Claise's Discuss on 
> draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)
>
> PM-Dir,
>
> *Subject: *
> *Date: *
> *From: *
> Benoit Claise <[email-masked]> <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> The IESG <[email-masked]> <mailto:[email-masked]>
>
> *CC: *
>
> 	
>
> <[email-masked]> 
> <mailto:[email-masked]>, 
> <mailto:[email-masked]>
>
> Please refer tohttp://www.ietf.org/iesg/statement/discuss-criteria.html

---

From: Qin Wu <[email-masked]>
Date: Tue, 11 Feb 2014 06:06:31 +0000

Hi, Benoit and Al:
Yes, I confirmed to make change to Appendix A of draft-ietf-xrblock-rtcp-xr-qoe. I am not supposed to change calculation algorithm name in this draft.
Here is my proposed change to Appendix( See attached) which I have sent to my authors for confirmation.
Hope this clarify.

Regards!
-Qin
From: Benoit Claise [mailto:[email-masked]]
Sent: Tuesday, February 11, 2014 1:57 PM
To: MORTON, ALFRED C (AL); [email-masked]; Qin Wu
Subject: Re: [pm-dir] Fwd: Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)

Hi Al,

Regards, Benoit
Hi Benoit,

From: pm-dir [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Thursday, February 06, 2014 9:09 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [pm-dir] Fwd: Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)

PM-Dir,

Regards, Benoit

-------- Original Message --------
Subject:

Date:

From:

To:

CC:

DISCUSS:

.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 10 Feb 2014 22:25:02 -0800

Hi Qin,

That works for me.

As a new PM-DIR member and someone deeply involved in XRBLOCK, do I 
guess correctly that you have checked for naming collisions, and also 
some sort of naming consistency in the XRBLOCK metrics?

http://tools.ietf.org/html/draft-claise-ippm-perf-metric-registry-01#section-4 
might help as an inventory as of Oct 2013

Regards, Benoit.
>
> Hi, Benoit and Al:
>
> Yes, I confirmed to make change to Appendix A of 
> draft-ietf-xrblock-rtcp-xr-qoe. I am not supposed to change 
> calculation algorithm name in this draft.
>
> *From:*Benoit Claise [mailto:[email-masked]]
> *Sent:* Tuesday, February 11, 2014 1:57 PM
> *To:* MORTON, ALFRED C (AL); [email-masked]; Qin Wu
> *Subject:* Re: [pm-dir] Fwd: Benoit Claise's Discuss on 
>     *From:*pm-dir [mailto:[email-masked]] *On Behalf Of
>     *Benoit Claise
>     *To:* [email-masked] <mailto:[email-masked]>

---

From: Qin Wu <[email-masked]>
Date: Tue, 11 Feb 2014 06:46:07 +0000

Yes, I have checked that, I will check again to make sure everything is consistent before the update is posted.

Regards!
-Qin
From: pm-dir [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Tuesday, February 11, 2014 2:25 PM
To: Qin Wu; MORTON, ALFRED C (AL); [email-masked]
Subject: Re: [pm-dir] Fwd: Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)

Hi Qin,

That works for me.

As a new PM-DIR member and someone deeply involved in XRBLOCK, do I guess correctly that you have checked for naming collisions, and also some sort of naming consistency in the XRBLOCK metrics?

http://tools.ietf.org/html/draft-claise-ippm-perf-metric-registry-01#section-4 might help as an inventory as of Oct 2013

Regards, Benoit.
Hi, Benoit and Al:

Regards!
-Qin
From: Benoit Claise [mailto:[email-masked]]
Sent: Tuesday, February 11, 2014 1:57 PM
To: MORTON, ALFRED C (AL); [email-masked]<mailto:[email-masked]>; Qin Wu
Subject: Re: [pm-dir] Fwd: Benoit Claise's Discuss on draft-ietf-xrblock-rtcp-xr-qoe-13: (with DISCUSS)

Hi Al,

Regards, Benoit
Hi Benoit,

PM-Dir,

Regards, Benoit

-------- Original Message --------
Subject:

Date:

From:

To:

CC:

DISCUSS:

.