Subject: [pm-dir] Review of draft-ietf-xrblock-rtcp-xr-psi-decodability

From: Brian Trammell <[email-masked]>
Date: Wed, 28 May 2014 14:39:36 +0200

Greetings, all,

I've reviewed draft-ietf-xrblock-rtcp-xr-psi-decodability for 6390 compliance.

The document defines the MPEG2 TS PSI Decodability Metrics Block, which creates an XRBLOCK for reporting error counters. The description of the events defined in an external document (ETSI TR 101 290, "Digital Video Broadcasting (DVB); Measurement guidelines for DVB systems"). The definitions of the error counters seem to be specific enough to be implementable, especially within the context of this external reference.

As they pertain to the reporting of raw error counters, these are not metrics per se, and the 6390 template would not appear to apply. The block may be misnamed (as in 6390 terminology, these aren't Decodability Metrics, rather Decode Error Counters); it's not clear to me if this name for the XRBLOCK was chosen for historical reasons.

Best regards,

Brian

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 28 May 2014 10:43:39 -0400

Thanks Brian. Forwarding to authors and ADs,
Al

> -----Original Message-----
> From: pm-dir [mailto:[email-masked]] On Behalf Of Brian Trammell
> Sent: Wednesday, May 28, 2014 8:40 AM
> To: [email-masked]
> Subject: [pm-dir] Review of draft-ietf-xrblock-rtcp-xr-psi-decodability
> 
> Greetings, all,
> 
> The document defines the MPEG2 TS PSI Decodability Metrics Block, which
> creates an XRBLOCK for reporting error counters. The description of the
> events defined in an external document (ETSI TR 101 290, "Digital Video
> Broadcasting (DVB); Measurement guidelines for DVB systems"). The
> definitions of the error counters seem to be specific enough to be
> implementable, especially within the context of this external reference.
> 
> As they pertain to the reporting of raw error counters, these are not
> metrics per se, and the 6390 template would not appear to apply. The block
> may be misnamed (as in 6390 terminology, these aren't Decodability
> Metrics, rather Decode Error Counters); it's not clear to me if this name
> for the XRBLOCK was chosen for historical reasons.
> 
> Best regards,
> 
> Brian

---

From: Qin Wu <[email-masked]>
Date: Thu, 29 May 2014 01:48:32 +0000

Hi:
Thanks Brian for your review,
This draft defines metrics block for the metrics that are not covered by RFC6990.
Similar to RFC6990, the metrics included in the metrics block are existing metrics defined in ETSI TR 101290, that's why 
RFC6390 template doesn't apply.

As we described in applicability section, we hope
these metrics can be applicable to any type of RTP application that uses
the MPEG2 TS standard format for multimedia data; for example, MPEG4
over MPEG2 TS over RTP.

Also I believe metrics has broad meaning and can be any parameter that can be measured related to performance.
I think we can change the name of block as you suggested to make it more explicit.
Hope this addresses your comment.

Regards!
-Qin
-----邮件原件-----
发件人: pm-dir [mailto:[email-masked]] 代表 MORTON, ALFRED C (AL)
发送时间: 2014年5月28日 22:44
收件人: Brian Trammell; [email-masked]
抄送: Benoit Claise; [email-masked]; [email-masked]
主题: Re: [pm-dir] Review of draft-ietf-xrblock-rtcp-xr-psi-decodability

Thanks Brian. Forwarding to authors and ADs, Al

> Subject: [pm-dir] Review of 
> draft-ietf-xrblock-rtcp-xr-psi-decodability
> 
> Greetings, all,
> 
> The document defines the MPEG2 TS PSI Decodability Metrics Block, 
> which creates an XRBLOCK for reporting error counters. The description 
> of the events defined in an external document (ETSI TR 101 290, 
> "Digital Video Broadcasting (DVB); Measurement guidelines for DVB 
> systems"). The definitions of the error counters seem to be specific 
> enough to be implementable, especially within the context of this external reference.
> 
> metrics per se, and the 6390 template would not appear to apply. The 
> block may be misnamed (as in 6390 terminology, these aren't 
> Decodability Metrics, rather Decode Error Counters); it's not clear to 
> me if this name for the XRBLOCK was chosen for historical reasons.
> 
> Best regards,
> 
> Brian

_______________________________________________
pm-dir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pm-dir