Subject: RE: WG Review: Transparent Interconnection of Lots of Links (trill)

From: "Susan Hares" <[email-masked]>
Date: Mon, 20 Jun 2005 15:11:15 -0400

Eric and Tony:

See my comments about Wireless Mesh proposal an Wi-Mesh alliance I'm a
part of submitted 6/15/05 to the 802.11s.

Radia or others may know more about 802.1 since they have more history
with IEEE.

Sue

  _____  

From: Eric W Gray [mailto:[email-masked]] 
Sent: Monday, June 20, 2005 2:45 PM
To: Tony Li
Cc: Susan Hares; Alex Zinin; [email-masked];
[email-masked]; [email-masked]
Subject: Re: WG Review: Transparent Interconnection of Lots of Links
(trill)

Tony,

    No disagreement from me.  Perhaps the next obvious question is - has
anyone taken this to the
IEEE?

--
Eric

Tony Li wrote:

In other instances, when proposals were IEEE'ish, we were directed to
take them to the IEEE.
 
Tony

Eric W Gray wrote:

	Sue,
	 
	    The trouble with obvious questions is that everybody assumes
they've
	been  asked already.
	Now this question has been asked at least once, for sure.  :-)
	 
	    From the charter attached in Alex's previous message, the
purpose is
	to "route" Ethernet
	Frames. Quote:
	 
	The TRILL WG will design a solution for shortest-path frame
routing in
	multi-hop IEEE 802.1 Ethernet networks with arbitrary
topologies,
	using the link-state routing protocol technology.
	 
	Since it is clear that at least some people are not satisfied
with the
	802.1 approach (perhaps
	because of the relative inefficiency associated with completely
unused
	high capacity links), I
	assume you mean to ask "why is it not IEEE" - rather than "why
is it not
	802.1".
	 
	    I believe that is a very good question.  I know of no very
good
	reason why the IEEE might
	not specify how to use an OSPF-like routing protocol to fulfill
the role
	previously handled by
	Spanning Tree Protocol. Perhaps the only reason why it is being
	discussed here is that it might
	be better - for implementers - if the protocol used was more
than
	"OSPF-like."
	 
	--
	Eric
	 
	[email-masked] wrote:

		Why are we doing this?  Is it IP or is it Frames?
		If it is Frames, why is it not 802.1 - etc? 
		 
		Sue Hares
		 
		-----Original Message-----
		From: Alex Zinin [mailto:[email-masked]] 
		Sent: Thursday, June 16, 2005 10:00 PM
		To: [email-masked]
		Cc: [email-masked]; [email-masked]
		Subject: Fwd: WG Review: Transparent Interconnection of
Lots of Links
		(trill)
		 
		Since the second BOF on this topic was inconclusive
regarding community
		support, the IESG is reevaluating the community
consensus on whether a
		WG
		should be formed or not.
		 
		If you have input on this, positive or negative, please
send it to
		[email-masked].

	
------------------------------------------------------------------------
	 
	_______________________________________________
	routing-discussion mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Tony Li <[email-masked]>
Date: Mon, 20 Jun 2005 13:01:00 -0700

Sue,

Please allow me to be a bit more direct...

What part of this should be in the IETF?  The IESG has made it quite
clear that they do not want a turf battle with the IEEE.

There seems like a clear separation of layers here and this is still L2
work.  As such, it would seem consistent for this should go over to
IEEE, even if it is  borrowing heavily from IETF technology.

Tony

Susan Hares wrote:
> Eric and Tony:
> 
>  
> 
> See my comments about Wireless Mesh proposal an Wi-Mesh alliance I’m a
> *From:* Eric W Gray [mailto:[email-masked]]
> *Sent:* Monday, June 20, 2005 2:45 PM
> *To:* Tony Li
> *Cc:* Susan Hares; Alex Zinin; [email-masked];
> *Subject:* Re: WG Review: Transparent Interconnection of Lots of Links
> (trill)
> 
>  
> 
> Tony,
> 
>>    The trouble with obvious questions is that everybody assumes they've
>>
>>been  asked already.
>>
>>    From the charter attached in Alex's previous message, the purpose is
>>
>>to "route" Ethernet
>>
>>Frames. Quote:
>>
>> 
>>
>>The TRILL WG will design a solution for shortest-path frame routing in
>>
>>multi-hop IEEE 802.1 Ethernet networks with arbitrary topologies,
>>
>>Since it is clear that at least some people are not satisfied with the
>>
>>802.1 approach (perhaps
>>
>>because of the relative inefficiency associated with completely unused
>>
>>high capacity links), I
>>
>>assume you mean to ask "why is it not IEEE" - rather than "why is it not
>>
>>802.1".
>>
>> 
>>
>>    I believe that is a very good question.  I know of no very good
>>
>>not specify how to use an OSPF-like routing protocol to fulfill the role
>>
>>previously handled by
>>
>>be better - for implementers - if the protocol used was more than
>>
>>"OSPF-like."
>>
>> 
>>
>>--
>>
>>Eric
>>
>> 
>>
>>[email-masked] <mailto:[email-masked]> wrote:
>>
>> 
>>
>>    
>>
>>>To: [email-masked] <mailto:[email-masked]>
>>>
>>>Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
>>>
>>>Subject: Fwd: WG Review: Transparent Interconnection of Lots of Links
>>>
>>>(trill)
>>>
>>> 
>>>
>>>Since the second BOF on this topic was inconclusive regarding community
>>>
>>>support, the IESG is reevaluating the community consensus on whether a
>>>
>>>WG
>>>
>>>should be formed or not.
>>>
>>> 
>>>
>>>If you have input on this, positive or negative, please send it to
>>>
>>>[email-masked] <mailto:[email-masked]>.
>>>
>>> 
>>>
>>> 
>>>
>>> 
>>>
>>>      
>>
>>[email-masked] <mailto:[email-masked]>
>>

---

From: Radia Perlman <[email-masked]>
Date: Mon, 20 Jun 2005 13:06:24 -0700

Yes. This has been discussed with IEEE. I even gave a tutorial there on 
TRILL at the
last IEEE, both at a general tutorial slot and at the mesh group 
(invited by the chair
of that group, Don Eastlake). It got a very friendly reception, by the way.

There are some people in the wireless mesh group who
have since mentioned to me that they are interested
in proposing a solution like this within the mesh group.
And that would be good. But this technology is not specific to any 
particular
layer 2 technology, and certainly not limited to wireless. So it should 
be standardized in something
that is layer 2 agnostic. It could also be used in other places, of 
course, and if multiple WGs are
working on similar things, it is good if they cooperate and liase (is 
that a word?) so that technology
works well together, and even better yet, if it converges towards the 
same design. I believe
the intention of all concerned is that all the WGs that might be 
interested and might
be helpful have liason relationships.

Radia

---

From: Radia Perlman <[email-masked]>
Date: Mon, 20 Jun 2005 13:12:27 -0700

Oh and one other thing...things like proxy ND and passing around (layer 
3, layer 2) pairs to
facilitate it, are something else that are not specific to any 
particular layer 2 technology.

Radia

Radia Perlman wrote:

> Yes. This has been discussed with IEEE. I even gave a tutorial there 
> on TRILL at the
> layer 2 technology, and certainly not limited to wireless. So it 
> should be standardized in something
>> See my comments about Wireless Mesh proposal an Wi-Mesh alliance I’m 
>> a part of submitted 6/15/05 to the 802.11s.
>>
>> Radia or others may know more about 802.1 since they have more 
>> history with IEEE.
>>
>> Sue
>>
>> *Subject:* Re: WG Review: Transparent Interconnection of Lots of 
>> Links (trill)
>>
>> Tony,
>>

---

From: Scott W Brim <[email-masked]>
Date: Mon, 20 Jun 2005 16:27:57 -0400

> IEEE, even if it is  borrowing heavily from IETF technology.

Yes.  

In fact that borrowing could be a good thing, and doesn't influence
who holds responsibility for the work area.