Subject: RE: IESG soliciting comments on use of BGP for VPN

From: Jeff Parker <[email-masked]>
Date: Thu, 29 May 2003 17:07:13 -0400

>  The IESG is currently considering the following questions which
>  we would like to solicit comments on:
> 
>   1. What is the line between appropriate and inappropriate use
>      of routing protocols in general, and BGP in particular.
> 
>   2. Whether the specific approaches described in the documents
>      above represent an appropriate use of BGP.
> 
>   3. If the answer to question 2 above is negative, what alternative
>      mechanisms could be used.
 
Mike Shand proposed an answer for #1.

> Where is the line between appropriate and inappropriate use?

> .. anything which was related to the computation of routing 
> information (i.e. that is used to influence the FIB) is fair 
> game, BUT (and note the shouting), it MUST be subject to 
> analysis to show that the volume and frequency of the 
> information will stay within reasonable bounds.  

The document draft-kompella-ppvpn-vpls-02.txt seems to
meet both clauses: it affects forwarding, and given 
some assumptions about the rate of joining and leaving,
the refresh rate could be kept in check.  

It does seem odd to be using NLRI that does not match 
the expectations of other BGP speakers.  It seems to
me that the actions when updating VLAN membership
and merging routes introduces new behaviors which 
are not spelled out.  In fact, there is a great deal
of behavior that is not described here.  A full
solution would need to agree on the details of 
signaling the tunnels used to distribute data,
decide on the encapsulation, etc.   It isn't clear
to me if this is described elsewhere, or if this
is a private matter between consenting adults.  

Clearly, if a new use of an old protocol would

   A) Confuse other speakers of the protocol
   B) Require new behaviors of old speakers

then the change would be harmful.  I don't see
evidence of either, and fall back to trusting 
the authors' supperior knowledge of the protocol.  

The draft suggests that this information would be 
exchanged within an AS.  What would happen should
this leaks to an E-BGP peer, who might have clients 
using similar NLRIs?  Since there are multiple possible
encapsulations and signaling protocols, this would
be a fruitful source of misunderstandings.  

- jeff parker

---

From: Alex Zinin <[email-masked]>
Date: Thu, 29 May 2003 16:13:39 -0700

Jeff,

> the refresh rate could be kept in check.  

Hmmm... I got the impression that the mechanism described there
carried exactly zero bit of routing information. It affects
data plane, but not the IP routing data plane...

> are not spelled out.

Is the best-path algo even applicable there? I.e., aren't they
interested in just the fact of the presence of a piece of info, rather
than the best path to it?

> In fact, there is a great deal

The WG should be reusing tunnels defined in PWE3.

> evidence of either, and

Hmmm... what do you mean in B above? To explain a bit more, supporting
new AFI/SAFI and/or BGP attributes always means modifying the BGP
code.

> fall back to trusting 

To what extent? Would you trust as much as not asking
them to show up before IDR?

Thanks.

Alex