Subject: RE: Quality of document review in RTG WGs

From: Jeff Parker <[email-masked]>
Date: Tue, 25 Feb 2003 12:31:20 -0500

> From the relatively little time I've spent in IETF, 
> people seem willing to look at stuff as it initially 
> comes out.   

Well said.  And your notes on motivation seem
spot on.  

But as well as good intentions, people need time.  
In this market, I suspect fewer people are being 
paid to spend a significant amount of time working 
on standards.

So what can be done?  I think nagging works, and 
selective nagging works best of all.  That is, 
when I hear folks complaining that no one is 
reviewing the TE MIB, the comments rolls off
like water down a duck's back.  When something 
I have worked on needs review, comments to the
list give me a twing.  When an AD writes me a
note, I might get busy.  

- jeff parker

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 25 Feb 2003 13:10:27 -0500

> But as well as good intentions, people need time.  

Another question to ask in this regard:  Is there some way we can
help individual working groups churn less?

What seems to have been having some success in the IDR WG with
regards to the FSM issues has been something along the following:
o Standardization Issues are brought up
o A willing individual tracks the issues and provides an issue summary
  list.  This allows issues to be tracked and more importantly,
  the relevant points.  The issues list maintainer operates as
  an editor and librarian to keep relevant points associated together
  along with their consensus status.
o People who wish to comment on individual items can do so.
o Rinse. Repeat.  Hopefully we get consensus.

Thus, my observation is that our problem isn't so much finding willing
people, its finding a way to make them more effective.
(oh dear... I feel my hair growing pointy...)
Thus, this is an information management issue more than anything else.

Some speculation:
What we seem to need is a mechanism for automate or help automate the
excellent job that Andrew has been doing for IDR.  This mechanism should
probably be invoked in the following circumstances:
o We are working through nitpicks to try to close out issues for 
  standardization.  This is late in the process.
o Earlier in process, when there are items of specific contention.

The properties of this mechanism would include:
o Open issues
o Thread comments specifically related to the issue.
o Allow for moderation/editorial clarification.  This involves librarian
  style skills.
o Track consensus.
o Reports

This seems to be a combination of something like slashdot and a bug
reporting tool.  The moderator/WG chairs/AD's would be the ones
to introduce an issue to be tracked.  Anyone should be able to
contribute, but the moderator should be able to declare how "focused"
the contribution is.

The gotcha is to integrate this with our existing mailing list 
discussion mechanism.

</speculation type="random">

-- 
Jeff Haas 
NextHop Technologies

---

From: Alex Zinin <[email-masked]>
Date: Wed, 26 Feb 2003 20:56:44 -0800

I agree, the issue list approach helps quite a bit,
especially when a big number of questions need resolution.
We tried it first in isis-update where Jeff P lead the crew,
and we're now using the same method in IDR.

Let's chat about this more in SF.
BTW, we should have a directorate meeting there, which I
will send a separate message about for folks who're skipping
this thread or filtering me ;-p

-- 
Alex

---

From: Bill Fenner <[email-masked]>
Date: Wed, 5 Mar 2003 14:25:36 -0800

>reporting tool.

rtg.ietf.org has an as-yet unused forum section.  I vaguely envisioned
the possibility of having a "forum" per document.  The biggest question
is how the forums relate to archived WG mailing lists.

http://rtg.ietf.org/modules.php?op=modload&name=Forums&file=viewforum&forum=12

(The second biggest question is: exactly how buggy is this stuff?)

  Bill