Subject: Site-Locals

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Mon, 7 Apr 2003 13:29:01 -0400 (EDT)

There seems to be a lot of emotion here, and I will admit
I have not been following the arguments. So I don't even
have an opinion, since I don't do that until I think I
understand all the arguments. Could someone summarize
what the arguments are on each side? I'm a little afraid that
"consensus" will never be really reached if people on the
other side do not feel their arguments were listened to and
understood. This is a fairly contentious issue and will benefit
from a document that explains what "site locals" are, and
what the arguments were on each side. Otherwise, this will
keep coming up, it will cause undue divisiveness, etc.

I will start, without doing my homework (reading the mailing list),
but just to hopefully inspire someone who has been following it
to write a real summary.
***************
1) What are site locals? These are IPv6 addresses that are not
globally administered, and therefore not guaranteed to be globally
unique.

2) How would you use them? You'd use them purely locally, or through
a NAT, if a site-local-addressed node wishes to communicate outside
its "site"

3) Why people think they are useful:
    . security: things are more secure if the resources on your own
       network are not directly addressable from outside
    . ease of deployment: you don't need to first obtain globally assigned
       addresses (perhaps this is a cost issue to if addresses aren't free)
       
3a) Counterarguments to 3)
    . security needs to be cryptographic. This is only the perception of
       security (though sometimes the perception of security sells)

4) Why people think they are bad:
    . confusion can exist about what a "site" is. You can have two locally
       addressed sites, merge them, and then have duplicate addresses
    . this will mean that NATs will still exist, and protocols will not
       be able to use IP addresses as endpoint identifiers
    . you need to make sure your border routers don't allow anything
       with site-locals to escape, otherwise confusion will exist

Radia

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 11 Apr 2003 10:23:44 -0400

On Mon, Apr 07, 2003 at 01:29:01PM -0400, Radia Perlman - Boston Center for Networking wrote:
> I have not been following the arguments.

I'm behind in my e-mail, so apologies if this has been noted before.
I would like to draw the directorate's attention to:
http://www.ietf.org/internet-drafts/draft-hain-ipv6-sitelocal-00.txt

-- 
Jeff Haas 
NextHop Technologies