Subject: Re: Draft L1VPN Charter

From: [email-masked]
Date: Wed, 4 May 2005 14:10:25 +0200

alex, all,

see in-line for comments

> Layer 1 Virtual Private Networks (l1vpn)
>
> Last Modified: 2005-01-25

< Last Modified: 2005-01-25
> Last Modified: 2005-05-04

> Chair(s):
>  TBD
>  TBD
>
> Routing Area Director(s):
> Bill Fenner <[email-masked]>
> Alex Zinin <[email-masked]>
>
> Routing Area Advisor:
> Alex Zinin <[email-masked]>
>
> Technical Advisor(s):
>
> Mailing Lists:
> General Discussion: [email-masked]
> To Subscribe: https://www1.ietf.org/mailman/listinfo/l1vpn
> Archive: http://www.ietf.org/mail-archive/web/l1vpn/index.html
>
> Description of Working Group:
>
> L1VPN Working Group's task is to specify mechanisms necessary for
> providing a VPN service over a GMPLS transport network.
>
> The following two service models will be addressed:
>
>  1. Basic mode: the CE-PE interface's functional repertoire is limited to
>     path setup signalling only. The GMPLS network is not involved in
>     distribution of user's routing information.

in this base model, VPN membership information exchange between PE's (what
is referred to as CE reachability) is to be provided (the CE-PE link
properties are to be considered as improvement); the difference wrt to the
enhanced mode
described here below (point 2) is that this information does not cross the
CE-PE boundary

in the base mode one would assume this information is manually registered
at PEs and in the enhanced mode "registration" would be provided through
the routing protocol running between CE-PE boundary

>  2. Enhanced mode: the CE-PE interface provides the signaling
capabilities
>     as in the Basic mode, plus permits utilization of the provider's
control
>     plane for distribution of user's routing information (e.g. similar to
>     the MPLS/BGP model).
>
> The WG will work on the following items:
>
>  1. Specification of the L1VPN user-to-network interface (UNI) basic
mode,
>     including both CE and PE functionality.
>
>  2. Specification of the L1VPN node-to-node interface (NNI) basic mode.
>
>  3. MIB modules and/or extensions required for UNI and NNI basic mode.
>
>  4. Specification of L1VPN UNI enhanced mode.
>
>  5. Specification of L1VPN NNI enhanced mode.
>
>  6. MIB modules and/or extensions required for UNI and NNI enhanced mode.
>
> Protocol extensions required for L1VPN will be done in cooperation with
> CCAMP, OSPF, IS-IS, IDR, and other WGs where necessary.
>
> Milestones:
>
>  Sep 05 Submit first Internet Drafts of UNI and NNI basic mode
>         specifications
>  Dec 05 Submit first Internet Drafts of MIB modules for UNI and NNI basic
>         mode
>  Jun 06 Submit UNI and NNI basic mode specifications to IESG for
>         publication as Proposed Standard
>  Jun 06 Submit first Internet Drafts of UNI and NNI enhanced mode
>         specifications
>  Aug 06 Submit MIB modules for UNI and NNI basic mode to IESG for
>         publication as Proposed Standard
>  Dec 06 Submit UNI and NNI enhanced mode specifications to IESG for
>         publication as Proposed Standard
>  Aug 06 Submit MIB modules for UNI and NNI enhanced mode to IESG for
>         publication as Proposed Standard

Aug 07 ?

---

From: Alex Zinin <[email-masked]>
Date: Wed, 4 May 2005 15:36:01 -0700

Dimitri,

> the routing protocol running between CE-PE boundary

Not clear to me that the text above should be changed--the PEs will have
to exchange whatever information they will have to exchange to make the
thing work.

> Aug 07 ?

ok

Alex