Subject: AD-review comments on draft-ietf-mpls-nodeid-subobject-02.txt

From: Alex Zinin <[email-masked]>
Date: Thu, 25 Mar 2004 13:58:51 -0800

Folks-

 Please find below my comments on this document.

 Substantial:

   In section 3, in the following para--

   > An implementation MAY either decide to support of one the following
   > options:

   --not clear language and not clear what the "MAY" specifies.
   There should be a description of what implementation supporting this
   spec MUST do so that other nodes can leverage that.

 Editorial:

  - poor general formatting, affects readability, please fix

  - Section 1 "Terminology":
      "CSPF" defined, but not used
      ditto for "NHOP bypass tunnel"
      ditto for "NNHOP bypass tunnel"

  - Section 2:

      The illustration is not captioned, though references to Figure 1 are
      made in the document.

  - Section 3. Non-ASCII characters in the following para:
 >
 > As mentioned above, the limitation that we need to address is the
 > generality of the contents of the RRO IPv4 and IPv6 subobjects, as
 > defined in [RSVP-TE].[RFC3209] defines the IPv4 and IPv6 RRO subobjects
 > along with two flags (namely the (Local Protection Available÷ and
 > (Local protection in use÷ bits). Moreover, other bits have been
 > specified in [FAST-REROUTE] and [SOFT-PREEMPTION].

 please check throughout the document.

 > Authors' Address:

 Should be "Addresses"

Alex

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Thu, 25 Mar 2004 18:24:24 -0500

Thanks a lot Alex: I'll quickly address the comments and post another revision.

thanks.

JP.