Subject: Other pieces of the MT-routing "puzzle"?

From: Alex Zinin <[email-masked]>
Date: Thu, 25 Mar 2004 18:34:59 -0800

RTG-DIR folks-

 So we have MT extensions to IS-IS, and a draft for OSPF has been recently
 published.

 One of my concerns with MT-ISIS a while back was the situation where an
 interface belongs to more than one MT. In this case the association between an
 incoming packet and the FIB to look in is not obvious, and both drafts are
 silent about it (which is sort of ok given that they describe the control part
 of the story). Management is supposed to ensure consistent configuration
 among MT routers to avoid loops and black holes, but there is a potentially
 unlimited number of ways to mux/demux MTs on a link, and it seems that defining
 a few IETF standards for this would help interoperability...

 In other words, STD-wise, we've been operating in a single-MT environment.
 What we're seeing is the RP-related part of the story, and it seems that
 we need the encaps/forwarding part of it and (possibly) the overarching
 architecture.

 Opinions?

-- 
Alex

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 26 Mar 2004 17:46:43 +0100

Alex Zinin wrote:

> interface belongs to more than one MT.
>
> In this case the association between an
> of the story). 
The problem space has been clasified in mt-isis draft version #6, 
section 12 more than a year
ago.

    --- tony

---

From: Alex Zinin <[email-masked]>
Date: Fri, 26 Mar 2004 09:04:44 -0800

> section 12 more than a year

It was apparently a long time ago when I read this draft.

Now that I look at it, you're right, the document indeed classifies
the problem space. Using the draft's words, my general sentiment
is whether this--

> 12.2.2. Multiple MTs share an interface with overlapping addresses
...
>     The generic approach of packet to multiple MT RIB mapping over
>     the same inbound interface is outside the scope of this draft.

--should be addressed.

Alex

---

From: Alex Zinin <[email-masked]>
Date: Mon, 5 Apr 2004 14:47:45 -0700

More opinions on this?

-- 
Alex
http://www.psg.com/~zinin/

---

From: Alex Zinin <[email-masked]>
Date: Fri, 16 Apr 2004 16:50:22 -0700

We would be interested in knowing what ops-dir people think about the need to
defining the enaps/forwarding part and the overall framework of MT routing. For
the control part of it, please see the following drafts:

http://www.ietf.org/proceedings/03nov/I-D/draft-ietf-isis-wg-multi-topology-06.txt
http://www.ietf.org/internet-drafts/draft-psenak-mt-ospf-00.txt

To correct my message below, the isis draft is not silent about it, but neither
of the drafts defines a mandatory to implement mechanism.

Opinions appreciated.

This is a forwarded message
From: Alex Zinin <[email-masked]>
To: [email-masked]
Cc: 
Date: Thursday, March 25, 2004, 7:34:59 PM
Subject: Other pieces of the MT-routing "puzzle"?

===8<==============Original message text===============
RTG-DIR folks-

 Opinions?

-- 
Alex

===8<===========End of original message text===========

---

From: Pekka Savola <[email-masked]>
Date: Thu, 29 Apr 2004 19:28:00 +0300 (EEST)

Hi,

A delayed response...

> of the drafts defines a mandatory to implement mechanism.

Let me try to understand your concern: you're concerned of the 
multi-topology model where the topology the packet belongs to is not 
obvious  -- that is, if you have an IPv6 topology and and IPv4 
topology that would be fine, but having two different IPv4 
topologies would be problematic?

If so, I share this concern and quite honestly I think 
multi-topologies should be restricting to the very obvious cases only: 
v4 and v6.  Maybe unicast/multicast separation would be possible as 
well, but I'm not sure that's necessary, good idea or obvious.

Note that IS-IS networks which have been v4-only have deployed
dual-stack IS-IS with a single topology, so MT-ISIS is not strictly
necessary even with v4/v6 transition; it may just help in the process,
if the operator does not have to plan the upgrade cycle as carefully.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings