Subject: Comments draft-ietf-isis-igp-p2p-over-lan-01.txt

From: Jeff Parker <[email-masked]>
Date: Thu, 20 Mar 2003 14:09:24 -0500

> The draft is well written, and solves a real problem. 
>
> - jeff parker

Having my questions sorted out, here are some nits.  

0) Use of 'ISIS' rather than 'IS-IS' throughout.  

1) Page 2 "flooding of link-state information"
"flooding link-state information" sounds better to me.  

2) Page 2  
"if there are more than two routers on the LAN media, [using DIS is better
than a full mesh]"

Isn't the break-even point above three?  With three routers, the LAN version
has 3 x 2 directed links, as does the p2p scheme, but the LAN version has an
additional PNode LSP, so the p2p scheme is still better.

3) Page 6, line 1.  
Section 4 ("Broadcast/multicast/proprietary") in 4.4 has a heading, but no
body, and thus looks like an error rather than a complete thought.  Add
something, even something as short as:

"Other schemes include using a broadcast or multicast MAC address to forward
packets, or proprietary schemes to forward packets."

4) Page 6, section 6, first line.
"There is obvious advantage to use of this extension..."  It is always hard
to know what others find obvious.  
At the start of the second paragraph of the section, there is thumbnail
recap of the advantages.  Perhaps this sentence could be moved to the start
of the section and the assertion dropped.  

5) Section 6, first paragraph
"The scalability impact is less of a concern..."
The phrase is ambiguous, as we are contrasting two scheme, each of which has
scaling advantages in some situations.  Further, 'impact' could mean
'increase' or 'decrease'.   If pressed, I would guess that this sentence
means 
"If all the vLANs are withing a single OSPF area or IS-IS level, there is no
particular advantage to using this scheme."

- jeff parker

---

From: Naiming Shen <[email-masked]>
Date: Fri, 21 Mar 2003 11:44:44 -0800

Jeff,

thanks for the comment. more inline.

 ]  
 ] > The draft is well written, and solves a real problem. 
 ] >
 ] > - jeff parker
 ] 
 ] Having my questions sorted out, here are some nits.  
 ] 
 ] 0) Use of 'ISIS' rather than 'IS-IS' throughout.  
 ] 
 ] 1) Page 2 "flooding of link-state information"
 ] "flooding link-state information" sounds better to me.  
 ] 
 ] 2) Page 2  
 ] "if there are more than two routers on the LAN media, [using DIS is better
 ] than a full mesh]"
 ] 
 ] Isn't the break-even point above three?  With three routers, the LAN version
 ] has 3 x 2 directed links, as does the p2p scheme, but the LAN version has an
 ] additional PNode LSP, so the p2p scheme is still better.

Well, this is not meant to count exact nodes on a LAN for the benefits.
This scheme is only meant for two nodes on a LAN/vLAN. if you have more
than two nodes:

 - you have to introduce vLAN into the picture
 - if you have three nodes, then it's possible also to have the 4th node,
   and 5th node later on, etc. so if the LAN/vLAN is not meant to use
   by only two nodes(in the case of back-to-back ethernet cabling, for
   example), then operators probably should not be bothered with this
   scheme.

 ] 
 ] 
 ] 3) Page 6, line 1.  
 ] Section 4 ("Broadcast/multicast/proprietary") in 4.4 has a heading, but no
 ] body, and thus looks like an error rather than a complete thought.  Add
 ] something, even something as short as:
 ] 
 ] "Other schemes include using a broadcast or multicast MAC address to forward
 ] packets, or proprietary schemes to forward packets."
 ] 
 ] 
 ] 4) Page 6, section 6, first line.
 ] "There is obvious advantage to use of this extension..."  It is always hard
 ] to know what others find obvious.  
 ] At the start of the second paragraph of the section, there is thumbnail
 ] recap of the advantages.  Perhaps this sentence could be moved to the start
 ] of the section and the assertion dropped.  
 ] 
 ] 
 ] 5) Section 6, first paragraph
 ] "The scalability impact is less of a concern..."
 ] The phrase is ambiguous, as we are contrasting two scheme, each of which has
 ] scaling advantages in some situations.  Further, 'impact' could mean
 ] 'increase' or 'decrease'.   If pressed, I would guess that this sentence
 ] means 
 ] "If all the vLANs are withing a single OSPF area or IS-IS level, there is no
 ] particular advantage to using this scheme."
 ] 

the above sentence didn't translate into the original intention of the
paragraph. it was meant to say that:

   if people are running hierarchical level/area, then the link-state
   database may not be very large, such the operator may decide to
   run full-mesh p2p over the LAN if there is some other compelling
   reasons.

one of the reason to run full-mesh p2p circuits over the LAN media
would be to have fine control of link cost to each neighbor rather
than use the single cost for all the neighbors over the LAN.

we can change this into: "The negative scalability impact is ..."...

thanks.

 ] - jeff parker

- Naiming