Subject: [RTG-DIR] RtgDir review: draft-templin-intarea-seal-51.txt

From: Alia Atlas <[email-masked]>
Date: Mon, 18 Feb 2013 16:52:29 +0000

Hello,
I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://www.ietf.org/iesg/directorate/routing.html
Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.
Document: draft-templin-intarea-seal-51.txt
Reviewer: Alia Atlas
Review Date: 18-Feb-2013
IETF LC End Date: 20-Feb-2013
Intended Status: Informational
Summary:
   This document is basically ready for publication, but has nits that should be considered prior to publication

Comments:
   The draft is generally very well written.  There are a couple things that could use a quick explanation, but it is basically very clear.

Major Issues:
   This draft is targeted at Informational, but it is defining new functionality, a new protocol, and is making obsolete an Experimental draft.  I think that Experimental would be a more accurate target.

Minor Issues:
1)      This document talks about re-encapsulation without describing it or defining when it might be needed.  Even a brief sentence in terminology or where re-encapsulation is first introduced would be useful to explain that a segmented tunnel can exist and why - or why segmentation needs to be understood by SEAL - as opposed to doing a decap/encap at the ETE/ITE?

Nits:
1)      Confusing typo:  Last paragraph of p.25 says:  "For SEAL packets, the ITE performs any necessary IP reassembly..."  I think this should be the ETE not the ITE.

Regards,
Alia

---

From: "Fred L. Templin" <[email-masked]>
Date: Tue, 19 Feb 2013 10:23:05 -0800 (PST)

Hello Alia,

Thank you very much for your comments, and please see below for proposed
resolutions:

Fred
[email-masked]

________________________________
> From: Alia Atlas <[email-masked]>
>To: "[email-masked]" <[email-masked]> 
>Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
>Sent: Monday, February 18, 2013 8:52 AM
>Subject: RtgDir review: draft-templin-intarea-seal-51.txt
> 
>
> 
>Hello,
>I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes
on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see
http://www.ietf.org/iesg/directorate/routing.html
>    1. This document talks about re-encapsulation without describing it or defining when it might be needed.  Even a brief sentence in terminology or where re-encapsulation is first introduced would be useful to explain that a segmented tunnel can exist and why
– or why segmentation needs to be understood by SEAL – as opposed to doing a decap/encap at the ETE/ITE?

Section 5.2 ("SEAL Model of Operation") is the first mention of re-encapsulation, and explains it in a fairly
detailed paragraph. Does this satisfy the concern?

> 
>Nits:
>    * Confusing typo:  Last paragraph of p.25 says:  “For SEAL packets, the ITE performs any necessary IP reassembly…”  I think this should be the ETE not the ITE.

You are correct. This should be ETE instead of ITE and will be fixed in the next version.

---

From: Alia Atlas <[email-masked]>
Date: Tue, 19 Feb 2013 18:28:22 +0000

Hi Fred,

On re-reading 5.2, it does explain re-encapsulation well.  I  thought I had seen re-encapsulation mentioned before that - but on hunting the text, I don't find it.  

Alia

-----Original Message-----
From: Fred L. Templin [mailto:[email-masked]] 
Sent: Tuesday, February 19, 2013 1:23 PM
To: Alia Atlas; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: RtgDir review: draft-templin-intarea-seal-51.txt

Hello Alia,

Fred
[email-masked]

>Cc: "[email-masked]" <[email-masked]>; 
>"[email-masked]" 
><[email-masked]>
>I have been selected as the Routing Directorate reviewer for this 
>draft. The Routing Directorate seeks to review all routing or 
>routing-related drafts as they pass through IETF last call and IESG 
>review, and sometimes
on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://www.ietf.org/iesg/directorate/routing.html
>Although these comments are primarily for the use of the Routing ADs, 
>it would be helpful if you could consider them along with any other 
>IETF Last Call comments that you receive, and strive to resolve them 
>through
discussion or by updating the draft.
>   This document is basically ready for publication, but has nits that 
>should be considered prior to publication
> 
>Comments:
>    1. This document talks about re-encapsulation without describing it 
>or defining when it might be needed.  Even a brief sentence in 
>terminology or where re-encapsulation is first introduced would be 
>useful to explain that a segmented tunnel can exist and why

Section 5.2 ("SEAL Model of Operation") is the first mention of re-encapsulation, and explains it in a fairly detailed paragraph. Does this satisfy the concern?