Subject: [RTG-DIR] Scaling, Rewards and Process Rules : Document mentors

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 31 Mar 2014 16:39:54 +0100

To answer two concerns in one email:

Yes, we might have the scaling numbers wrong.

I suspect that only about half of the documents would end up with a mentor. 
Alia (I think - but she can comment) would like a higher number.

The number of documents we need to worry about is the number of WG documents
across the Routing Area at any one time. Alia has counted this as 187+27. I make
that 200 :-)

The Directorate is currently 40 people. 
That means between 2.5 and 5 documents per person.
5 seems too many, but some people might want to take on that sort of load while
others will not.

We do not know how much effort will be involved.
I would guess 3 detailed reviews over the course of the document, reviews of a
few diffs, and some email exchanges.

As the load ramps up, and according to people's willingness to participate we
might:
- declare the project a failure
- increase the size of the Directorate
- see that everything is cool.

I do note that several Directorate members said that they wished they got more
work from the Directorate, so at least some of you want something else to do.
Not sure if this is it :-)

Which takes me to "rewards".
What reward does a Directorate member get today?
I think that anyone in the Directorate who participates in this scheme could
easily expect to double the reward.

And lastly, is this new process and rules? Absolutely not.
This is just a way to inject resource into documents and help the authors/WGs to
deliver stuff that is useful and works. 
Does a WG have to halt processing while a mentor is found? No.
A mentor is just something that might happen in parallel.
Does a WG have to pay attention to what a mentor says? Yes.
But only in the same way that they would pay attention to the same person
commenting on the mailing list in the normal course of events.

A

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 31 Mar 2014 17:04:14 +0000

> work from the Directorate, so at least some of you want something else to do.

Then, it seems to me that those members of the directorate should already be swinging in, and looking at a document or two to review. ;-)  IMO, this seems like a great thing to do - I just don't believe it needs all of the attendant process wrapped around it that is being outlined.

> easily expect to double the reward.

Got'cha. It's pretty much like the "reward" I'm receiving for being a working group co-chair: bruises, a scar (or two), and an increased pain threshold. That and the ability to work on some pretty cool stuff… ;-)

Regards,
Stan

---

From: Thomas Clausen <[email-masked]>
Date: Mon, 31 Mar 2014 19:20:13 +0200

> Then, it seems to me that those members of the directorate should already be swinging in, and looking at a document or two to review. ;-)  IMO, this seems like a great thing to do - I just don't be…

Believe me, Stan, we already do - to some degree, picked at random, according to personal interests, or to "who catches us in the hallways first" or "who's on jabber" or something.

All we ask is that somebody points us to the documents that are most in need for reviews....

....where "in need for review" can be interpreted as "will decrease the workload on the ADs so that they may spend their time doing more important things" and, ultimately "will mean better end results"....

> Got'cha. It's pretty much like the "reward" I'm receiving for being a working group co-chair: bruises, a scar (or two), and an increased pain threshold. That and the ability to work on some pretty…

One thing that an AD with a decreased workload may have time for, is to pound harder on WG chairs that so request ;)

Thomas

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 31 Mar 2014 17:31:22 +0000

On Mar 31, 2014, at 1:20 PM, Thomas Clausen <[email-masked]<mailto:[email-masked]>> wrote:

On 31 Mar 2014, at 19:04, Stan Ratliff (sratliff) <[email-masked]<mailto:[email-masked]>> wrote:

On Mar 31, 2014, at 11:39 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>>
wrote:

All we ask is that somebody points us to the documents that are most in need for reviews….

Then perhaps an ordered list, picked by the ADs, would suffice?

Regards,
Stan

Thomas

Regards,
Stan

A

---

From: Edward Crabbe <[email-masked]>
Date: Mon, 31 Mar 2014 10:55:40 -0700

Is it mandatory for the group to wait for mentor feedback?  (If so, this
may slow document development and iteration unless a specific deadline is
provided and review happens in parallel to existing wg review - I'm
assuming this is the intention.)

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 31 Mar 2014 19:24:44 +0100

Hi Ed,
 
That's a good question. How would you like that to work? I can guess!
 
Can you propose changes to the text that do what you want?
 
A
 
From: Edward Crabbe [mailto:[email-masked]] 
Sent: 31 March 2014 18:56
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: Scaling, Rewards and Process Rules : Document mentors

Is it mandatory for the group to wait for mentor feedback?  (If so, this may
slow document development and iteration unless a specific deadline is provided
and review happens in parallel to existing wg review - I'm assuming this is the
intention.)

A

---

From: Leeyoung <[email-masked]>
Date: Mon, 31 Mar 2014 18:48:08 +0000

Hi,

Related to Ed's comment, I am wondering if this additional mentor feedback could potentially slow down the progress of standardization. Good document quality should never get compromised, but the time to standardization should not be compromised. General perception is that it takes too long to standardize in IETF.

I would support mentor feedback if this is only selectively applied to some documents per WG chair's call and is done in parallel to WG review.

Young

From: rtg-dir [mailto:[email-masked]] On Behalf Of Edward Crabbe
Sent: Monday, March 31, 2014 12:56 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [RTG-DIR] Scaling, Rewards and Process Rules : Document mentors

Is it mandatory for the group to wait for mentor feedback?  (If so, this may slow document development and iteration unless a specific deadline is provided and review happens in parallel to existing wg review - I'm assuming this is the intention.)

On Mon, Mar 31, 2014 at 8:39 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
To answer two concerns in one email:

A

---

From: Edward Crabbe <[email-masked]>
Date: Mon, 31 Mar 2014 13:15:07 -0700

Adrian;

Probably a single, specific, reasonable deadline stipulated by the chairs
for the WG as a whole, with the document reviewer having 50-70% of said
time allotment  to submit their review (thus allowing for substantive post
review commentary within the deadline.)

On Mon, Mar 31, 2014 at 11:24 AM, Adrian Farrel <[email-masked]> wrote:

> *From:* Edward Crabbe [mailto:[email-masked]]
> *Sent:* 31 March 2014 18:56
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: Scaling, Rewards and Process Rules : Document mentors
>
>
>
>
>