Subject: [RTG-DIR] RtgDir review: draft-farrkingel-pce-abno-architecture-11.txt

From: Tomonori Takeda <[email-masked]>
Date: Fri, 3 Oct 2014 15:59:00 +0000

Hello, 

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft. 

Document: draft-farrkingel-pce-abno-architecture-11.txt
Reviewer: Tomonori Takeda
Review Date: 3 October 2014
IETF LC End Date: Don't know
Intended Status: Informational 

Summary:
I have some minor concerns about this document that I think should be resolved before publication.

Comments:
This draft is well structured and easy to read (even though this draft is over 60 pages). However, I think there are some points to be clarified for the reader to understand more clearly.

Major Issues:
None

Minor Issues:
1) It is not clear whether interfaces in Section 2.3.2 intend to be exhaustive or not. My reading is that interfaces between functional components in Fig.1 are the interfaces mentioned in Section 2.3.2. However, for example, it is not clear where path computation request from the network (Section 2.3.2.5) is located in Fig.1. Another example is that it is not clear whether PCE to Provisioning Manager interface (not Provisioning Manager to Networks interface) is covered in Section 2.3.2 or not.

2) In Section 3.2.1, 2., Cross Stratum Addressing Mapping is mentioned. It says, "The ABNO Controller and/or the PCE may need to translate or map addresses from different address spaces." Maybe I am just missing something but it is not clear how this sentence is related to "a. The Application Layer knows Client Network Layer" and "b. Application Layer knows Server Network Layer". (I thought that a. corresponds to the case for the mapping by ABNO controller and b. corresponds to the case for the mapping by the PCE. However, this guess is not correct by reading the draft.)

Nits :
3) In Section 3.5, it would be good to add reference(s) for EON.

4) In Section 3.6.5, applicability of ABNO to PWs are mentioned. Although I agree PWs falls into multi-layer network, I am not sure whether/how ABNO covers that case for LDP signaled PWs.

5) In Section 3.7.2, it says "the task of selecting the data center may be left to the ABNO Controller". In this case, is the information such as server loads etc. stored in ABNO components? It seems that Fig.1 does not contain such databases.

6) Is Section 3.8 to be included in the final RFC?

7) In Appendix A., as for the VNTM to PCE/ABNO Controller interface, isn't it necessary to add PCE Notify (in addition to I2RS) to be in line with Section 2.3.2.10 (for completeness)?

Thanks,
Tomonori Takeda

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 3 Oct 2014 17:25:35 +0100

Hi,

Nice review. Thanks.

We can make updates to clarify these issues and pick up the nits.

In response to your points...

> 1) It is not clear whether interfaces in Section 2.3.2 intend to be exhaustive
or
> not. My reading is that interfaces between functional components in Fig.1 are
the
> interfaces mentioned in Section 2.3.2. However, for example, it is not clear
where
> path computation request from the network (Section 2.3.2.5) is located in
Fig.1.
> Another example is that it is not clear whether PCE to Provisioning Manager
> interface (not Provisioning Manager to Networks interface) is covered in
Section
> 2.3.2 or not.

Right. It is not intended to be an exhaustive list.
I think we have text for this somewhere, and we will add some clarity (and
possibly repetition in 2.3.2).
Furthermore, I think we even have text describing one or two interfaces that are
not in the figure.
The problem is that the figure could easily turn into a graphical representation
of Kotteri Hakata Tonkotsu Ramen.
So we only drew the main interfaces.

> 2) In Section 3.2.1, 2., Cross Stratum Addressing Mapping is mentioned. It
says,
> "The ABNO Controller and/or the PCE may need to translate or map addresses
> from different address spaces." Maybe I am just missing something but it is
not
> clear how this sentence is related to "a. The Application Layer knows Client
> Network Layer" and "b. Application Layer knows Server Network Layer". (I
> thought that a. corresponds to the case for the mapping by ABNO controller and
> b. corresponds to the case for the mapping by the PCE. However, this guess is
not
> correct by reading the draft.)

OK. Fair question.
I need to go back to the text to resolve this, but it sound just like there is
some clarity missing.

> 3) In Section 3.5, it would be good to add reference(s) for EON.

Yes

> 4) In Section 3.6.5, applicability of ABNO to PWs are mentioned. Although I
agree
> PWs falls into multi-layer network, I am not sure whether/how ABNO covers that
> case for LDP signaled PWs.

We'll add a few words although I don't want to develop a full use case for that
in this document (o/w we will add another 3 pages for each use potential case
and end up with 100 pages ;-)

In short, it is a layered network where:
- the upper layer is end-to-end multi-segment PW segments
- the middle layer is a mesh of S-PEs connected by MPLS tunnels
- the lower layer is the MPLS network(s) through which the tunnels are routed.

The placement of tunnels and the selection of which nodes are capable of acting
as S-PEs is a planning action for the lower layer in coordination with the
demands from higher layers.

The selection of tunnels and S-PEs to place e2e MS-PWs is an upper layer TE
computation that may trigger activity in the lower layers.

> 5) In Section 3.7.2, it says "the task of selecting the data center may be
left to the
> ABNO Controller". In this case, is the information such as server loads etc.
stored
> in ABNO components? It seems that Fig.1 does not contain such databases.

Yes. Not explicitly covered and the database section has left this open (again
because we can't include every possibility in the picture).
But we can draw this out in 3.7.2.

> 6) Is Section 3.8 to be included in the final RFC?

Good catch. The wording needs to change, but the section will remain. It is just
that more detailed development of these use cases is left to future documents.

> 7) In Appendix A., as for the VNTM to PCE/ABNO Controller interface, isn't it
> necessary to add PCE Notify (in addition to I2RS) to be in line with Section
2.3.2.10
> (for completeness)?

OK

Many thanks,
Adrian

---

From: Tomonori Takeda <[email-masked]>
Date: Sat, 4 Oct 2014 12:57:38 +0000

Hi Adrian,

Thanks.

In general, I understand that this draft is about overall framework and applicability and I do not intend to suggest adding every detail. I think it would be helpful to add a few words for clarification.

Specifically,

- snipped -

> I think we have text for this somewhere, and we will add some clarity (and possibly repetition in 2.3.2).
> Furthermore, I think we even have text describing one or two interfaces that are not in the figure.
> The problem is that the figure could easily turn into a graphical representation of Kotteri Hakata Tonkotsu Ramen.

Thanks for clarification.

Perhaps just adding a few words for clarification would help.
(I love Kotteri Hakata Tonkotsu Ramen though:-) )

- snipped -

> We'll add a few words although I don't want to develop a full use case for that in this document (o/w we will add another 3 pages for each use potential case and end up with 100 pages ;-)
> 
> The placement of tunnels and the selection of which nodes are capable of acting as S-PEs is a planning action for the lower layer in coordination with the demands from higher layers.
> 
> The selection of tunnels and S-PEs to place e2e MS-PWs is an upper layer TE computation that may trigger activity in the lower layers.

Thanks for clarification.

My question is about the upper layer e2e MS-PWs. PCE today is mainly for RSVP-TE signaling MPLS/GMPLS LSPs. In that sense, I am wondering whether/how LDP signaled PWs are in the scope of ABNO. 

In any case, I agree adding every detail is not a good idea. If my comment/question makes sense, it may be good to add a few words for clarification.

> Yes. Not explicitly covered and the database section has left this open (again because we can't include every possibility in the picture).

Understood.

As long as current main scope of ANBO does not include information such as server loads to be in the database, I am fine not explicitly mentioning about this in the draft.

Thanks,
Tomonori Takeda

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Saturday, October 04, 2014 1:26 AM
To: Tomonori Takeda（武田知典）; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: RtgDir review: draft-farrkingel-pce-abno-architecture-11.txt

Hi,

Nice review. Thanks.

or
the
where
Fig.1.
> Another example is that it is not clear whether PCE to Provisioning 
> Manager interface (not Provisioning Manager to Networks interface) is 
> covered in
Section

Right. It is not intended to be an exhaustive list.
I think we have text for this somewhere, and we will add some clarity (and possibly repetition in 2.3.2).
Furthermore, I think we even have text describing one or two interfaces that are not in the figure.
The problem is that the figure could easily turn into a graphical representation of Kotteri Hakata Tonkotsu Ramen.
So we only drew the main interfaces.

says,
> "The ABNO Controller and/or the PCE may need to translate or map 
> addresses from different address spaces." Maybe I am just missing 
> something but it is
not
> clear how this sentence is related to "a. The Application Layer knows 
> Client Network Layer" and "b. Application Layer knows Server Network 
> Layer". (I thought that a. corresponds to the case for the mapping by 
> ABNO controller and b. corresponds to the case for the mapping by the 
> PCE. However, this guess is
not
> correct by reading the draft.)

OK. Fair question.
I need to go back to the text to resolve this, but it sound just like there is some clarity missing.

Yes

agree
> PWs falls into multi-layer network, I am not sure whether/how ABNO 
> covers that case for LDP signaled PWs.

We'll add a few words although I don't want to develop a full use case for that in this document (o/w we will add another 3 pages for each use potential case and end up with 100 pages ;-)

The placement of tunnels and the selection of which nodes are capable of acting as S-PEs is a planning action for the lower layer in coordination with the demands from higher layers.

The selection of tunnels and S-PEs to place e2e MS-PWs is an upper layer TE computation that may trigger activity in the lower layers.

left to the
stored
> in ABNO components? It seems that Fig.1 does not contain such databases.

Yes. Not explicitly covered and the database section has left this open (again because we can't include every possibility in the picture).
But we can draw this out in 3.7.2.

> 6) Is Section 3.8 to be included in the final RFC?

Good catch. The wording needs to change, but the section will remain. It is just that more detailed development of these use cases is left to future documents.

> 7) In Appendix A., as for the VNTM to PCE/ABNO Controller interface, 
> isn't it necessary to add PCE Notify (in addition to I2RS) to be in 
> line with Section
2.3.2.10

OK

Many thanks,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 4 Oct 2014 17:12:13 +0100

Just closing one remaining point before I post an updated draft.

> My question is about the upper layer e2e MS-PWs. PCE today is mainly for RSVP-
> TE signaling MPLS/GMPLS LSPs. In that sense, I am wondering whether/how LDP
> signaled PWs are in the scope of ABNO.

Oh, I don't think so!
PCE is about calculating paths. That is a relatively abstract concept.
It is true that PCEP has currently only got RFCs for requesting and supplying
paths for RSVP-TE signaled LSPs (in packet or non-packet networks). But there
are I-Ds around for SFC, SPRING, and 6TSCH (I probably missed some as well :-)

In fact, the work to add to PCEP for PW LSPs turns out to be very, very small
basically because the extensions to tLDP for MS-PWs are based on CR-LDP which
shares its roots with the work done for MPLS-TE and GMPLS.

So, i think that the PCE would be fundamentally unchanged and that a few tweaks
would be needed to PCEP.

That leads me to look at the Appendix and to add a note there that PCEP might
need extending for some use cases.

Thanks,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 4 Oct 2014 18:46:06 +0100

A new revision has been posted

> > or not. My reading is that interfaces between functional components in 
> > Fig.1 are the interfaces mentioned in Section 2.3.2. However, for example,
> > it is not clear where path computation request from the network (Section
> > 2.3.2.5) is located in Fig.1.
> > Section 2.3.2 or not.

I was certain we had text, but I can't find it!
New text added in 2.3 before Figure 1 and in 2.3.2

> > says, "The ABNO Controller and/or the PCE may need to translate or map
> > something but it is not clear how this sentence is related to "a. The 
> > Application Layer knows Client Network Layer" and "b. Application Layer
> > knows Server Network Layer". (I thought that a. corresponds to the case
> > for the mapping by ABNO controller and b. corresponds to the case for
> > the mapping by the PCE. However, this guess is not correct by reading 
> > the draft.)
> 
> OK. Fair question.

Yeah, the text in 3.2.1 was icky (and actually plain wrong :-) 
I have done a little rewriting.

> > 3) In Section 3.5, it would be good to add reference(s) for EON.

Added a pointer to a foundational IEEE paper.

> > agree PWs falls into multi-layer network, I am not sure whether/how ABNO

As discussed in a separate thread, I have added some words to Section 3.6 and
also to Appendix A.

> > left to the ABNO Controller". In this case, is the information such as
server
> > loads etc. stored in ABNO components? It seems that Fig.1 does not contain
> > such databases.
> 

Done.

> that more detailed development of these use cases is left to future documents.

Moved the ALTO Server text into its own subsection of Section 3, and cleaned up
the text for 3.8 (now 3.9).

> > 2.3.2.10 (for completeness)?

Done.

Thanks for everything,
Adrian

---

From: Tomonori Takeda <[email-masked]>
Date: Sun, 5 Oct 2014 03:58:41 +0000

Hi Adrian,

Thanks!
It looks good to me.

Tomonori Takeda

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Sunday, October 05, 2014 2:46 AM
To: Tomonori Takeda（武田知典）; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: RtgDir review: draft-farrkingel-pce-abno-architecture-11.txt

> > Fig.1 are the interfaces mentioned in Section 2.3.2. However, for 
> > example, it is not clear where path computation request from the 
> > network (Section
> > Manager interface (not Provisioning Manager to Networks interface) 
> > is covered in Section 2.3.2 or not.
> 

> > 2) In Section 3.2.1, 2., Cross Stratum Addressing Mapping is 
> > mentioned. It says, "The ABNO Controller and/or the PCE may need to 
> > translate or map addresses from different address spaces." Maybe I 
> > am just missing something but it is not clear how this sentence is 
> > related to "a. The Application Layer knows Client Network Layer" and 
> > "b. Application Layer knows Server Network Layer". (I thought that 
> > a. corresponds to the case for the mapping by ABNO controller and b. 
> > corresponds to the case for the mapping by the PCE. However, this 
> > guess is not correct by reading the draft.)
> 
> OK. Fair question.

Yeah, the text in 3.2.1 was icky (and actually plain wrong :-) I have done a little rewriting.

> > 4) In Section 3.6.5, applicability of ABNO to PWs are mentioned. 
> > Although I agree PWs falls into multi-layer network, I am not sure 
> > whether/how ABNO covers that case for LDP signaled PWs.

As discussed in a separate thread, I have added some words to Section 3.6 and also to Appendix A.

> > 5) In Section 3.7.2, it says "the task of selecting the data center 
> > may be left to the ABNO Controller". In this case, is the 
> > information such as
server
> > loads etc. stored in ABNO components? It seems that Fig.1 does not 
> > contain such databases.
> 
> Yes. Not explicitly covered and the database section has left this 
> open (again because we can't include every possibility in the picture).

Done.

> Good catch. The wording needs to change, but the section will remain. 
> It is
just
> that more detailed development of these use cases is left to future documents.

Moved the ALTO Server text into its own subsection of Section 3, and cleaned up the text for 3.8 (now 3.9).

> > isn't
it

Done.

Thanks for everything,
Adrian