Subject: [RTG-DIR] Drafts without MUST requirements - advice needed

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 22 Apr 2015 10:43:43 +0000

Dear colleagues,

Recently I have seen a few drafts with intended status as PS but wiythout any MUST/MUST NOT requirement in the text.

>From my POV this is bad form, because  the implementer does not know what is the minimal functionality that provides any level of interoperability. In the worst case the implementer may decide not to do anything and claim compliance.

However, I could not find any documents that explicitly define such style  as not acceptable. Have I missed something? Or am I over-cautious?

Your advice would be highly appreciated.

Regards, and lots of thanks in advance,

Sasha

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 22 Apr 2015 13:26:30 +0100

On 22/04/2015 11:43, Alexander Vainshtein wrote:
>
> Dear colleagues,
>
> Recently I have seen a few drafts with intended status as PS but 
> wiythout any MUST/MUST NOT requirement in the text.
>
>
> From my POV this is bad form, because  the implementer does not know 
> what is the minimal functionality that provides any level of 
> interoperability. In the worst case the implementer may decide not to 
> do anything and claim compliance.
>
>
> However, I could not find any documents that explicitly define such 
> style  as not acceptable. Have I missed something? Or am I over-cautious?
>
>

Sasha

I think that you need to provide a bit more context.

It is possible to text describing a definitive action without using the 
word "must".

Stewart