Subject: Re: [RTG-DIR] [L2tpext] RTG-DIR review: draft-ietf-l2tpext-keyed-ipv6-tunnel-05

From: "Giles Heron (giheron)" <[email-masked]>
Date: Mon, 21 Mar 2016 17:57:45 +0000

Updated draft attached (sorry for the delay).  will post this in an hour or two unless anyone objects.

changes:

1) updated the wording to make it clear that the management plane is now in charge instead of the control plane (to address your comment re re-configuration to change cookies etc.)  I didn’t go as far as putting the word “orchestrator” in the draft as that may change by next week ;)   But I did use the phrase “matching configurations” - which should take care of concerns re e.g. MTU mismatches.

2) updated the draft to allow the L2-specific sublayer (for VCCV and frame sequencing)

3) added a paragraph to section 2 explaining the benefits of this approach (better ECMP and finer-grained route advertisements)

we can debate the other comments at a later point, but for now I wanted to get the draft published again - partly because there’s a dependency on this draft from the keyed IP tunnel YANG draft.  Speaking of which I’m not sure I want to put a ref here to that draft as that would all get a bit circular.

Giles

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 21 Mar 2016 19:06:46 +0000

Giles,
I will read the draft and provide detailed comments tomorrow. If you want to post it earlier, it is also OK.

With regard to circular references - it is simple to resolve if the reference to the YANG draft in this one is Informational. To me it maked sense due to the imortant role management plays in this draft, but I do not insist on it.

Your claim that the techniques  draft allows for better ECMP looks very interesting. I must admit that I have completely missed this consideration in my original analysis.

Thumb typed on my cellphone
Regards,
Sasha

-------- Original Message --------
From: "Giles Heron (giheron)" <[email-masked]>
Date: Mon, March 21, 2016 7:57 PM +0200
To: Alexander Vainshtein <[email-masked]>
CC: Maciek Konstantynowicz <[email-masked]>, Rainer Schatzmayr <[email-masked]>, Wim Henderickx <[email-masked]>, [email-masked], [email-masked], "Mark Townsley (townsley)" <[email-masked]>, Stewart Bryant <[email-masked]>, [email-masked], [email-masked], "Carlos Pignataro (cpignata)" <[email-masked]>
Subject: Re: [L2tpext] RTG-DIR review:  draft-ietf-l2tpext-keyed-ipv6-tunnel-05

changes:

1) updated the wording to make it clear that the management plane is now in charge instead of the control plane (to address your comment re re-configuration to change cookies etc.)  I didn't go as far as putting the word "orchestrator" in the draft as that may change by next week ;)   But I did use the phrase "matching configurations" - which should take care of concerns re e.g. MTU mismatches.

we can debate the other comments at a later point, but for now I wanted to get the draft published again - partly because there's a dependency on this draft from the keyed IP tunnel YANG draft.  Speaking of which I'm not sure I want to put a ref here to that draft as that would all get a bit circular.

Giles

---

From: "Giles Heron (giheron)" <[email-masked]>
Date: Mon, 21 Mar 2016 19:14:05 +0000

Hi Sasha,

On 21 Mar 2016, at 19:06, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:

Giles,

I’ll have to post today due to the cut-off.  I’m sure we can figure out a next rev once the window opens again.

I'm not sure if the tip revisions of 2 drafts can refer to each other as one has to be published before the other (even if by a few minutes)?

yes - that’s the main benefit.  But there others (the route advertisement granularity benefit I alluded to, but also potentially implementation advantages in being able to do a simpler lookup).

Giles

-------- Original Message --------
From: "Giles Heron (giheron)" <[email-masked]<mailto:[email-masked]>>
Date: Mon, March 21, 2016 7:57 PM +0200
To: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
CC: Maciek Konstantynowicz <[email-masked]<mailto:[email-masked]>>, Rainer Schatzmayr <[email-masked]<mailto:[email-masked]>>, Wim Henderickx <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, "Mark Townsley (townsley)" <[email-masked]<mailto:[email-masked]>>, Stewart Bryant <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, "Carlos Pignataro (cpignata)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [L2tpext] RTG-DIR review:  draft-ietf-l2tpext-keyed-ipv6-tunnel-05

changes:

Giles

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 21 Mar 2016 19:28:17 +0000

Thanks Giles and Sasha!

My AR$ 0.02 inline.

> On Mar 21, 2016, at 3:14 PM, Giles Heron (giheron) <[email-masked]> wrote:
> 
> Hi Sasha,
> 
>> On 21 Mar 2016, at 19:06, Alexander Vainshtein <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Giles,

Exactly — that sounds good. Posting will also make it easier to track state, diffs, etc.

Let’s also continue the conversation in this thread.
> I'm not sure if the tip revisions of 2 drafts can refer to each other as one has to be published before the other (even if by a few minutes)?

I’d leave it as-is.
> yes - that’s the main benefit.  But there others (the route advertisement granularity benefit I alluded to, but also potentially implementation advantages in being able to do a simpler lookup).

Thanks!

— Carlos.
>> From: "Giles Heron (giheron)" <[email-masked] <mailto:[email-masked]>>
>> To: Alexander Vainshtein <[email-masked] <mailto:[email-masked]>>
>> CC: Maciek Konstantynowicz <[email-masked] <mailto:[email-masked]>>, Rainer Schatzmayr <[email-masked] <mailto:[email-masked]>>, Wim Henderickx <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, "Mark Townsley (townsley)" <[email-masked] <mailto:[email-masked]>>, Stewart Bryant <[email-masked] <mailto:[email-masked]>>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, "Carlos Pignataro (cpignata)" <[email-masked] <mailto:[email-masked]>>