Subject: Re: [RTG-DIR] Rtg Dir review of draft-ietf-ospf-sbfd-discriminator-04.txt

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 3 May 2016 19:06:16 +0100

Carlos,
 
Alia asked me to confirm whether your proposed change would have caused me to not have made this comment on review.
 
It would certainly have helped. But...
 
"quite static" is not very clear as a relative term.
 
I think the concern might be that the network is large and there are many BFD sessions. 
Unless have I have misunderstood, it is not just a change in discriminator, but also a change to whether reflection is wanted or not.
 
Anyway, this is not a trap, just an encouragement to make a statement that helps readers to know that they don't need to worry. The parameters are:
- what causes an LSA to be flooded?
- how does that compare to the number of LSAs normally flooded?
- the security thing about using this as a way to cause excess flooding
- how much extra state info does an OSPF implementation have to hold
   for these LSA in the LSA DB?
 
Cheers,
Adrian
 
From: Carlos Pignataro (cpignata) [mailto:[email-masked]] 
Sent: 28 April 2016 17:15
To: Adrian Farrel
Cc: Acee Lindem (acee); Manav Bhatia; <[email-masked]>; <[email-masked]>; [email-masked]; OSPF WG List
Subject: Re: Rtg Dir review of draft-ietf-ospf-sbfd-discriminator-04.txt
 
Adrian,
 
I would not oppose to making a clarification similar to the following, if the WG things its useful:
 
The S-BFD Discriminators are expected to be quite static. S-BFD Discriminators may change when enabling the S-BFD functionality or via an explicit configuration event. These will result in a change in the information advertised in the S-BFD Discriminator TLV in OSPF, but are not expected to happen with any regularity.
 
[I expect that text needs (a lot of) wordsmithing, and might not be useful or desired at all, but just to make the discussion more real]
 
Thanks,
 
— Carlos.
 
On Apr 28, 2016, at 8:59 AM, Adrian Farrel <[email-masked]> wrote:
 
Acee has it right.
 
While (of course) stuff can be done in implementations to mitigate the effects, the protocol extensions here increase the size of LSA and increase the amount of flooding. Since the LSAs have to be stored (in some form), it is reasonable to describe the amount of extra information that reflects across a network - maybe express it as "LSA data" and leave it up to an implementation to choose how to store it. Since the number of LSA updates impacts the routing plane processing and bits on the wire, it is reasonable to ask what impact that might have.
 
I am interested to hear whether turning Reflectors on and off could be a feature that could cause LSAs to flap and so create flooding ripples in the network.
 
Adrian
 
From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: 28 April 2016 10:21
To: Manav Bhatia; Adrian Farrel
Cc: <[email-masked]>; [email-masked]; [email-masked]; OSPF WG List
Subject: Re: Rtg Dir review of draft-ietf-ospf-sbfd-discriminator-04.txt
 
Hi Manav,
 
From: Manav Bhatia < <mailto:[email-masked]> [email-masked]>
Date: Thursday, April 28, 2016 at 1:31 AM
To: Adrian Farrel < <mailto:[email-masked]> [email-masked]>
Cc: "< <mailto:[email-masked]> [email-masked]>" < <mailto:[email-masked]> [email-masked]>, Routing Directorate < <mailto:[email-masked]> [email-masked]>, " <mailto:[email-masked]> [email-masked]" < <mailto:[email-masked]> [email-masked]>, OSPF WG List < <mailto:[email-masked]> [email-masked]>
Subject: Re: Rtg Dir review of draft-ietf-ospf-sbfd-discriminator-04.txt
 
Hi Adrian,
 
Thanks for the extensive review. I have a minor comment on a minor issue that you raised.

Minor Issues:

I should like to see some small amount of text on the scaling impact on
OSPF. 1. How much additional information will implementations have to
store per node/link in the network? 2. What is the expected churn in
LSAs introduced by this mechanism (especially when the Reflector is
turned on and off)?
 
Isnt this implementation specific? This is what will differentiate one vendor implementation from the other. 
 
I am not sure how we can quantify this -- any ideas?
 
This is akin to saying that IS-IS, in contrast to OSPFv2, is more attuned for partial SPF runs because the node information is cleanly separated from the reachability information. However, this isnt entirely true. While i concede that node information is mixed with prefix information in OSPFv2, there still are ways in which clever implementations could separate the two and do exactly what IS-IS does. 
 
I took this rather circuitous approach to drive home the point that scalability, churn, overheads on the system are in many cases dependent on the protocol implementation and by that token outside the scope of the IETF drafts.
 
I believe what is being requested is a discussion of how often the S-BFD TLV is likely to change, the effects on flooding, and, if required, recommendations for any rate-limiting or other measures to prevent churn. 
 
Thanks,
Acee

You *do* have...
   A change in information in the S-BFD Discriminator TLV MUST NOT
   trigger any SPF computation at a receiving router.
...which is a help.
 
I would be alarmed if an implementation in an absence of this pedantic note triggered SPF runs each time an S-BFD disc changed ! I mean if you understand the idea being discussed then you also understand that a change in this TLV has no bearing on the reachability anywhere. And that knowledge should be enough to prevent SPF runs in most cases ! 
 
I know that we have added this note but if we need to explicitly spell such things out in all standards then we clearly have bigger problems ! :-)
 
Cheers, Manav

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 3 May 2016 19:49:43 +0000

Hi Adrian,

Thanks for the follow-up.

As I wrote to Alia, I am hesitant to quantify this further. These are identifiers expected to be static (think of a loopback IP address or a hostname as identifiers), on a feature that is not toggled on-and-off constantly. I really think that the document is saying enough for implementors to understand and take action (we are saying how often they change, and saying that when they do they are advertised).

Plus, regarding how much extra info additionally flooded or stored, as Alia also acknowledged, this isn’t a high-volume TLV, and the format is shown.

I do like helpful advice in an RFC, but it seems to me that the current text goes as far.

Perhaps I am misunderstanding the intention or the concern. In that case, if you have specific ideas in mind, it might help if you could provide a text proposal to compare and contrast.

Thanks,

— Carlos.

> On May 3, 2016, at 2:06 PM, Adrian Farrel <[email-masked]> wrote:
> 
> Carlos,
> 
>> On Apr 28, 2016, at 8:59 AM, Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Acee has it right.
>> 
>> From: Acee Lindem (acee) [mailto:[email-masked] <mailto:[email-masked]>]
>> Cc: <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; OSPF WG List
>> From: Manav Bhatia <[email-masked] <mailto:[email-masked]>>
>> To: Adrian Farrel <[email-masked] <mailto:[email-masked]>>
>> Cc: "<[email-masked] <mailto:[email-masked]>>" <[email-masked] <mailto:[email-masked]>>, Routing Directorate <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, OSPF WG List <[email-masked] <mailto:[email-masked]>>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 3 May 2016 21:18:48 +0100

I might express the concern as one that an operator might voice. "If I turn on this feature, what will happen to my IGP?"
 
But look, my review was for Alia to give her stuff to think about as AD. If I really cared that much about this feature I would have reviewed the I-D within the WG well before last call (not, as currently, well after). So, if Alia is happy I have nothing more to say.
 
Thanks,
Adrian
 
Sent: 03 May 2016 20:50
 
Hi Adrian,

 

 
Thanks,
 
— Carlos.

Carlos,

 

 
Cheers,
Adrian

Adrian,

 
 
Thanks,
 
— Carlos.
 
On Apr 28, 2016, at 8:59 AM, Adrian Farrel < <mailto:[email-masked]> [email-masked]> wrote:
 
Acee has it right.

 
Adrian
 
From: Acee Lindem (acee) [ <mailto:[email-masked]> mailto:[email-masked]] 
Sent: 28 April 2016 10:21
To: Manav Bhatia; Adrian Farrel
Cc: < <mailto:[email-masked]> [email-masked]>;  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]; OSPF WG List
Subject: Re: Rtg Dir review of draft-ietf-ospf-sbfd-discriminator-04.txt
 
Hi Manav,

Hi Adrian,

Minor Issues:

 

 
 
Thanks,
Acee

You *do* have...

 
Cheers, Manav