Subject: [RTG-DIR] RtgDir review: draft-smirnov-ospf-xaf-te

From: IJsbrand Wijnands <[email-masked]>
Date: Fri, 20 May 2016 14:31:55 +0200

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-smirnov-ospf-xaf-te 
Reviewer: IJsbrand Wijnands 
Review Date: 20-05-2016
Intended Status: Standards Track

Summary: 

This document is basically ready for publication, but has nits that should be considered prior to publication.

Comments:

This document is well written and the use-case is very clear and useful to solve. Does this also solve the use-case for P2MP TE LSPs? If it does, maybe its good to mention this. I do think it has consequences as it requires an IPv4/IPv6 explicit NULL label, if you want to share IPv4 and IPv6 traffic over the same P2MP LSP.

Major Issues: 
No major issues found.

Minor Issues: 

Section 3.
"For example, suppose the OSPFv2 instance …”

This paragraph could benefit from a rewrite as I find it hard to follow what the intention is. I would also advise not to use real IP addresses as an example since the actual value does not matter. Better to say IPv4_1, IPv4_2,.. IMO. 

Nits:

The acronym “ASON” is used in this document, but it is not spelled out what it stands for.

Thx,

Ice.

---

From: Alia Atlas <[email-masked]>
Date: Fri, 20 May 2016 08:35:44 -0400

Ice,

Thank you for doing this review.

Regards,
Alia

On Fri, May 20, 2016 at 8:31 AM, IJsbrand Wijnands <[email-masked]> wrote:

> Hello,
>
> I have been selected as the Routing Directorate reviewer for this draft.
> The Routing Directorate seeks to review all routing or routing-related
> drafts as they pass through IETF last call and IESG review, and sometimes
> on special request. The purpose of the review is to provide assistance to
> the Routing ADs. For more information about the Routing Directorate, please
> see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
>
> Although these comments are primarily for the use of the Routing ADs, it
> would be helpful if you could consider them along with any other IETF Last
> Call comments that you receive, and strive to resolve them through
> discussion or by updating the draft.
>
> This document is well written and the use-case is very clear and useful to
> solve. Does this also solve the use-case for P2MP TE LSPs? If it does,
> maybe its good to mention this. I do think it has consequences as it
> requires an IPv4/IPv6 explicit NULL label, if you want to share IPv4 and
> IPv6 traffic over the same P2MP LSP.
>
>
> Major Issues:
> No major issues found.
>
> Minor Issues:
>
> Section 3.
> This paragraph could benefit from a rewrite as I find it hard to follow
> what the intention is. I would also advise not to use real IP addresses as
> an example since the actual value does not matter. Better to say IPv4_1,
> IPv4_2,.. IMO.
>
> Nits:
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 20 May 2016 13:46:00 +0000

Yes - thanks Ice,
Acee

P.S.  ASON stands for Automatically Switched Optical Networks with the OSPF extensions defined in RFC 5787.

From: rtg-dir <[email-masked]<mailto:[email-masked]>> on behalf of Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 20, 2016 at 8:35 AM
To: "IJsbrand Wijnands (iwijnand)" <[email-masked]<mailto:[email-masked]>>
Cc: "<[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>>, Routing Directorate <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [RTG-DIR] RtgDir review: draft-smirnov-ospf-xaf-te

Ice,

Regards,
Alia

On Fri, May 20, 2016 at 8:31 AM, IJsbrand Wijnands <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Summary:

Comments:

Major Issues:
No major issues found.

Minor Issues:

Section 3.

Nits:

Thx,

Ice.

---

From: Anton Smirnov <[email-masked]>
Date: Tue, 24 May 2016 16:51:24 +0200

Hi Ice,
    thanks for your review comments. Please find updated text attached 
to this email. If changes are OK then I will publish them in a new revision.

 > Does this also solve the use-case for P2MP TE LSPs?
 > If it does, maybe its good to mention this. I do think it has
 > consequences as it requires an IPv4/IPv6 explicit NULL label, if you
 > want to share IPv4 and IPv6 traffic over the same P2MP LSP.

    The method described in this document can be used to compute 
cross-AF mapping of egress LSR for sub-LSPs of a P2MP LSP. I've added a 
sentence mentioning this.
    The document concentrates on path computation aspects specific to
OSPF. Data plane considerations are not specific to OSPF, so I don't 
think this document is a good place to have a text about how to forward 
cross-AF traffic thru P2MP LSP.

 > Section 3. "For example, suppose the OSPFv2 instance …”
 >
 > This paragraph could benefit from a rewrite as I find it hard to
 > follow what the intention is. I would also advise not to use real IP
 > addresses as an example since the actual value does not matter.
 > Better to say IPv4_1, IPv4_2,.. IMO.

    I rewrote the paragraph. Hopefully the text is clearer now.
    Having in the example IP addresses from the documentation range is 
very explicit in showing what information is put into TLVs. So I left in 
the text IP addresses but reduced their number from 3 to 2. I hope this 
also will make the example more straightforward to follow.

 > The acronym “ASON” is used in this document, but it is not spelled

    Fixed.

Anton