Subject: Re: [RTG-DIR] Routing directorate QA review of draft-ietf-i2rs-yang-network-topo

From: Ines Robles <[email-masked]>
Date: Mon, 9 May 2016 05:17:09 +0300

Hi,

QA review related to Data Model for Network Topologies I-D:

Document: draft-ietf-i2rs-yang-network-topo-02.txt

Reviewer: Ines Robles

Review Date: May 9, 2016

Intended Status: Standards Track

Summary:

 I have some minor concerns about this document that should be resolved
before publication.

Comments:

I believe the draft is technically good. Thinking how it could be extended
for constrained topology networks, e.g. RPL build a DODAG
(Destination-Oriented Directed Acyclic Graph) and I like that the links
 are point-to-point and unidirectional, and like "One common requirement
concerns the ability to represent that the same device can be part of
multiple networks and topologies." a RPL node can participate in several
DODAGs and in each one can have different role.

Major Issues:

I have no “Major” issues with this I-D.

Minor Issues and Nits:

1- Section 1, following Figure 2:

 1.1- " X1 and X2 - mapping onto... ",  I think it would be "X1 and X3
mapping onto..."
 1.2- " a single L3 network element", I would add in this case [Y2] "a
single L3 [Y2] network element", the same for "The figure shows a single
"L3" network element mapped onto multiple "Optical" network elements.", I
would add "The figure shows a single "L3" [Y2] network element mapped onto
multiple "Optical" network elements [Z] and [Z1]."

2- Section 2:

 2.1- I would add a reference to RFC 6020, since the document uses
terminology e.g container, augment, etc. which are defined in 6020. Even if
this RFC is mentioned in the normative reference, still I would add it here
as well.

 2.2- In terminology you mention ReST, for this I would add the reference
for further information. "Fielding, Roy Thomas. "Architectural styles and
the design of network-based software architectures." PhD diss., University
of California, Irvine, 2000.".
ReST is mentioned here but not in the rest of the draft, is it correct?

3- Section 5: What about add the security considerations mentioned in 6020?

4- In general: I would mention as related work and the relation with this
draft: draft-ietf-i2rs-yang-l2-network-topology-02,
draft-ietf-i2rs-yang-l3-topology-01 and
draft-contreras-supa-yang-network-topo-03 (this one is expired)

Thank you,

Ines.

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 9 May 2016 12:20:01 -0400

Ines: 

Thank you for the excellent review.  We appreciate your hard work. 

Sue 

From: i2rs [mailto:[email-masked]] On Behalf Of Ines Robles
Sent: Sunday, May 08, 2016 10:17 PM
To: [email-masked]; [email-masked]
Cc: Jonathan Hardwick; [email-masked]; Zhangxian (Xian); Susan Hares; Jon Hudson
Subject: Re: [i2rs] Routing directorate QA review of draft-ietf-i2rs-yang-network-topo

Hi,

 

Reviewer: Ines Robles

Review Date: May 9, 2016

 

Summary:

 I have some minor concerns about this document that should be resolved before publication.

Comments:

I believe the draft is technically good. Thinking how it could be extended for constrained topology networks, e.g. RPL build a DODAG (Destination-Oriented Directed Acyclic Graph) and I like that the links  are point-to-point and unidirectional, and like "One common requirement concerns the ability to represent that the same device can be part of multiple networks and topologies." a RPL node can participate in several DODAGs and in each one can have different role.

Major Issues:

Minor Issues and Nits:

 1.1- " X1 and X2 - mapping onto... ",  I think it would be "X1 and X3 mapping onto..."

 1.2- " a single L3 network element", I would add in this case [Y2] "a single L3 [Y2] network element", the same for "The figure shows a single "L3" network element mapped onto multiple "Optical" network elements.", I would add "The figure shows a single "L3" [Y2] network element mapped onto multiple "Optical" network elements [Z] and [Z1]."

2- Section 2:

 2.1- I would add a reference to RFC 6020, since the document uses terminology e.g container, augment, etc. which are defined in 6020. Even if this RFC is mentioned in the normative reference, still I would add it here as well. 

 2.2- In terminology you mention ReST, for this I would add the reference for further information. "Fielding, Roy Thomas. "Architectural styles and the design of network-based software architectures." PhD diss., University of California, Irvine, 2000.". 

 

 

4- In general: I would mention as related work and the relation with this draft: draft-ietf-i2rs-yang-l2-network-topology-02, draft-ietf-i2rs-yang-l3-topology-01 and draft-contreras-supa-yang-network-topo-03 (this one is expired)

Thank you,

Ines.