Subject: Re: [RTG-DIR] [mpls] Routing directorate review of draft-ietf-mpls-residence-time

From: "Hejia (Jia)" <[email-masked]>
Date: Tue, 13 Dec 2016 06:01:02 +0000

Hi Greg,

Thanks for your quick updates. They have addressed all of my questions. I’m OK the draft moves forward.

B.R.
Jia
发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2016年12月13日 0:29
收件人: Hejia (Jia)
抄送: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Jon Hudson
主题: Re: [mpls] Routing directorate review of draft-ietf-mpls-residence-time

Hi Jia,
greatly appreciate your thorough review and thoughtful recommendations. Please find my answers in-line tagged GIM>>.

Kind regards,
Greg

On Tue, Dec 6, 2016 at 6:43 AM, Hejia (Jia) <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing
Directorate seeks to review all routing or routing-related drafts as they pass through IETF
last call and IESG review, and sometimes on special request. The purpose of the review is to
provide assistance to the Routing ADs. For more information about the Routing Directorate,
please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if
you could consider them along with any other IETF Last Call comments that you receive, and
strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-mpls-residence-time-11.txt
Reviewer: Jia He
Review Date: Dec.6, 2016
IETF LC End Date:
Intended Status: Standards Track

Summary:
This document is basically ready for publication, but has minor issues that should be
considered prior to publication.

Comments:
The draft is clearly structured and easy to read.
GIM>> Thank you.

Major Issues:
No major issues found.
GIM>> Thank you.

Minor Issues:
1) Section 3.1, the description of "Type field" of PTP Sub-TLV format (following Figure 3) is
the same as the description of "PTPType". Shouldn't the PTP Sub-TLV follow RTM sub-TLV
registry?

"The Type field identifies PTP sub-TLV defined in the Table 19 Values of messageType field in
[IEEE.1588.2008]."

"The PTPType indicates the type of PTP packet carried in the TLV. PTPType is the messageType
field of the PTPv2 packet whose values are defined in the Table 19 [IEEE.1588.2008]."

GIM>> Great catch, thank you. Indeed, some cut-paste error. Proposed new text for Type field:
""
No changes for PTPType field.
Another question about RTM sub-TLV registry, why only PTP 2-step is defined under RTM sub-TLV
registry(8.3)?
GIM>> You absolutely right. There's no need for two types of sub-TLV for PTP.

Nits:
1) Section 1, first paragragh, s/Generalized Associated Channel/Generic Associated Channel
GIM>> Yes, agreed.
2) Section 3, first paragragh, s/select/selected
GIM>> Yes, agreed.
3) Section 4.7, last paragraph of Page 12, s/If match have been found, then the calculated..../If match has been found, the calculated....
GIM>> Yes, agreed.
4) Section 5, the first paragragh, ".....as described in Section 4.6 or as described in the second paragraph of Section 4 and in Section 4.6, ...." Duplication? Not sure about what " the second paragraph of Section 4" really indicates
GIM>> Great catch, thank you. The part after "or" is old. Removed "or as described in the second paragraph of Section 4 and in Section 4.6".
5) Section 7, Page 18(in the middle), BC needs to be spelt out, s/BC/Boundary Clock
GIM>>  First use of Boundary Clock term I've found is in section 4.6. I've added it to Terminology section and in 4.6 did s/Boundary Clock/Boundary Clock (BC)/

B.R.
Jia

发件人: Zhangxian (Xian)
发送时间: 2016年11月22日 16:41
收件人: Hejia (Jia)
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'Jon Hudson'
主题: Routing directorate review of draft-ietf-mpls-residence-time

Hey, Jia,

Please would you do a routing directorate review of this draft?
https://tools.ietf.org/html/draft-ietf-mpls-residence-time-11

The draft has been submitted to the IESG for publication.  The responsible AD – Deborah – has requested a review from the directorate before she initiates the IETF last call.  It would be great if you could review the document and send comments by 6th December.

You can find some guidance and a review template at the following link:
​https://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDirGuidance

Please send your comments to the RTG Area Directors (​[email-masked]<mailto:[email-masked]>) and the draft authors, and copy the MPLS mailing list and the rtg-dir list.

Please let me know if you can do it, or not.

Many thanks,
Xian

_______________________________________________
mpls mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mpls

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 13 Dec 2016 08:32:10 -0800

Hi Jia,
thank you for your comments and the most expedient response. I've uploaded
-12 version.

Regards,
Greg

On Mon, Dec 12, 2016 at 10:01 PM, Hejia (Jia) <[email-masked]> wrote:

> *发件人:* Greg Mirsky [mailto:[email-masked]]
> *发送时间:* 2016年12月13日 0:29
> *收件人:* Hejia (Jia)
> *抄送:* [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]; Jon
> Hudson
> *主题:* Re: [mpls] Routing directorate review of
> draft-ietf-mpls-residence-time
>
>
>
> Hi Jia,
>
> greatly appreciate your thorough review and thoughtful recommendations.
> Please find my answers in-line tagged GIM>>.
>
>
>
> Kind regards,
>
> Greg
>
>
>
>
>
> On Tue, Dec 6, 2016 at 6:43 AM, Hejia (Jia) <[email-masked]> wrote:
>
> Hello,
>
>
>
> 3) Section 4.7, last paragraph of Page 12, s/If match have been found,
> then the calculated..../If match has been found, the calculated....
>
> GIM>> Yes, agreed.
>
> 4) Section 5, the first paragragh, ".....as described in Section 4.6 or as
> described in the second paragraph of Section 4 and in Section 4.6, ...."
> Duplication? Not sure about what " the second paragraph of Section 4"
> really indicates
>
> GIM>> Great catch, thank you. The part after "or" is old. Removed "or as
> described in the second paragraph of Section 4 and in Section 4.6".
>
> GIM>>  First use of Boundary Clock term I've found is in section 4.6. I've
> added it to Terminology section and in 4.6 did s/Boundary Clock/Boundary
> Clock (BC)/
>
>
>
>
>
>
>
> B.R.
>
> Jia
>
>
>
> *发件人:* Zhangxian (Xian)
> *发送时间:* 2016年11月22日 16:41
> *收件人:* Hejia (Jia)
> *抄送:* [email-masked]; [email-masked]; 'Jon Hudson'
> *主题:* Routing directorate review of draft-ietf-mpls-residence-time
>
>
>
> Hey, Jia,
>
>
>
> The draft has been submitted to the IESG for publication.  The responsible
> AD – Deborah – has requested a review from the directorate before she
> initiates the IETF last call.  It would be great if you could review the
> document and send comments by *6th December*.
>
>
>
> Please send your comments to the RTG Area Directors (​[email-masked])
> and the draft authors, and copy the MPLS mailing list and the rtg-dir list.
>
>
>
> [email-masked]