Subject: [RTG-DIR] [RTG-DIR} RtgDir last call review: draft-ietf-lisp-signal-free-multicast-07.txt

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 12 Jan 2018 06:48:16 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir .

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-lisp-signal-free-multicast-07.txt
Reviewer: Les Ginsberg
Review Date: 11 January 2018
IETF LC End Date: Unknown
Intended Status: Experimental

Summary:
    This document is basically ready for publication, but has nits that should be considered prior to publication.

Comments:

This draft is very well written. Ideas are presented in a logical and coherent manner and I find it easy to understand the concepts even
without necessarily being an expert in the specific technology.

Major Issues:

No major issues found.

Minor Issues:

No minor issues found.

Nits:

The first use of LCAF (Section 2) should be expanded.

I find the acronym "RTR" a bit unfortunate for the obvious reason that it intuitively represents "just a router". I wonder if the authors could
consider something like "ReTR". I am sensitive to the fact that this document has been around since 2014 and has undergone significant WG review. I have
not attempted to track all of the email history regarding this document. Perhaps this point has been considered and consensus has been that the
RTR acronym is the best choice. If so, feel free to disregard my suggestion, but as someone who read this document for the first time I found myself 
looking back for the definition of "RTR" multiple times as I read through the text.

   Les

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 12 Jan 2018 09:58:50 -0800

> I find the acronym "RTR" a bit unfortunate for the obvious reason that it intuitively represents "just a router". I wonder if the authors could

Les, I understand your concern here. However, RTR is littered throughout many LISP documents as well as in product documentation and implementations. We have clearly defined it in the base documents and for any new use-case of an RTR, it is explained in the use-case documents.

I really think it is too late. The term will continue to be used even if IETF changes the documents. And adding a new term could add confusion (you’d have to clarify everywhere that an RTR and a ReTR is the same thing).

> consider something like "ReTR". I am sensitive to the fact that this document has been around since 2014 and has undergone significant WG review. I have

RTR was introduced in a general way in RFC6830 which dates even further back in time. And the component has added NAT functionality, TE functionality, and in this document multicast functionality.

> looking back for the definition of "RTR" multiple times as I read through the text.

Do you believe the definition is sufficient? This is what’s in the current document:

  Re-encapsulating Tunnel Router (RTR): An RTR is a router that
   implements the re-encapsulating tunnel function detailed in Section 8
   of the main LISP specification [RFC6830].  A LISP RTR performs packet
   re-routing by chaining ETR and ITR functions, whereby it first
   removes the LISP header of an ingress packet and then prepends a new
   LISP header to an egress packet.

Dino

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 12 Jan 2018 18:31:17 +0000

Dino -

I - of course - defer to you as regards all things LISP. And if the use of RTR is already widespread, then please ignore my comment.

That said, I do not see use of "RTR" in RFC 6830. I see ITR and ETR and their TE equivalents, but I do not see "RTR".
???

The definition of Re-encapsulating Tunnel Router is fine. It is just that when I saw "RTR" used in the text I had to go back to the terminology section because otherwise I thought you were just talking about a "Router".

   Les

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: Friday, January 12, 2018 9:59 AM
> To: Les Ginsberg (ginsberg) <[email-masked]>
> Cc: [email-masked]; [email-masked]; draft-ietf-lisp-signal-free-
> [email-masked]; [email-masked]
> Subject: Re: [RTG-DIR} RtgDir last call review: draft-ietf-lisp-signal-free-
> multicast-07.txt
> 
> > I find the acronym "RTR" a bit unfortunate for the obvious reason that
> > it intuitively represents "just a router". I wonder if the authors
> > could
> 
> Les, I understand your concern here. However, RTR is littered throughout
> many LISP documents as well as in product documentation and
> implementations. We have clearly defined it in the base documents and for
> any new use-case of an RTR, it is explained in the use-case documents.
> 
> I really think it is too late. The term will continue to be used even if IETF
> changes the documents. And adding a new term could add confusion (you’d
> have to clarify everywhere that an RTR and a ReTR is the same thing).
> 
> > consider something like "ReTR". I am sensitive to the fact that this
> > document has been around since 2014 and has undergone significant WG
> > review. I have
> 
> RTR was introduced in a general way in RFC6830 which dates even further
> back in time. And the component has added NAT functionality, TE
> functionality, and in this document multicast functionality.
> 
> > not attempted to track all of the email history regarding this
> > document. Perhaps this point has been considered and consensus has
> > been that the RTR acronym is the best choice. If so, feel free to disregard
> my suggestion, but as someone who read this document for the first time I
> found myself looking back for the definition of "RTR" multiple times as I read
> through the text.
>

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 12 Jan 2018 10:39:54 -0800

> I - of course - defer to you as regards all things LISP. And if the use of RTR is already widespread, then please ignore my comment.

Thanks.

> That said, I do not see use of "RTR" in RFC 6830. I see ITR and ETR and their TE equivalents, but I do not see "RTR".

That has been noticed by many and the definition has been put in the 6830bis draft. Sorry about referring to 6830 when I should have said draft-ietf-lisp-rfc6830bis-08.

> The definition of Re-encapsulating Tunnel Router is fine. It is just that when I saw "RTR" used in the text I had to go back to the terminology section because otherwise I thought you were just talking about a "Router”.

A sign that you have been doing routers (aka RTRs) too long. ;-)

Dino

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 12 Jan 2018 18:52:20 +0000

> Sent: Friday, January 12, 2018 10:40 AM
> > I - of course - defer to you as regards all things LISP. And if the use of RTR is
> already widespread, then please ignore my comment.
> 
> Thanks.
> 
> That has been noticed by many and the definition has been put in the
> 6830bis draft. Sorry about referring to 6830 when I should have said draft-
> ietf-lisp-rfc6830bis-08.
> 

[Les:] Yes - I see that. But - at a quick perusal of other LISP documents - I do not see a definition of RTR elsewhere. So it would seem you still have an opportunity to change the acronym and keep all published documents consistent.

But, I don't want to prolong this discussion. I think we understand each other and I am comfortable with whatever decision you make.

   Les

> > The definition of Re-encapsulating Tunnel Router is fine. It is just that when
> I saw "RTR" used in the text I had to go back to the terminology section
> because otherwise I thought you were just talking about a "Router”.
> 
> >> Subject: Re: [RTG-DIR} RtgDir last call review:
> >> draft-ietf-lisp-signal-free- multicast-07.txt
> >>
> >>> I find the acronym "RTR" a bit unfortunate for the obvious reason
> >>> that it intuitively represents "just a router". I wonder if the
> >>> authors could
> >>
> >> Les, I understand your concern here. However, RTR is littered
> >> throughout many LISP documents as well as in product documentation
> >> and implementations. We have clearly defined it in the base documents
> >> and for any new use-case of an RTR, it is explained in the use-case
> documents.
> >>
> >> I really think it is too late. The term will continue to be used even
> >> if IETF changes the documents. And adding a new term could add
> >> confusion (you’d have to clarify everywhere that an RTR and a ReTR is the
> same thing).
> >>
> >> RTR was introduced in a general way in RFC6830 which dates even
> >> further back in time. And the component has added NAT functionality,
> >> TE functionality, and in this document multicast functionality.
> >>
> >> my suggestion, but as someone who read this document for the first
> >> time I found myself looking back for the definition of "RTR" multiple
> >> times as I read through the text.
> >>
> >> Do you believe the definition is sufficient? This is what’s in the
> >> current
> >> document:
> >>