Subject: Re: [RTG-DIR] RtgDir review: draft-ietf-spring-segment-routing-ldp-interop-11

From: Ahmed Bashandy <[email-masked]>
Date: Wed, 6 Jun 2018 09:27:52 -0700

thanks a lot for the review

I will address your comments in the next few days

Ahmed

On 5/26/18 8:47 AM, Tomonori Takeda wrote:
> I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir  
>
> Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.
>
>   Document: draft-ietf-spring-segm

---

From: Ahmed Bashandy <[email-masked]>
Date: Wed, 13 Jun 2018 08:07:25 -0700

Hi

I just published version 13
https://www.ietf.org/internet-drafts/draft-ietf-spring-segment-routing-ldp-interop-13.txt

I moved the section about migration to appendix

Thanks

Ahmed

On 5/26/18 8:47 AM, Tomonori Takeda wrote:
> Hello,
>   Document: draft-ietf-spring-segment-routing-ldp-interop-11
>   Reviewer: Tomonori Takeda
>   Review Date: May 26th, 2018
>   IETF LC End Date: Not known
>   Intended Status: Standards Track
>
> Summary:
> This document is basically ready for publication, but has nits that should be considered prior to publication.
>
> Major Issues:
> None
>
> Minor Issues:
> I am a little bit confused about the relationship of SR/LDP interworking and migration from LDP to SR.
>
> The document says:
>   
>     "This document outlines the mechanisms through which SR interworks
>     with LDP in cases where a mix of SR-capable and non-SR-capable
>     routers co- exist within the same network and more precisely in the
>     same routing domain."
>
> My understanding of SR/LDP interworking and migration from LDP to SR is a different story.
> Migration from LDP to SR may or may not use SR/LDP interworking.
>
> Section 3 described migration from LDP to SR, but this migration scenario does not use
> SR/LDP interworking (expect for SR-based FRR usage to protect LDP traffic).
> This migration scenario uses SR/LDP co-existence, though.
>
> Is section 3 for information purpose only?
>
> Nits:
> None
>
>
> Thanks,
> Tomonori Takeda
>