Subject: [scim] What is this list's topic?

From: Alessandro Vesely <[email-masked]>
Date: Sat, 28 Jan 2012 11:42:05 +0100

Hi Peter and all,

I just read the announce for this, and wonder whether to subscribe or
not.  What is "Simple Cloud Identity Management"?  More precise questions:

Is "Cloud" meant to generically address netizenship or something more
specific, such as the dynamic nature of the IP assignments?

Identity management describes the management of individual identities,
their authentication, authorization, roles, and
privileges/permissions.  Correct?

Is there a relation with OpenID or BrowserID?  They both assume that
the user-ids are email addresses, but also have a framework and
definite techniques that could be standardized.  Is the discussion
supposed to build on those achievements?

TIA for any clarifications.

---

From: Trey Drake <[email-masked]>
Date: Sun, 29 Jan 2012 08:43:15 -0600

Hi Alessandro,

Please see inlined.  I believe it would be worth your time to review the use cases and specifications found at http://www.simplecloud.info.  I've pasted the abstract below.

"The Simple Cloud Identity Management (SCIM) specification is designed to make managing user identity in cloud based applications and services easier. The specification suite seeks to build upon experience with existing schemas and deployments, placing specific emphasis on simplicity of development and integration, while applying existing authentication, authorization, and privacy models. It's intent is to reduce the cost and complexity of user management operations by providing a common user schema and extension model, as well as binding documents to provide patterns for exchanging this schema using standard protocols. In essence, make it fast, cheap, and easy to move users in to, out of, and around the cloud."

> specific, such as the dynamic nature of the IP assignments?
More along the lines of SaaS application/software infrastructure.

> privileges/permissions.  Correct?
Correct.

> Is there a relation with OpenID or BrowserID?  

There will be bindings to OpenID for the purposes of just-in-time provisioning.  Same for SAML.

> They both assume that

The id is not presumed to be the user email address.  
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim