Subject: [scim] Deliverable section of charter

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Mon, 12 Mar 2012 00:17:50 -0500

Eliot suggestion we should add a deliverable section to the charter.
Here is a suggestion based on discussion and documents under SCIM 1.0.
Consider the dates on each item as a complete guess. We should discuss
the list of documents to begin with and then assign
appropriate/practical timeline to these:

5/2012    Initial problem statement draft

5/2012    Initial adoption of SCIM core schema

5/2012    Initial adoption of SCIM restful interface draft

5/2012    Initial adoption of SCIM SAML bindings draft

5/2012    Initial adoption of SCIM LDAP mapping draft

9/2012    WGLC SCIM core schema

9/2012    WGLC SCIM restful interface

9/2012    WGLC SCIM SAML bindings

9/2012    WGLC SCIM LDAP mapping

3/2013    Re-charter discussion

Cheers,

Morteza

---

From: Samuel Erdtman <[email-masked]>
Date: Mon, 12 Mar 2012 07:56:26 +0100

Have we considered to include an OpenID binding, 2.0 or Connect?

Cheers
//Samuel

On Mon, Mar 12, 2012 at 6:17 AM, Morteza Ansari (moransar)
<[email-masked]> wrote:
> Eliot suggestion we should add a deliverable section to the charter. Here is
> a suggestion based on discussion and documents under SCIM 1.0. Consider the
> dates on each item as a complete guess. We should discuss the list of
> documents to begin with and then assign appropriate/practical timeline to
> these:
>
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>

---

From: Eliot Lear <[email-masked]>
Date: Mon, 12 Mar 2012 08:10:34 +0100

Do we have a draft volunteer?

Eliot

---

From: Phil Hunt <[email-masked]>
Date: Mon, 12 Mar 2012 09:14:22 -0700

We still need to discuss adding major missing components in SCIM that are present in RESTpml. Specifically 'targeting'. 

I have not yet heard back on including this material as input docs to the charter. 

SCIM as it stands now is great for single service SaaS providers but there are major gaps for larger multi-service providers that targeting addresses. 

Note that I think these changes are additive and would not delay or significantly change the core spec--though there may be some normative adjustments required. I believe these are foundational requirements and need to be addressed now. 

Phil

---

From: Trey Drake <[email-masked]>
Date: Mon, 12 Mar 2012 11:29:53 -0500

Phil,

I believe it would be helpful if you made a specific proposal for how the "Simplest" schema, et al. might be meshed with the existing SCIM schema.  A proposal pointing out:

- the specific schema and attribute changes (schema change required? applicable to core? additional extensions?, etc.)
- what impact those changes have on the protocol (in theory none) 
- reasoning for change
- implementation impact  (is it useful by the masses, generalizable across a variety of 'backends', *implementable*)

Thanks,
Trey

---

From: Phil Hunt <[email-masked]>
Date: Mon, 12 Mar 2012 09:58:40 -0700

Trey,

I think such a draft proposal is premature. At the BoF stage, we should simply cite existing published materials as input rather then submitting changes prior to formation. Having other sources of input does not commit the WG to using the material, it simply indicates that the material is being considered.

I propose we discuss the issue at the BoF, and decide whether or not it should fall within the initial charter.

As to the whys/impact etc., I'm prepared to present that at the BoF. Then based on feedback, I am happy to work with any other interested WG members (as editor or contributor) to submit a draft proposal after the WG formation.

If it helps, I can publish some comments on the requirements externally on my personal blog so that everyone can have a chance to think about the issue in greater detail prior to the meeting.

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Mon, 12 Mar 2012 18:06:47 +0100

Phil,

I'm just saying that the scope of the WG cannot exceed the willingness
of various folk to volunteer to do the work.  Law of physics sort of thing.

Eliot

---

From: Trey Drake <[email-masked]>
Date: Mon, 12 Mar 2012 12:10:41 -0500

Phil,

Understood.  I was suggesting you provide more detail so as to solicit more feedback.  Please do publish/email more detail for us to review ahead of time.  My read on the Simplest schema/attribute spec is that its mostly overlap therefore if you're willing to do the work to highlight the deltas that would go a long way (at least for me) in getting those of us that have had our noses buried in SCIM for awhile up to speed.

Thanks,
Trey

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 12 Mar 2012 17:16:31 +0000

I have not reviewed RESTSPML or SIMPLEST yet, but from a the viewpoint of a provisioning vendor I think it is relevant and should be considered with SCIM.  I plan on reviewing the OASIS work in the near future and would be interested in hearing your summary.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Trey Drake
Sent: Monday, March 12, 2012 12:11 PM
To: Phil Hunt
Cc: [email-masked]
Subject: Re: [scim] Deliverable section of charter

Phil,

Thanks,
Trey

On Mar 12, 2012, at 11:58 AM, Phil Hunt wrote:

>> - the specific schema and attribute changes (schema change required? 
>> applicable to core? additional extensions?, etc.)
>> - implementation impact  (is it useful by the masses, generalizable 
>> across a variety of 'backends', *implementable*)
>> 
>> Thanks,
>> Trey
>> 
>> 
>>>>>> Eliot suggestion we should add a deliverable section to the 
>>>>>> charter. Here is a suggestion based on discussion and documents 
>>>>>> under SCIM 1.0. Consider the dates on each item as a complete 
>>>>>> guess. We should discuss the list of documents to begin with and 
>>>>>> then assign appropriate/practical timeline to
>>>>>> these:
>>>>>> 
>>>>>> 
>>>>>>

---

From: Chris Phillips <[email-masked]>
Date: Mon, 12 Mar 2012 13:20:32 -0400

+1 to the request for the delta.

More clarity around what are the overlaps are between SCIM the schema you
are citing will be very helpful.
>From my perspective(and I think others) it's hard to understand what the
ask is for considering the schema without details and advocating the
position as to why.

Thanks...

Chris.
___________________________________________________________________________
___
Chris Phillips | Technical Architect, CANARIE Inc.|
[email-masked] | W: 613.449.6715

On 12-03-12 1:10 PM, "Trey Drake" <[email-masked]> wrote:

>Phil,
>
>Understood.  I was suggesting you provide more detail so as to solicit
>more feedback.  Please do publish/email more detail for us to review
>ahead of time.  My read on the Simplest schema/attribute spec is that its
>mostly overlap therefore if you're willing to do the work to highlight
>the deltas that would go a long way (at least for me) in getting those of
>us that have had our noses buried in SCIM for awhile up to speed.
>
>Thanks,
>Trey
>
>
>> I think such a draft proposal is premature. At the BoF stage, we should
>>simply cite existing published materials as input rather then submitting
>>changes prior to formation. Having other sources of input does not
>>commit the WG to using the material, it simply indicates that the
>>material is being considered.
>> 
>> As to the whys/impact etc., I'm prepared to present that at the BoF.
>>Then based on feedback, I am happy to work with any other interested WG
>>members (as editor or contributor) to submit a draft proposal after the
>>WG formation.
>> 
>> If it helps, I can publish some comments on the requirements externally
>>on my personal blog so that everyone can have a chance to think about
>>the issue in greater detail prior to the meeting.
>> 
>> Phil
>> 
>> @independentid
>> www.independentid.com
>> [email-masked]
>> 
>> 
>> 
>> 
>> 
>>> I believe it would be helpful if you made a specific proposal for how
>>>the "Simplest" schema, et al. might be meshed with the existing SCIM
>>>schema.  A proposal pointing out:
>>> 
>>>> We still need to discuss adding major missing components in SCIM that
>>>>are present in RESTpml. Specifically 'targeting'.
>>>> 
>>>> SCIM as it stands now is great for single service SaaS providers but
>>>>there are major gaps for larger multi-service providers that targeting
>>>>addresses. 
>>>> 
>>>> Note that I think these changes are additive and would not delay or
>>>>significantly change the core spec--though there may be some normative
>>>>adjustments required. I believe these are foundational requirements
>>>>and need to be addressed now.
>>>> 
>>>> Phil
>>>> 
>>>>>>>charter. Here is

---

From: Phil Hunt <[email-masked]>
Date: Mon, 12 Mar 2012 10:22:02 -0700

Trey,

You are correct. This is why a merger of efforts seems appropriate to discuss.

The issue is to look at the gaps and see if:

a. They add value to SCIM
b. They can be added with minimal disruption

As far as I can tell, the key missing piece is the concept of Targeting in the SIMPLEST spec.

Phil

@independentid
www.independentid.com
[email-masked]

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Mon, 12 Mar 2012 19:48:04 -0500

I believe the updated charter addresses this: "The working group should
consider: ... *	Work done by other standard bodies as input to the
process such as OASIS Provisioning TC"

I guess the question is how to provide a deliverable section when we
don't know what the exact list of the documents we need to be producing
as part of the WG adopted work.

Cheers,
Morteza

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Phil Hunt
Sent: Monday, March 12, 2012 10:22 AM
To: Trey Drake
Cc: [email-masked]
Subject: Re: [scim] Deliverable section of charter

Trey,

You are correct. This is why a merger of efforts seems appropriate to
discuss.

As far as I can tell, the key missing piece is the concept of Targeting
in the SIMPLEST spec.

Phil

@independentid
www.independentid.com
[email-masked]

more feedback.  Please do publish/email more detail for us to review
ahead of time.  My read on the Simplest schema/attribute spec is that
its mostly overlap therefore if you're willing to do the work to
highlight the deltas that would go a long way (at least for me) in
getting those of us that have had our noses buried in SCIM for awhile up
to speed.
>> I think such a draft proposal is premature. At the BoF stage, we
should simply cite existing published materials as input rather then
submitting changes prior to formation. Having other sources of input
does not commit the WG to using the material, it simply indicates that
the material is being considered.
>> 
>> I propose we discuss the issue at the BoF, and decide whether or not
it should fall within the initial charter.
>> 
>> If it helps, I can publish some comments on the requirements
externally on my personal blog so that everyone can have a chance to
think about the issue in greater detail prior to the meeting.
>>> I believe it would be helpful if you made a specific proposal for
how the "Simplest" schema, et al. might be meshed with the existing SCIM

>>>> We still need to discuss adding major missing components in SCIM
that are present in RESTpml. Specifically 'targeting'. 
>>>> SCIM as it stands now is great for single service SaaS providers
but there are major gaps for larger multi-service providers that
targeting addresses. 
significantly change the core spec--though there may be some normative
adjustments required. I believe these are foundational requirements and
need to be addressed now.