Subject: [scim] greetings from one of your BoF chairs

From: Eliot Lear <[email-masked]>
Date: Wed, 07 Mar 2012 08:37:46 +0100

Hi everyone,

I look forward to working with you all to hold a successful BoF. 
Following on from Peter's earlier message, let's start structuring an
agenda for the BoF.  Here's my first swing:

  * Agenda Bashing (3 minutes)
  * Introduction – a clear and crisp problem statement that includes:
      o What is the provisioning problem that SCIM is trying to solve?
      o *and why is it importan*t?
      o Why isn't attribute exchange in SAML sufficient?  (with example,
        please)
      o Why not SPML/XACML?  Perhaps there are circumstances when
        SPML/XACML are appropriate and when they are not?  Discuss.
      o What problems are you *not* trying to solve?  e.g., limit your
        scope.
  * Overview of proposed starting point: SCIM and how it answers the
    above problem statement
      o Include document structure
  * Discussion
      o Is the problem important?
      o Is the problem well scoped?
      o Is the work appropriate for the IETF?
      o Do we understand how scim will differentiate against existing work?
      o Who are the volunteers to-
          + be editors for the various documents?
          + review the documents?
      o Is there implementer interest?
      o Should a working group be formed?
  * Brief introduction and discussion of a charter (if appropriate)

I think we can anticipate substantial participation from both the
application and security areas in this BoF.

Can we please have volunteers for the introduction and for the overview
of the solution?  The chairs will lead the discussion and introduction
to the charter.

Eliot

---

From: "Lipton, Paul C" <[email-masked]>
Date: Thu, 8 Mar 2012 21:27:34 +0000

Hi all,

It seems that there has been lively discussion regarding elements of the proposed charter over the last few weeks. That said; it is rather hard to find the latest iteration in its totality. Last place I saw something like that was at (1). Would somebody be able to provide a pointer to where the latest proposal might be posted? 

(1) http://www.ietf.org/mail-archive/web/scim/current/msg00003.html

Thanks,
Paul 
 
Paul Lipton
CA Technologies
VP, Industry Standards and Open Source 
Member, CA Council for Technical Excellence 
Office Phone: +1 609 583-9718
Mobile: +1 267 987-6887
Email: [email-masked]

From: [email-masked] [mailto:[email-masked]] On Behalf Of Eliot Lear
Sent: Wednesday, March 07, 2012 2:38 AM
To: [email-masked]
Cc: Steven M. Bellovin
Subject: [scim] greetings from one of your BoF chairs

Hi everyone,

I look forward to working with you all to hold a successful BoF.  Following on from Peter's earlier message, let's start structuring an agenda for the BoF.  Here's my first swing:
• Agenda Bashing (3 minutes)
• Introduction – a clear and crisp problem statement that includes:
o What is the provisioning problem that SCIM is trying to solve? 
o and why is it important?
o Why isn't attribute exchange in SAML sufficient?  (with example, please)
o Why not SPML/XACML?  Perhaps there are circumstances when SPML/XACML are appropriate and when they are not?  Discuss.
o What problems are you not trying to solve?  e.g., limit your scope.
• Overview of proposed starting point: SCIM and how it answers the above problem statement
o Include document structure
• Discussion
o Is the problem important?
o Is the problem well scoped?
o Is the work appropriate for the IETF?
o Do we understand how scim will differentiate against existing work?
o Who are the volunteers to-
• be editors for the various documents?
• review the documents?
o Is there implementer interest?
o Should a working group be formed?
• Brief introduction and discussion of a charter (if appropriate)
I think we can anticipate substantial participation from both the application and security areas in this BoF.
Can we please have volunteers for the introduction and for the overview of the solution?  The chairs will lead the discussion and introduction to the charter.
Eliot

---

From: Trey Drake <[email-masked]>
Date: Thu, 8 Mar 2012 17:21:56 -0600

On Mar 7, 2012, at 1:37 AM, Eliot Lear wrote:

> Agenda Bashing (3 minutes)
> Introduction – a clear and crisp problem statement that includes:
> What is the provisioning problem that SCIM is trying to solve? 
> and why is it important?
> Why isn't attribute exchange in SAML sufficient?  (with example, please)
> Why not SPML/XACML?  Perhaps there are circumstances when SPML/XACML are appropriate and when they are not?  Discuss.
> What problems are you not trying to solve?  e.g., limit your scope.
> Overview of proposed starting point: SCIM and how it answers the above problem statement
> Include document structure
> Discussion
> Is the problem important?
> Is the problem well scoped?
> Is the work appropriate for the IETF?
> Do we understand how scim will differentiate against existing work?
> Who are the volunteers to-
> be editors for the various documents?
> review the documents?
> Is there implementer interest?
> Should a working group be formed?
> Brief introduction and discussion of a charter (if appropriate)

I'll volunteer to present the protocol and schema.

Thanks,
Trey

> Eliot
> 
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Thu, 8 Mar 2012 21:30:25 -0600

Paul,

You are correct. There has been number of changes and suggestions and it is definitely time to roll them in. I will compile them into an updated version and send it out this weekend.

Cheers,
Morteza

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lipton, Paul C
Sent: Thursday, March 08, 2012 1:28 PM
To: Eliot Lear; [email-masked]
Cc: Steven M. Bellovin
Subject: Re: [scim] greetings from one of your BoF chairs

Hi all,

Thanks,
Paul 
 
Paul Lipton
CA Technologies
VP, Industry Standards and Open Source
Member, CA Council for Technical Excellence Office Phone: +1 609 583-9718
Mobile: +1 267 987-6887
Email: [email-masked]

Hi everyone,

o Why isn't attribute exchange in SAML sufficient?  (with example, please) o Why not SPML/XACML?  Perhaps there are circumstances when SPML/XACML are appropriate and when they are not?  Discuss.
• Overview of proposed starting point: SCIM and how it answers the above problem statement o Include document structure • Discussion o Is the problem important?
• Brief introduction and discussion of a charter (if appropriate) I think we can anticipate substantial participation from both the application and security areas in this BoF.

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Thu, 8 Mar 2012 21:32:36 -0600

Thanks Eliot for getting this started. I think this is a pretty good start. Unless we have another volunteer, I will take the introduction.

Cheers,

Morteza

From: [email-masked] [mailto:[email-masked]] On Behalf Of Eliot Lear
Sent: Tuesday, March 06, 2012 11:38 PM
To: [email-masked]
Cc: Steven M. Bellovin
Subject: [scim] greetings from one of your BoF chairs

Hi everyone,

	*	What is the provisioning problem that SCIM is trying to solve? 
	*	and why is it important?
	*	Why isn't attribute exchange in SAML sufficient?  (with example, please)
	*	Why not SPML/XACML?  Perhaps there are circumstances when SPML/XACML are appropriate and when they are not?  Discuss.
	*	What problems are you not trying to solve?  e.g., limit your scope.

*	Overview of proposed starting point: SCIM and how it answers the above problem statement

	*	Include document structure

*	Discussion

	*	Is the problem important?
	*	Is the problem well scoped?
	*	Is the work appropriate for the IETF?
	*	Do we understand how scim will differentiate against existing work?
	*	Who are the volunteers to-

		*	be editors for the various documents?
		*	review the documents?

	*	Is there implementer interest?
	*	Should a working group be formed?

Eliot