Subject: [scim] Conflict with extensions (consider for SICM 2.0)

From: Samuel Erdtman <[email-masked]>
Date: Tue, 24 Apr 2012 12:47:03 +0200

Since extensions are not contained within an extension node there are
the possibility of conflicts with existing and future attributes.
Would it be desirable to put extensions within an extension node
(since extensions as Kelly mentioned are defined by URN:s conflicts
are in worst cases rare).
Today a user with two extensions could look like this
{
 "schemas":["urn:scim:schemas:core:1.0", urn:scim:schemas:ext1,
urn:scim:schemas:ext2],
 "userName": "kalle",
 "urn:scim:schemas:ext1": {
   employeeNumber: "abc123"
 },
 "urn:scim:schemas:ext2": {
   employeeNumber: "123abc"
 }
}
Would it be better to change it to this
{
 "schemas":["urn:scim:schemas:core:1.0", ext1, ext2],
 "userName": "kalle",
 "extension": {
   "urn:scim:schemas:ext1": {
      employeeNumber: "abc123"
    },
   "urn:scim:schemas:ext2": {
     employeeNumber: "123abc"
   }
 }
}

Thoughts?
(for details see the thread
http://www.ietf.org/mail-archive/web/scim/current/msg00235.html and
the http://www.simplecloud.info/ page)
//Samuel

---

From: Phil Hunt <[email-masked]>
Date: Tue, 24 Apr 2012 11:04:24 -0700

I think there may be a more complex issue.  The URN listed is usually the extension namespace and not the extension object.

So if you defined:

urn:scim:schemas:ext:corporate as an extended schema and within that defined an "employee" and a "contractor" objects, then the following json would be ambiguous

> {
> "schemas":["urn:scim:schemas:core:1.0", urn:scim:schemas:ext:corporate],
> "userName": "kalle",
> "urn:scim:schemas:ext:corporate": {
>   employeeNumber: "abc123"
> }
> }

Unless you can tell by the attributes, it is unclear whether the User above is a "contractor" or an "employee".   Should the schema URN in the extendsion be the object URN?  --> urn:scim:schemas:ext:corporate:contractor

Phil

@independentid
www.independentid.com
[email-masked]

On 2012-04-24, at 3:47 AM, Samuel Erdtman wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim