Subject: [scim] Draft charter - v8

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Fri, 27 Apr 2012 02:55:02 -0500

Thanks everyone for reviews and suggestions and sorry for delay on my
side in updating the text of charter.  Updated version is attached. The
changes in this version are:

-Added most of the text Peter suggested (see my response to his email)

-Added the security consideration text from Peter & Melinda

-Reordered the milestone to emphasize initial focus on the core
documents

-Fixed minor correction Kelly reported

Please review the text and send your comments. Hopefully this is good
enough to hand it over to the ADs.

Cheers,

Morteza

*** charter7.txt               2012-04-09 18:52:42.000000000 -0700

--- charter8.txt  2012-04-27 00:52:41.000000000 -0700

***************

*** 9,21 ****

       Archive:
http://www.ietf.org/mail-archive/web/scim/current/maillist.html

  Description of Working Group:

! The Simple Cloud Identity Management (SCIM) specification will be
designed to 

! simplify user identity management in services and applications by
defining

! standard protocols and schemas for creating, reading/searching,
modifying,

! and deleting user identities and identity-related objects across 

! administrative domains.

! Today, distributed identity management across such domains is
complicated

  by a lack of protocol and schema standardization between consumers and

  producers of identities.  This has led to a number of approaches,

  including error prone manual administration and bulk file uploads,

--- 9,26 ----

       Archive:
http://www.ietf.org/mail-archive/web/scim/current/maillist.html

  Description of Working Group:

! The Simple Cloud Identity Management (SCIM) working group will
standardize

! methods for creating, reading/searching, modifying, and deleting user

! identities and identity-related objects across administrative domains,
with

! the goal of simplifying common tasks related to user identity
management in

! services and applications.

! 

! "Standardize" does not necessarily mean that the working group will
develop

! new technologies.  For example, the existing specifications for "SCIM
1.0"

! provide RESTful interfaces on top of HTTP rather than defining a new

! application protocol.

! Today, distributed identity management across administrative domains
is complicated

  by a lack of protocol and schema standardization between consumers and

  producers of identities.  This has led to a number of approaches,

  including error prone manual administration and bulk file uploads,

***************

*** 25,31 ****

  including, a lack of common schema, toolsets, and libraries.

  The SCIM working group will develop the core schema and RESTful
interfaces

! to address these problems. Initially, the WG will focus on a schema
definition

  and set of operations for creation, modification, and deletion of
users, as

  well as schema discovery, search, and bulk operations followed by
extensions

  including client targeting of specific SCIM endpoints.  The approach
will be

--- 30,36 ----

  including, a lack of common schema, toolsets, and libraries.

  The SCIM working group will develop the core schema and RESTful
interfaces

! to address these problems.  Initially, the WG will focus on a schema
definition

  and set of operations for creation, modification, and deletion of
users, as

  well as schema discovery, search, and bulk operations followed by
extensions

  including client targeting of specific SCIM endpoints.  The approach
will be

***************

*** 40,56 ****

  These drafts are based on existing specifications, which together are
commonly

  known as SCIM 1.0.  As such, some consideration should be given for
backward

! compatibility as the group evolves the work.  This group will
consider,

! the operational experience gathered from the existing work, as well as

! experiences with work done by other bodies, including the OASIS
Provisioning 

! TC.

  The group will produce Proposed Standards for a schema, a protocol, a
SAML

  binding, and an LDAP mapping.  In doing so, the group will make
consistent

! the terminology, review and improve security of the overall system,

! identify any functional gaps that would be useful for future work,
address

! internationalization, and provide guidelines for extensibility (either

! through IANA registries or other means).  

  The group considers the following out of scope for this group:

       Defining new authentication schemes

--- 45,66 ----

  These drafts are based on existing specifications, which together are
commonly

  known as SCIM 1.0.  As such, some consideration should be given for
backward

! compatibility as the group evolves the work.  This group will consider
the

! operational experience gathered from the existing work, as well as
experiences

! with work done by other bodies, including the OASIS Provisioning TC.

  The group will produce Proposed Standards for a schema, a protocol, a
SAML

  binding, and an LDAP mapping.  In doing so, the group will make
consistent

! the terminology, identify any functional gaps that would be useful for
future

! work, address internationalization, and provide guidelines for
extensibility

! (either through IANA registries or other means).  

! 

! In addition, the working group will ensure that the SCIM protocol
embodies

! good security practices, or document gaps in its capabilities and
propose a

! path forward for addressing those gaps.  Given both the sensitivity of
the

! information being conveyed in SCIM messages and the regulatory
requirements

! regarding the privacy of personally identifiable information, the
working

! group will pay particular attention to issues around authenticity and
privacy.

  The group considers the following out of scope for this group:

       Defining new authentication schemes

***************

*** 61,70 ****

  mm/yyyy    Initial adoption of SCIM use cases, as a living document

  mm/yyyy    Initial adoption of SCIM core schema

  mm/yyyy    Initial adoption of SCIM restful interface draft

- mm/yyyy    Initial adoption of SCIM SAML bindings draft

- mm/yyyy    Initial adoption of SCIM LDAP mapping draft

  mm/yyyy    WGLC SCIM core schema

  mm/yyyy    WGLC SCIM restful interface

  mm/yyyy    WGLC SCIM SAML bindings

  mm/yyyy    WGLC SCIM LDAP mapping

  mm/yyyy    Re-charter discussion

--- 71,80 ----

  mm/yyyy    Initial adoption of SCIM use cases, as a living document

  mm/yyyy    Initial adoption of SCIM core schema

  mm/yyyy    Initial adoption of SCIM restful interface draft

  mm/yyyy    WGLC SCIM core schema

  mm/yyyy    WGLC SCIM restful interface

+ mm/yyyy    Initial adoption of SCIM SAML bindings draft

+ mm/yyyy    Initial adoption of SCIM LDAP mapping draft

  mm/yyyy    WGLC SCIM SAML bindings

  mm/yyyy    WGLC SCIM LDAP mapping

  mm/yyyy    Re-charter discussion

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Apr 2012 13:52:39 -0400

> Please review the text and send your comments. Hopefully this is good enough
> to hand it over to the ADs.

Excellent; I'm basically happy with this version, and I think it's in
good shape.  Attached is an updated version with some edits, which are
all editorial (wording and formatting).  Please check the editorial
changes to be sure I didn't distort what you meant, and let me know if
anything is amiss.

If this group is happy with this 8.1 version, I'm happy to send it to
the IESG to start the review.

Barry

---

From: Melinda Shore <[email-masked]>
Date: Fri, 27 Apr 2012 10:09:15 -0800

It looks good to me.

Melinda

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 27 Apr 2012 18:29:10 +0000

+1

Looks great.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Melinda Shore
Sent: Friday, April 27, 2012 1:09 PM
To: [email-masked]
Subject: Re: [scim] Draft charter - v8

It looks good to me.

Melinda
_______________________________________________
scim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/scim

---

From: Tina TSOU <[email-masked]>
Date: Fri, 27 Apr 2012 18:39:38 +0000

It looks good to me.

Sent from my iPad

---

From: Phil Hunt <[email-masked]>
Date: Fri, 27 Apr 2012 11:57:09 -0700

Targeting appears to be missing (was in v7).

Trey had proposed inclusion into the core spec as permissible in the path to avoid an explicit extension endpoint.  Not sure what would happen with the schema extension. 

I think you should reference the target draft and we can decide later the best approach (separate extension or part of core) -- I can support either approach.  

Phil

@independentid
www.independentid.com
[email-masked]

On 2012-04-27, at 12:55 AM, Morteza Ansari (moransar) wrote:

> Thanks everyone for reviews and suggestions and sorry for delay on my side in updating the text of charter.  Updated version is attached. The changes in this version are:
>  
> -Reordered the milestone to emphasize initial focus on the core documents
> Please review the text and send your comments. Hopefully this is good enough to hand it over to the ADs.
>  
>  
> Cheers,
> Morteza
>  
>        Archive: http://www.ietf.org/mail-archive/web/scim/current/maillist.html
>   
> ! The Simple Cloud Identity Management (SCIM) specification will be designed to
> ! simplify user identity management in services and applications by defining
> ! standard protocols and schemas for creating, reading/searching, modifying,
> ! Today, distributed identity management across such domains is complicated
>        Archive: http://www.ietf.org/mail-archive/web/scim/current/maillist.html
>   
> ! The Simple Cloud Identity Management (SCIM) working group will standardize
> ! identities and identity-related objects across administrative domains, with
> ! the goal of simplifying common tasks related to user identity management in
> ! "Standardize" does not necessarily mean that the working group will develop
> ! new technologies.  For example, the existing specifications for "SCIM 1.0"
> ! Today, distributed identity management across administrative domains is complicated
>   The SCIM working group will develop the core schema and RESTful interfaces
> ! to address these problems. Initially, the WG will focus on a schema definition
>   and set of operations for creation, modification, and deletion of users, as
>   well as schema discovery, search, and bulk operations followed by extensions
>   including client targeting of specific SCIM endpoints.  The approach will be
> --- 30,36 ----
>   The SCIM working group will develop the core schema and RESTful interfaces
> ! to address these problems.  Initially, the WG will focus on a schema definition
>   and set of operations for creation, modification, and deletion of users, as
>   well as schema discovery, search, and bulk operations followed by extensions
>   including client targeting of specific SCIM endpoints.  The approach will be
> ***************
> *** 40,56 ****
>  
>   These drafts are based on existing specifications, which together are commonly
>   known as SCIM 1.0.  As such, some consideration should be given for backward
> ! compatibility as the group evolves the work.  This group will consider,
> ! experiences with work done by other bodies, including the OASIS Provisioning
> ! TC.
>  
>   The group will produce Proposed Standards for a schema, a protocol, a SAML
>   binding, and an LDAP mapping.  In doing so, the group will make consistent
> ! identify any functional gaps that would be useful for future work, address
>   These drafts are based on existing specifications, which together are commonly
>   known as SCIM 1.0.  As such, some consideration should be given for backward
> ! compatibility as the group evolves the work.  This group will consider the
> ! operational experience gathered from the existing work, as well as experiences
>   The group will produce Proposed Standards for a schema, a protocol, a SAML
>   binding, and an LDAP mapping.  In doing so, the group will make consistent
> ! the terminology, identify any functional gaps that would be useful for future
> ! work, address internationalization, and provide guidelines for extensibility
> ! In addition, the working group will ensure that the SCIM protocol embodies
> ! good security practices, or document gaps in its capabilities and propose a
> ! path forward for addressing those gaps.  Given both the sensitivity of the
> ! information being conveyed in SCIM messages and the regulatory requirements
> ! regarding the privacy of personally identifiable information, the working
> ! group will pay particular attention to issues around authenticity and privacy.
>  
> <charter8.txt>_______________________________________________
> scim mailing list
> [email-masked]

---

From: Phil Hunt <[email-masked]>
Date: Fri, 27 Apr 2012 11:58:45 -0700

apologies. I see the text is in there...
> to address these problems.  Initially, the WG will focus on a schema definition
> extensible.

+1 for the document.

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Chris Phillips <[email-masked]>
Date: Fri, 27 Apr 2012 15:24:01 -0400

Looks good to me..

C

/mobile_____________________
[email-masked]

On Apr 27, 2012, at 1:52 PM, "Barry Leiba" <[email-masked]> wrote:

> <scim charter v8.1.txt>

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Fri, 27 Apr 2012 15:49:50 -0500

I like the edits in 8.1.  But noticed a minor inconsistency between 4th
and 7th paragraph (BTW, this was inconsistent in my version).  You may
want to add this minor tweak to the text.  I am fine with it as is
though.

Cheers,
Morteza

*** charter8-1.txt	2012-04-27 11:30:36.000000000 -0700
--- charter9.txt	2012-04-27 11:32:29.000000000 -0700
***************
*** 40,49 ****
  - a schema definition
  - a set of operations for creation, modification, and deletion of
users
  - schema discovery
! - search
  - bulk operations
  It will follow that by considering extensions for client targeting of
! specific SCIM endpoints.  The approach will be extensible.
  
  The group will use, as starting points, the following drafts in the
  following ways:
--- 40,50 ----
  - a schema definition
  - a set of operations for creation, modification, and deletion of
users
  - schema discovery
! - read and search
  - bulk operations
  It will follow that by considering extensions for client targeting of
! specific SCIM endpoints, SAML binding, and LDAP mapping.  The approach
! will be extensible.
  
  The group will use, as starting points, the following drafts in the
  following ways:

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Barry Leiba
Sent: Friday, April 27, 2012 10:53 AM
To: Morteza Ansari (moransar)
Cc: [email-masked]
Subject: Re: [scim] Draft charter - v8

Barry

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Apr 2012 18:29:38 -0400

> want to add this minor tweak to the text.

Done in my version.  Now let's just come up with some draft dates for
the milestones, and I'll proceed with this.

[By the way: you'll notice that I'm not talking about the name
further.  I've given my opinion, and the group has given its.  I'm in
the rough on wanting to rename things, so "SCIM" it is for now.  The
IESG might or might not push back on the name; we'll see.  But no need
to discuss it further here.]

Barry