Subject: [scim] draft agenda for Vancouver

From: Leif Johansson <[email-masked]>
Date: Thu, 12 Jul 2012 14:40:33 +0200

Here is a draft agenda for Vancouver. Please help us fill this
in by suggesting things we missed or volunteering to present.

- - Agenda bashing and IETF Note Well
- - Chairs Introduction to the WG
- - SCIM 1.1 overview and document status (volunteers welcome!)
- - Technical discussion and open Mic

We have 2 hours on Friday morning so make sure not to leave early!

For those who are new to the IETF I suggest reading the Tao of
the IETF: http://www.ietf.org/tao.html

Note that on this our first WG meeting we will try to devote a little
bit of time to level-set and introduction but during future meetings
we will focus increasingly on resolving technical issues so if you are
curious about SCIM this is the time to get involved!

	Morteza and Leif

---

From: Phil Hunt <[email-masked]>
Date: Fri, 13 Jul 2012 11:15:25 -0700

It doesn't have to be a formal session, but I would like to discuss the following topics (possibly during the open mic):

* Searching without using URLs (e.g. due to privacy and injection attack considerations)
* Is minimum (GET/POST) REST profile needed?
* Using PUT to support Add/Replace since they are identical save for entity URL

Another topic of general exploration is:
* Reverse provisioning use case discussion
   Is this a big deal? Or will it have to wait for the next charter?

Targeting:
* Do we need an explicit extension, or should we just role the schema change into the core schema (to support linking related User entities) with appropriate modification of the core api spec clarifying extended path support as an alternative.

SCIM As General purpose IDMaaS:
* Example, allowing OAuth enabled client devices to update attributes in a person's profile.

Important Note: some of these topics may be a case of acknowledging the case and deciding stuff that can't be supported within the current charter. I do not want to argue for a change in scope, but really talk more about use cases and limit expectations appropriately.

Phil

@independentid
www.independentid.com
[email-masked]

On 2012-07-12, at 5:40 AM, Leif Johansson wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAk/+xcEACgkQ8Jx8FtbMZnfhwQCfW48IetBbBDb4FqZLsHI1D7vC
> XgYAoI+39hyFZhDHXV30aoSgIgdHy4Ql
> =+7V9
> -----END PGP SIGNATURE-----
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Leif Johansson <[email-masked]>
Date: Fri, 13 Jul 2012 21:19:40 +0200

On 07/13/2012 08:15 PM, Phil Hunt wrote:
> It doesn't have to be a formal session, but I would like to discuss
> the following topics (possibly during the open mic):
> 

Do you think you could put together a few slides to get the discussion
started?

> * Searching without using URLs (e.g. due to privacy and injection
> attack considerations) * Is minimum (GET/POST) REST profile
> needed? * Using PUT to support Add/Replace since they are identical
> save for entity URL
> 
> Another topic of general exploration is: * Reverse provisioning use
> case discussion Is this a big deal? Or will it have to wait for the
> next charter?
> 
> Targeting: * Do we need an explicit extension, or should we just
> role the schema change into the core schema (to support linking
> related User entities) with appropriate modification of the core
> api spec clarifying extended path support as an alternative.
> 
> SCIM As General purpose IDMaaS: * Example, allowing OAuth enabled
> client devices to update attributes in a person's profile.
> 
> Important Note: some of these topics may be a case of acknowledging
> the case and deciding stuff that can't be supported within the
> current charter. I do not want to argue for a change in scope, but
> really talk more about use cases and limit expectations
> appropriately.
> 
> Phil
> 
> @independentid www.independentid.com [email-masked]
> 
> 
> 
> 
> 
> Here is a draft agenda for Vancouver. Please help us fill this in
> by suggesting things we missed or volunteering to present.
> 
> - Agenda bashing and IETF Note Well - Chairs Introduction to the
> WG - SCIM 1.1 overview and document status (volunteers welcome!) -
> Technical discussion and open Mic
> 
> For those who are new to the IETF I suggest reading the Tao of the
> IETF: http://www.ietf.org/tao.html
> 
> Note that on this our first WG meeting we will try to devote a
> little bit of time to level-set and introduction but during future
> meetings we will focus increasingly on resolving technical issues
> so if you are curious about SCIM this is the time to get involved!
> 
> Morteza and Leif
>> _______________________________________________ scim mailing
>> list [email-masked] https://www.ietf.org/mailman/listinfo/scim
>

---

From: Phil Hunt <[email-masked]>
Date: Fri, 13 Jul 2012 12:24:33 -0700

Sure. 

Also re targeting. I think we should have a combined targeting graph api discussion re Kim Cameron's recent thoughts on scim and graph. 

Phil

On 2012-07-13, at 12:19, Leif Johansson <[email-masked]> wrote:

> iEYEARECAAYFAlAAdMgACgkQ8Jx8FtbMZnd3EACdEa7HUAIgiRK86xXk6Z06HZGc
> QugAniySGYwfzc9G1bQhMEQ/SnA5Uw54
> =KRSG