Subject: [scim] Directory mapping discussion at ietf vancouver

From: Phil Hunt <[email-masked]>
Date: Sat, 14 Jul 2012 11:16:44 -0700

Would anyone be interested in having a broader discussion about ldap directories and mapping support prior to the scim wg session. 

In particular it would good to explore some alternatives for mapping vs direct complex attribute support.

My primary worry is some mapping proposals lead to existing clients having to change classic ldap queries. I'd like to get to full fidelity (bi-directional mapping) support and full backwards compatibility for existing clients if possible.  

I think a good open discussion might take longer than we have scheduled time in the meeting. :)

Phil

---

From: Anthony Nadalin <[email-masked]>
Date: Sat, 14 Jul 2012 20:16:43 +0000

I would be interested

Sent from my Windows Phone
________________________________
From: Phil Hunt
Sent: 7/14/2012 11:17 AM
To: scim WG
Subject: [scim] Directory mapping discussion at ietf vancouver

Phil
_______________________________________________
scim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/scim

---

From: Leif Johansson <[email-masked]>
Date: Sun, 15 Jul 2012 00:00:40 +0200

On 07/14/2012 08:16 PM, Phil Hunt wrote:
> Would anyone be interested in having a broader discussion about
> ldap directories and mapping support prior to the scim wg session.
> 
> 
> In particular it would good to explore some alternatives for
> mapping vs direct complex attribute support.
> 
> My primary worry is some mapping proposals lead to existing clients
> having to change classic ldap queries. I'd like to get to full
> fidelity (bi-directional mapping) support and full backwards
> compatibility for existing clients if possible.
> 

We can at least do a report-back in the session and make sure to
capture follow-ups etc.

---

From: Phil Hunt <[email-masked]>
Date: Sat, 14 Jul 2012 18:14:14 -0700

Agreed. 

Phil

On 2012-07-14, at 15:00, Leif Johansson <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAlAB7AcACgkQ8Jx8FtbMZne8yQCeLhEo0rsPF0BQclf34uS1Sw2M
> Ps4An3oRlV1i+fVOA4CfdAgfuH4G2MAT
> =sJyT
> -----END PGP SIGNATURE-----

---

From: Chris Phillips <[email-masked]>
Date: Sun, 15 Jul 2012 07:48:43 -0400

I would be interested as well...

/mobile_____________________
[email-masked]