Subject: Re: [scim] scim Digest, Vol 8, Issue 29

From: Ganesh and Sashi Prasad <[email-masked]>
Date: Sat, 11 Aug 2012 19:00:47 +1000

A couple of you have mentioned the failure of SPML, with conjectures as to
why it failed. Let me share my experience with it.

I tried to implement an SPML-based provisioning system 3-4 years ago and
gave up, not because of a lack of language features but simply because I
found the messages were too heavyweight for something that was just a
shell. There was little attention paid to the data model (a common failing
in many protocol designs, IMO). The payload was the real thing, and that
was entirely the organisation's responsibility.

I finally designed a provisioning scheme with specific attention to data,
that was loosely-coupled and idempotent, and which (most importantly)
worked. It's described on pages 124-128 of my eBook
<http://www.infoq.com/minibooks/Identity-Management-Shoestring>
.

So yes, SPML failed, but the lessons I drew from that are quite different
from what others seem to be drawing. The spec needs to deliver value, and
that was what was missing in SPML.

My two cents.

Regards,
Ganesh

On 11 August 2012 15:22, <[email-masked]> wrote:

> If you have received this digest without all the individual message
> attachments you will need to update your digest options in your list
> subscription.  To do so, go to
>
> https://www.ietf.org/mailman/listinfo/scim
>
> Click the 'Unsubscribe or edit options' button, log in, and set "Get
> MIME or Plain Text Digests?" to MIME.  You can set this option
> globally for all the list digests you receive at this point.
>
>
>
> Send scim mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/scim
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of scim digest..."
>
> Today's Topics:
>
>    1. Re: scim Digest, Vol 8, Issue 26 (Trey Drake)
>    2. Re: scim Digest, Vol 8, Issue 26 (Richard Sand)
>
>
> ---------- Forwarded message ----------
> From: Trey Drake <[email-masked]>
> To: Ganesh and Sashi Prasad <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Date: Fri, 10 Aug 2012 23:55:14 -0500
> Subject: Re: [scim] scim Digest, Vol 8, Issue 26
> I believe Mark's comments are sound as they speak directly to the failure
> of SPML viz. lessons learned.  Since inception, SCIM has had an eye towards
> easing the pain for SPs.  History has proven that failure to do so may
> result in a technically solid spec with zero adoption.
>
>
> On Aug 10, 2012, at 10:23 PM, Ganesh and Sashi Prasad <
> [email-masked]> wrote:
>
> Ganesh - we are all participating as individuals in IETF. Maybe you should
>> consult the rules for working groups as explained in:
>>
>> http://tools.ietf.org/pdf/rfc2418.pdf
>>
>> It is irrelevant whether you belong to a very large technology company,
>> or are a technology analyst or whether you are just a great guy/gal.
>>
>> All the discussion has to be in the open and all sources (no confidential
>> research reports!) have to be publicly made available.
>>
>> - prateek
>>
>> Fair enough. I was just concerned listening to Mark's comments (about
> adoption being hindered because of complexity for SPs), that one interest
> group may have undue influence over the WG. if that's not the case, I'm
> happy :-).
>
> Regards,
> Ganesh
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>
>
> ---------- Forwarded message ----------
> From: Richard Sand <[email-masked]>
> To: Trey Drake <[email-masked]>, Ganesh and Sashi Prasad <
> [email-masked]>
> Cc: [email-masked]
> Date: Sat, 11 Aug 2012 01:22:37 -0400
> Subject: Re: [scim] scim Digest, Vol 8, Issue 26
>
> I’d like to jump in here too in support of Mark’s comments. I see many on
> the SCIM list who were former members or contributors to the OASIS PSTC and
> the failings of SPML should be well know. What SPML failed to do was
> provide a simple language for specific tasks – if a company just needed to
> set up an endpoint to enable/disable accounts or perform password resets,
> SPML was not purpose-build for this, and set requirements conformance that
> made it ill-suited towards one-off usage as a tool to solve a specific
> integration problem. SCIM as it is now addresses some of these shortcomings
> – it does not require much of a burden to the SP, it language handles
> identity management requirements at a slightly higher level than just
> directory-style object-crud operations. So I would not deviate from these
> principles, as lack of them did in what was otherwise a useful and
> functional spec in SPML.
>
>
>
> Standard Schema of course is another topic that SPML never adequately
> addressed.
>
>
>
> Richard Sand | Managing Director
> PO Box 91824 | Austin | Texas 78709-1824 | USA
> Office: +1 888 612 8820 ext 02 | Fax: +1 866 304 3754
> Mobile: +1 267 984 3651
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Trey Drake
> *Sent:* Saturday, August 11, 2012 12:55 AM
> *To:* Ganesh and Sashi Prasad
> *Cc:* [email-masked]
> *Subject:* Re: [scim] scim Digest, Vol 8, Issue 26
>
>
>
> I believe Mark's comments are sound as they speak directly to the failure
> of SPML viz. lessons learned.  Since inception, SCIM has had an eye towards
> easing the pain for SPs.  History has proven that failure to do so may
> result in a technically solid spec with zero adoption.
>
>
>
>
> On Aug 10, 2012, at 10:23 PM, Ganesh and Sashi Prasad <
> [email-masked]> wrote:
>
> Ganesh - we are all participating as individuals in IETF. Maybe you should
> consult the rules for working groups as explained in:
>
> http://tools.ietf.org/pdf/rfc2418.pdf
>
> It is irrelevant whether you belong to a very large technology company, or
> are a technology analyst or whether you are just a great guy/gal.
>
> All the discussion has to be in the open and all sources (no confidential
> research reports!) have to be publicly made available.
>
> - prateek
>
> Fair enough. I was just concerned listening to Mark's comments (about
> adoption being hindered because of complexity for SPs), that one interest
> group may have undue influence over the WG. if that's not the case, I'm
> happy :-).
>
>
>
> Regards,
>
> Ganesh
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>

---

From: Trey Drake <[email-masked]>
Date: Sat, 11 Aug 2012 10:37:03 -0500

It seems to me you are missing context.  Discussions on SPML, and for that matter other schemes, have been had and documented (look over chartering slides, email threads, BoF script, as well as the numerous blog posts that have been written about SCIM).  

On Aug 11, 2012, at 4:00 AM, Ganesh and Sashi Prasad <[email-masked]> wrote:

> A couple of you have mentioned the failure of SPML, with conjectures as to why it failed. Let me share my experience with it.
> 
> I tried to implement an SPML-based provisioning system 3-4 years ago and gave up, not because of a lack of language features but simply because I found the messages were too heavyweight for something that was just a shell. There was little attention paid to the data model (a common failing in many protocol designs, IMO). The payload was the real thing, and that was entirely the organisation's responsibility.
> 
> I finally designed a provisioning scheme with specific attention to data, that was loosely-coupled and idempotent, and which (most importantly) worked. It's described on pages 124-128 of my eBook .
> 
> So yes, SPML failed, but the lessons I drew from that are quite different from what others seem to be drawing. The spec needs to deliver value, and that was what was missing in SPML.
> 
> My two cents.
> 
> Regards,
> Ganesh
> 
> I believe Mark's comments are sound as they speak directly to the failure of SPML viz. lessons learned.  Since inception, SCIM has had an eye towards easing the pain for SPs.  History has proven that failure to do so may result in a technically solid spec with zero adoption.  
> 
> 
> On Aug 10, 2012, at 10:23 PM, Ganesh and Sashi Prasad <[email-masked]> wrote:
> 
>> Ganesh - we are all participating as individuals in IETF. Maybe you should consult the rules for working groups as explained in:
>> 
>> It is irrelevant whether you belong to a very large technology company, or are a technology analyst or whether you are just a great guy/gal. 
>> 
>> All the discussion has to be in the open and all sources (no confidential research reports!) have to be publicly made available.
>> 
>> - prateek
>> 
>> Fair enough. I was just concerned listening to Mark's comments (about adoption being hindered because of complexity for SPs), that one interest group may have undue influence over the WG. if that's not the case, I'm happy :-).
>> 
>> Regards,
>> Ganesh
> To: Trey Drake <[email-masked]>, Ganesh and Sashi Prasad <[email-masked]>
> Cc: [email-masked]
> I’d like to jump in here too in support of Mark’s comments. I see many on the SCIM list who were former members or contributors to the OASIS PSTC and the failings of SPML should be well know. What SPML failed to do was provide a simple language for specific tasks – if a company just needed to set up an endpoint to enable/disable accounts or perform password resets, SPML was not purpose-build for this, and set requirements conformance that made it ill-suited towards one-off usage as a tool to solve a specific integration problem. SCIM as it is now addresses some of these shortcomings – it does not require much of a burden to the SP, it language handles identity management requirements at a slightly higher level than just directory-style object-crud operations. So I would not deviate from these principles, as lack of them did in what was otherwise a useful and functional spec in SPML.
> 
>  
> Standard Schema of course is another topic that SPML never adequately addressed.
> 
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Trey Drake
> Sent: Saturday, August 11, 2012 12:55 AM
> To: Ganesh and Sashi Prasad
> Cc: [email-masked]
> I believe Mark's comments are sound as they speak directly to the failure of SPML viz. lessons learned.  Since inception, SCIM has had an eye towards easing the pain for SPs.  History has proven that failure to do so may result in a technically solid spec with zero adoption.  
> 
>  
> 
> On Aug 10, 2012, at 10:23 PM, Ganesh and Sashi Prasad <[email-masked]> wrote:
> 
> Ganesh - we are all participating as individuals in IETF. Maybe you should consult the rules for working groups as explained in:
> 
> It is irrelevant whether you belong to a very large technology company, or are a technology analyst or whether you are just a great guy/gal. 
> 
> All the discussion has to be in the open and all sources (no confidential research reports!) have to be publicly made available.
> 
> - prateek
> 
> Fair enough. I was just concerned listening to Mark's comments (about adoption being hindered because of complexity for SPs), that one interest group may have undue influence over the WG. if that's not the case, I'm happy :-).
> 
>  
> Regards,
> 
> Ganesh
>