Subject: [scim] SCIM attributes to LDAP attributes mapping {was: Directory mapping discussion at ietf vancouver}

From: Hasini Gunasinghe <[email-masked]>
Date: Tue, 28 Aug 2012 18:48:20 +0530

Hi all,

Did the below mentioned discussion happen? If so, could some one please
brief the list what the outcome of the discussion was?

Mapping SCIM attributes to LDAP attributes and vice versa is a common
requirement that both the SCIM consumer and SP implementations encounter.

IMO, we can come up with a Object Class for SCIM User (may be extending
inetOrgPerson or a completely new schema) and SCIM Group.

Appreciate thoughts on this..

Thanks,
Hasini.

On Sat, Jul 14, 2012 at 11:46 PM, Phil Hunt <[email-masked]> wrote:

> Would anyone be interested in having a broader discussion about ldap
> directories and mapping support prior to the scim wg session.
>
> In particular it would good to explore some alternatives for mapping vs
> direct complex attribute support.
>
> My primary worry is some mapping proposals lead to existing clients having
> to change classic ldap queries. I'd like to get to full fidelity
> (bi-directional mapping) support and full backwards compatibility for
> existing clients if possible.
>
> I think a good open discussion might take longer than we have scheduled
> time in the meeting. :)
>
> Phil
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>

---

From: Phil Hunt <[email-masked]>
Date: Tue, 28 Aug 2012 06:32:14 -0700

Hasini,

Yes. The meeting did happen. I'm putting together a draft right now that should capture the discussion and some of the previous work that has been done on mappings.  Would be great to have your input.

The slides I presented are available here:
http://www.ietf.org/proceedings/84/slides/slides-84-scim-0.pdf

Phil

@independentid
www.independentid.com
[email-masked]

On 2012-08-28, at 6:18 AM, Hasini Gunasinghe wrote:

> Hi all,
> 
> Did the below mentioned discussion happen? If so, could some one please brief the list what the outcome of the discussion was? 
> 
> Mapping SCIM attributes to LDAP attributes and vice versa is a common requirement that both the SCIM consumer and SP implementations encounter.
> 
> IMO, we can come up with a Object Class for SCIM User (may be extending inetOrgPerson or a completely new schema) and SCIM Group.
> 
> Would anyone be interested in having a broader discussion about ldap directories and mapping support prior to the scim wg session.
> 
> In particular it would good to explore some alternatives for mapping vs direct complex attribute support.
> 
> My primary worry is some mapping proposals lead to existing clients having to change classic ldap queries. I'd like to get to full fidelity (bi-directional mapping) support and full backwards compatibility for existing clients if possible.
> 
> I think a good open discussion might take longer than we have scheduled time in the meeting. :)
> 
> Phil

---

From: Hasini Gunasinghe <[email-masked]>
Date: Wed, 29 Aug 2012 06:47:01 +0530

Hi Phil,

Thanks for the info.

Looking forward for the draft to provide input..

Thanks,
Hasini.

On Tue, Aug 28, 2012 at 7:02 PM, Phil Hunt <[email-masked]> wrote:

> Hasini,
>
> Yes. The meeting did happen. I'm putting together a draft right now that
> should capture the discussion and some of the previous work that has been
> done on mappings.  Would be great to have your input.
>
>> My primary worry is some mapping proposals lead to existing clients
>> having to change classic ldap queries. I'd like to get to full fidelity