Subject: [scim] schemas question - clarification on use

From: Phil Hunt <[email-masked]>
Date: Wed, 31 Oct 2012 09:08:38 -0700

I was just looking at the "schemas" attribute definition (in core-schema-00) and was wondering whether it is meant to indicate whether the SP's resource "has" a particular schema extension, or whether it means the current JSON structure has the extension schema present?  

For example, if a SP returns a User resource that internally has the Enterprise extension but no enterprise schema attributes were requested, then what should schemas say?

IMHO. I think having schemas always return what is available is always useful. If the client didn't request all attributes, then it already knows whether to look for extended attributes or not.

I just mention this because I believe we have an ticket to review schemas in order to define how we indicate what resource type a json structure represents.   Also, should schemas be part of the "meta" attribute?

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 1 Nov 2012 00:39:44 +0000

> IMHO. I think having schemas always return what is available is always useful.

Agreed.  This would be similar to the objectclass attribute in LDAP.

--Kelly

On Oct 31, 2012, at 11:08 AM, "Phil Hunt" <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>