Subject: Re: [scim] #27: Make support for XML optional or drop it; JSON required

From: Kelly Grizzle <[email-masked]>
Date: Fri, 2 Nov 2012 16:55:07 +0000

Please review the proposed changes to remove XML support from SCIM.  Any feedback is greatly appreciated.  I have attached the full txt documents, which may be easier to read than the diffs (attached to ticket #27).

--Kelly

-----Original Message-----
From: scim issue tracker [mailto:[email-masked]] 
Sent: Friday, November 02, 2012 11:46 AM
To: Kelly Grizzle; [email-masked]
Cc: [email-masked]
Subject: Re: [scim] #27: Make support for XML optional or drop it; JSON required

#27: Make support for XML optional or drop it; JSON required

Comment (by kelly.grizzle@…):

 Attached a diff from revision 206 of
 https://scim.googlecode.com/svn/trunk/specs/ietf with proposed changes.
 At a high level, the following changes were made:

 1) Removed mentions of XML format from both schema and API documents.
 2) Changed section 3 (SCIM Schema Structure) of schema document to be  based off of JSON.  Attribute types are now all derived from JSON.  Binary  and DateTime have no JSON representation, so these both use XML  formatting.
 3) Removed xmlDataFormat from the ServiceProviderConfig resource.
 4) Removed multiValuedAttributeChildName from the Schema resource.
 5) Removed all XML representation examples from the schema document.
 6) Removed application/xml content type from the Data Input/Output Format  section of the API document.
 7) Removed XML examples from the Data Input/Output Format section of the  API document.

-- 
-------------------------------+------------------------------
 Reporter:  bjorn.aannestad@…  |       Owner:  kelly.grizzle@…
     Type:  enhancement        |      Status:  assigned
 Priority:  major              |   Milestone:
Component:  api                |     Version:
 Severity:  -                  |  Resolution:
 Keywords:                     |
-------------------------------+------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/scim/trac/ticket/27#comment:4>
scim <http://tools.ietf.org/scim/>

---

From: Phil Hunt <[email-masked]>
Date: Fri, 2 Nov 2012 13:20:50 -0700 (PDT)

+1

I haven't read the changes yet, but in principal I think this is an important simplification.

Phil

@independentid
www.independentid.com
[email-masked]

On 2012-11-02, at 9:55 AM, Kelly Grizzle wrote:

> <draft-ietf-scim-api-01.txt><draft-ietf-scim-core-schema-01.txt>_______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Melinda Shore <[email-masked]>
Date: Fri, 02 Nov 2012 14:10:51 -0800

> I haven't read the changes yet, but in principal I think this is an important simplification.

I do, too.  It seems to me that if there is interest in an
optional alternate encoding at a later time it could in theory
be specified in a separate document, however a negotiation
mechanism would be needed and those are probably best avoided.
But it also seems to me that if there's an actual need it
will almost certainly be raised before working group last
call.

Melinda

---

From: Phil Hunt <[email-masked]>
Date: Fri, 2 Nov 2012 15:52:04 -0700

Do we need to leave a "hook" such as saying use of accept headers to specify alternate types is acceptable as an extension.

Phil

@independentid
www.independentid.com
[email-masked]

On 2012-11-02, at 3:10 PM, Melinda Shore wrote:

> _______________________________________________
> scim mailing list
> [email-masked]

---

From: Leif Johansson <[email-masked]>
Date: Sat, 03 Nov 2012 18:03:23 +0100

> Do we need to leave a "hook" such as saying use of accept headers to specify alternate types is acceptable as an extension.

As an individual I'd advocate staying away from negotiating features
unless there is real need for them - remember we can always rev
the version of the protocol at some later date when/if such extensibility
becomes necessary. The impact on implementers will be roughly the same.

---

From: Eliot Lear <[email-masked]>
Date: Sat, 03 Nov 2012 20:17:30 +0100

> becomes necessary. The impact on implementers will be roughly the same.

+1.  Options are bad for interoperability.

Eliot

---

From: Hasini Gunasinghe <[email-masked]>
Date: Sun, 4 Nov 2012 18:08:03 +0530

On Fri, Nov 2, 2012 at 10:25 PM, Kelly Grizzle
<[email-masked]>wrote:

> Please review the proposed changes to remove XML support from SCIM.  Any
> feedback is greatly appreciated.  I have attached the full txt documents,
> which may be easier to read than the diffs (attached to ticket #27).
>
> --Kelly
>

+1. JSON is adequate.

Thanks,
Hasini.

>  2) Changed section 3 (SCIM Schema Structure) of schema document to be
>  based off of JSON.  Attribute types are now all derived from JSON.  Binary
>  and DateTime have no JSON representation, so these both use XML
>  formatting.

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 5 Nov 2012 14:17:37 +0000

Section 3.6 of the api doc - Data Input/Output Formats - specifies that the Content-Type and Accept headers are used to declare what content type is included in a request body and what content type is desired for the response.  The only allowed value is "application/json".  This could eventually be an extension point, but as Eliot and others have said I don't think we should open up this option for now.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Eliot Lear
Sent: Saturday, November 03, 2012 2:18 PM
To: Leif Johansson
Cc: [email-masked]
Subject: Re: [scim] #27: Make support for XML optional or drop it; JSON required

On 11/3/12 6:03 PM, Leif Johansson wrote:
> unless there is real need for them - remember we can always rev the 
> version of the protocol at some later date when/if such extensibility 

Eliot

---

From: Leif Johansson <[email-masked]>
Date: Thu, 08 Nov 2012 21:20:57 +0100

> Please review the proposed changes to remove XML support from SCIM.  Any feedback is greatly appreciated.  I have attached the full txt documents, which may be easier to read than the diffs (attach…
There was strong consensus in the WG meeting in Atlanta for dropping
XML in favour of JSON.

If anyone opposes this change, now is the time to speak up, or the chairs
will call consensus on this issue.

        Cheers Leif

---

From: Emmanuel Dreux <[email-masked]>
Date: Mon, 12 Nov 2012 22:30:55 +0000

+1 for dropping XML.

I have also a strong request to use natively FOAF as "identity schema" and exchange data on the wire in Turtle N3 format (eventually JSON-LD).

I found this old article that tries to explain why :https://blogs.oracle.com/bblfish/entry/the_limitations_of_json

We are convinced of the future of semantic web in IAM platforms ( See what others are saying: http://labs.safelayer.com/en/research-and-development/focus-areas/semantic-web/327-semantic-technologies-in-the-identity-management-metasystem).
And we are convinced of the convergence of semantic with IAM.

If IAM platforms use FOAF/RDF and if SAAS platforms also use FOAF (example facebook with open graph apis, F8 apis), it would be great if  we could stay FOAF/RDF from end to end without having to break the chain using JSON on the wire.

Therefore I propose to add Turtle as optional format (or JSON-LD?) and propose FOAF optionally as standard schema for identities.
We have already this needs that we will have to implement. This is for us eventually a marketing issue: Will we call it SCIM or will we implement it without giving it a name :-)

What do you think of making SCIM ready for the future of IAM. I'm strongly confident that this would open the door to a lot of other opportunities that we are not thinking of today.

--
Cordialement / Regards,
Emmanuel Dreux
http://www.cloudiway.com
Tel: +33 4 26 78 17 58
Mobile: +33 6 47 81 26 70
skype: Emmanuel.Dreux

-----Message d'origine-----
De : Leif Johansson [mailto:[email-masked]] 
Envoyé : jeudi 8 novembre 2012 21:21
À : [email-masked]
Objet : Re: [scim] #27: Make support for XML optional or drop it; JSON required

> Please review the proposed changes to remove XML support from SCIM.  Any feedback is greatly appreciated.  I have attached the full txt documents, which may be easier to read than the diffs (attach…
There was strong consensus in the WG meeting in Atlanta for dropping XML in favour of JSON.

If anyone opposes this change, now is the time to speak up, or the chairs will call consensus on this issue.

        Cheers Leif

---

From: Leif Johansson <[email-masked]>
Date: Tue, 13 Nov 2012 11:05:50 +0100

> +1 for dropping XML.

I'm calling consensus on this. Kelly & Melinda - go ahead and close this
issue.