Subject: [scim] Considerations for evaluating the suitability of vCard?

From: Bjorn Aannestad <[email-masked]>
Date: Thu, 01 Nov 2012 17:32:39 -0500

Based on a suggestion from Morteza, Kelly Grizzle and I volunteered to 
assemble some "findings" about vCard for presentation to the group at 
IETF next week.  The same information will be sent to the list for 
everyone to review.

Our goal is to provide some of the information needed for the group to 
make an eventual decision on #19 - "Incorporate vCard as the SCIM schema."

To do that, we're considering the following:
* Extensibility for additional attributes
* Extensibility for additional resource types
* Support for meta-data on attributes and on values

* Alignment with SCIM's charter goals ("simplicity", etc)
* Gap analysis between what SCIM now supports and vCard, leading to a 
sense of how much work there is to bring it in.

* Existence and suitability of a JSON representation
* Degree of adoption, and by whom.  Existence of client libraries.

* Support for complex objects
* Support for relationships between objects

* Ability to work together with the vCard group for advice and 
(potentially) changes to vCard itself

* Any "baggage" that vCard may bring with it

Some of these are objective and easy to answer, others are subjective.

What other aspects should we consider?   Is an important consideration 
missing from the above?

Thanks!
-Bjorn Aannestad

-- 
__________________________________________________________
Bjorn Aannestad | Dir, Product Management | UnboundID Corp
mailto:[email-masked] | 512-769-6461

---

From: Likepeng <[email-masked]>
Date: Fri, 2 Nov 2012 01:18:32 +0000

There is an available draft related to this topic:
http://datatracker.ietf.org/doc/draft-greevenbosch-scim-vcard-mapping/

We can use that as a baseline for discussion, or you guys can work together for this topic.

Kind Regards
Kepeng

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Bjorn Aannestad
发送时间: 2012年11月2日 6:33
收件人: scim WG
主题: [scim] Considerations for evaluating the suitability of vCard?

Based on a suggestion from Morteza, Kelly Grizzle and I volunteered to assemble some "findings" about vCard for presentation to the group at IETF next week.  The same information will be sent to the list for everyone to review.

Our goal is to provide some of the information needed for the group to make an eventual decision on #19 - "Incorporate vCard as the SCIM schema."

* Alignment with SCIM's charter goals ("simplicity", etc)
* Gap analysis between what SCIM now supports and vCard, leading to a sense of how much work there is to bring it in.

Thanks!
-Bjorn Aannestad

--
__________________________________________________________
Bjorn Aannestad | Dir, Product Management | UnboundID Corp mailto:[email-masked] | 512-769-6461

---

From: Bjorn Aannestad <[email-masked]>
Date: Fri, 02 Nov 2012 10:30:33 -0500

Thank you very much for pointing that out! It contains good work that we
can simply refer to.

-Bjorn