Subject: [scim] Proposal to resolve as "wontfix": #19: Incorporate the vCard model into the schema

From: Bjorn Aannestad <[email-masked]>
Date: Mon, 19 Nov 2012 14:07:04 -0600

Hi all,

Based on the discussions in Atlanta and the rough consensus sampling 
there, I'd like to propose that we close the vCard adoption question by 
resolving to NOT adopt the vCard attribute schema, nor its JSON 
representation.

Issue #19 has my summary of the additional points that have been made 
since the meeting.

Two important notes:
1. The work to produce a vCard-SCIM mapping is, I believe, still 
valuable and should continue.  This is 
draft-greevenbosch-scim-vcard-mapping.
2. I have created a separate issue (#30) for adopting the IANA 
registration aspects of vCard into SCIM.   This was proposed as one of 
the important aspects of vCard to consider.

Any other vCard aspects that we feel could be worth incorporating into 
SCIM can also be made into separate issues.

However, let's close the big question which is holding up the other SCIM 
schema adjustments.

Please respond with assent or objections, especially if you feel a 
strong case can still be made for vCard-in-SCIM.

Regards,
-Bjorn

-- 
__________________________________________________________
Bjorn Aannestad | Dir, Product Management | UnboundID Corp
mailto:[email-masked] | 512-769-6461

---

From: Igor Faynberg <[email-masked]>
Date: Mon, 19 Nov 2012 17:14:31 -0500

+1

Igor

On 11/19/2012 3:07 PM, Bjorn Aannestad wrote:
> there, I'd like to propose that we close the vCard adoption question 
> by resolving to NOT adopt the vCard attribute schema, nor its JSON 
> representation.
>
> However, let's close the big question which is holding up the other 
> SCIM schema adjustments.
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Melinda Shore <[email-masked]>
Date: Mon, 19 Nov 2012 13:31:34 -0900

> However, let's close the big question which is holding up the other SCIM

That seems reasonable to me, but that does open other questions
with regard to the schema.  I believe that using inetOrgPerson as
the basis for the core SCIM schema was kicked to the curb before
the working group was chartered and that should probably be
documented lest some helpful participant put forth a proposal
to use it.

But I think it might be worth taking some care that in closing
the ticket the working group isn't saying that there will never
be work on mapping between vCard and SCIM, but just that the
core SCIM schema will not be based on vCard.

Melinda

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Nov 2012 23:36:04 +0100

> strong case can still be made for vCard-in-SCIM.
I think we need to hear from some of the people who were at the mic
in ATL on this issue.

            Cheers Leif

---

From: Phil Hunt <[email-masked]>
Date: Mon, 19 Nov 2012 15:04:47 -0800

In the spirit of documentation, I think the key issue for inetorgperson is how LDAP defines attributes.  For example, LDAP has no support for complex attributes - address information is spread across several attributes like locality, zipcode, etc.  The effect is only one address is possible for most scenarios. 

This is in stark contrast to poco and vcards which support multiple typed addresses and seemed to be a founding requirement.  Can someone confirm the history here?

My SCIM Directory draft goes into this issue at some length.  Dual bi-directional mapping support is a complex issue.

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Bjorn Aannestad <[email-masked]>
Date: Mon, 19 Nov 2012 17:55:06 -0600

On 11/19/2012 16:31, Melinda Shore wrote:
> But I think it might be worth taking some care that in closing the 
> ticket the working group isn't saying that there will never be work on 
> mapping between vCard and SCIM, but just that the core SCIM schema 
> will not be based on vCard. 

That's right, Melinda.   The following text appear in the issue comment:
"The valuable work on the SCIM-to-vCard mapping draft should continue as 
a separate effort"

-Bjorn

---

From: Likepeng <[email-masked]>
Date: Tue, 20 Nov 2012 02:31:06 +0000

>The work to produce a vCard-SCIM mapping is, I believe, still valuable and should continue.  This is draft-greevenbosch-scim-vcard-mapping.

+1.

Kind Regards
Kepeng

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Bjorn Aannestad
发送时间: 2012年11月20日 4:07
收件人: scim WG
主题: [scim] Proposal to resolve as "wontfix": #19: Incorporate the vCard model into the schema

Hi all,

Based on the discussions in Atlanta and the rough consensus sampling there, I'd like to propose that we close the vCard adoption question by resolving to NOT adopt the vCard attribute schema, nor its JSON representation.

Issue #19 has my summary of the additional points that have been made since the meeting.

Two important notes:
1. The work to produce a vCard-SCIM mapping is, I believe, still valuable and should continue.  This is draft-greevenbosch-scim-vcard-mapping.
2. I have created a separate issue (#30) for adopting the IANA 
registration aspects of vCard into SCIM.   This was proposed as one of 
the important aspects of vCard to consider.

Any other vCard aspects that we feel could be worth incorporating into SCIM can also be made into separate issues.

However, let's close the big question which is holding up the other SCIM schema adjustments.

Please respond with assent or objections, especially if you feel a strong case can still be made for vCard-in-SCIM.

Regards,
-Bjorn

--
__________________________________________________________
Bjorn Aannestad | Dir, Product Management | UnboundID Corp mailto:[email-masked] | 512-769-6461

---

From: Chris Phillips <[email-masked]>
Date: Tue, 20 Nov 2012 08:39:10 -0500

+1 To Bjorn's email below resolving to NOT adopt the vCard Attribute schema, nor its JSON representation.

Chris.

From: Igor Faynberg <[email-masked]<mailto:[email-masked]>>
Organization: Alcatel-Lucent
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Monday, 19 November, 2012 5:14 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Proposal to resolve as "wontfix": #19: Incorporate the vCard model into the schema

+1

Igor

Two important notes:
1. The work to produce a vCard-SCIM mapping is, I believe, still valuable and should continue.  This is draft-greevenbosch-scim-vcard-mapping.
2. I have created a separate issue (#30) for adopting the IANA registration aspects of vCard into SCIM.   This was proposed as one of the important aspects of vCard to consider.

Regards,
-Bjorn

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 20 Nov 2012 14:09:17 +0000

+1

I agree that Bert's mapping work is very valuable and also agree with Peter's sentiment that if we were starting from scratch vCard would be a great place to start.  Given the adoption and momentum of SCIM I am +1 for keeping the current schema.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Phillips
Sent: Tuesday, November 20, 2012 7:39 AM
To: [email-masked]
Subject: Re: [scim] Proposal to resolve as "wontfix": #19: Incorporate the vCard model into the schema

Chris.

+1

Igor

Two important notes:

Regards,
-Bjorn

scim mailing list

---

From: Bert Greevenbosch <[email-masked]>
Date: Sat, 24 Nov 2012 01:04:20 +0000

+1 for keeping the current schema. I will be happy to continue the work on the mapping draft.

Best regards,
Bert

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kelly Grizzle
Sent: 20 November 2012 22:09
To: Chris Phillips; [email-masked]
Subject: Re: [scim] Proposal to resolve as "wontfix": #19: Incorporate the vCard model into the schema

+1

--Kelly

Chris.

+1

Igor

Two important notes:

Regards,
-Bjorn

scim mailing list

---

From: Leif Johansson <[email-masked]>
Date: Sat, 24 Nov 2012 16:28:20 +0100

> by resolving to NOT adopt the vCard attribute schema, nor its JSON
So far this sounds like pretty solid consensus but I'd like to give the WG
a _little_ more time collecting +1/-1's since there were a few people at
the mic in ATL if not arguing for vCard, at least being very much on the
fence.

By a little more time I mean at least a week(ish) since we're in the middle
of a major US holiday.

            Cheers Leif

---

From: Anthony Nadalin <[email-masked]>
Date: Sat, 24 Nov 2012 16:21:06 +0000

So the way this question is proposed this does not close the question of schema or representation, it just says that we won't adopt the vCard proposal but leave us open to changing existing schema and representation as I'm not really happy with existing proposal, as I think it can be far simpler with better extensibility. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Saturday, November 24, 2012 7:28 AM
To: [email-masked]
Subject: Re: [scim] Proposal to resolve as "wontfix": #19: Incorporate the vCard model into the schema

> by resolving to NOT adopt the vCard attribute schema, nor its JSON 
So far this sounds like pretty solid consensus but I'd like to give the WG a _little_ more time collecting +1/-1's since there were a few people at the mic in ATL if not arguing for vCard, at least being very much on the fence.

By a little more time I mean at least a week(ish) since we're in the middle of a major US holiday.

            Cheers Leif

---

From: Chris Phillips <[email-masked]>
Date: Tue, 27 Nov 2012 10:05:48 -0500

Hi Anthony,

It has always been a challenge to try and capture which attributes should
be core and what should exist in the extensions area using an 80/20 style
rule.  Coupled with complex attribute representation many data
constructs/relationships can be encapsulated in the SCIM schema.

Can you describe in more depth the comment '...it can be far simpler with
better extensibility.' so we can better understand where you see the gaps?

Chris.

On 12-11-24 11:21 AM, "Anthony Nadalin" <[email-masked]> wrote:

>So the way this question is proposed this does not close the question of
>schema or representation, it just says that we won't adopt the vCard
>proposal but leave us open to changing existing schema and representation
>as I'm not really happy with existing proposal, as I think it can be far
>simpler with better extensibility.
>
>So far this sounds like pretty solid consensus but I'd like to give the
>WG a _little_ more time collecting +1/-1's since there were a few people
>at the mic in ATL if not arguing for vCard, at least being very much on
>the fence.
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 27 Nov 2012 22:44:52 -0700

On 11/24/12 8:28 AM, Leif Johansson wrote:
>> Based on the discussions in Atlanta and the rough consensus
>> sampling there, I'd like to propose that we close the vCard
>> adoption question by resolving to NOT adopt the vCard attribute
>> schema, nor its JSON representation.
>> 
> So far this sounds like pretty solid consensus but I'd like to give
> the WG a _little_ more time collecting +1/-1's since there were a
> few people at the mic in ATL if not arguing for vCard, at least
> being very much on the fence.
> 

Hej Leif,

I was one of those people at the mic. My sense is still that, if we
were designing from scratch, it might sense to look seriously at
vCard, but that at this point there's really no deeply compelling
reason (e.g., code reuse or interoperability) to change the format
used in SCIM.

However, I reiterate that it's really important for this WG to "get it
right" with regard to the extensibility model, and secondarily with
regard to registration of extensions. I see the SCIM<=>vCArd mapping
as tertiary but still of interest.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/