Subject: [scim] Question regarding RFC 7642

From: Wouter de Wit <[email-masked]>
Date: Mon, 2 Jan 2017 14:44:34 +0000

Hello,

I was going through the SCIM specs and protocol and found a typo in one of the examples that make it quite confusing. 
Source location:
https://tools.ietf.org/html/rfc7642 <https://tools.ietf.org/html/rfc7642>

in:

2.3.1.  CSP->CSP: Create Identity (Push)

   In this scenario, two CSPs (CSP-1 and CSP-2) have a shared service
   agreement in place that requires the exchange of Cloud Service User
   (CSU) accounts.  CSP-1 receives a Create Identity trigger action from
   its Enterprise Cloud Subscriber (ECS-1).  CSP-1 creates a local user
   account for the new CSU.  CSP-1 then pushes the new CSU joiner push
   request downstream to CSU-2 and gets confirmation that the account
   was successfully created.  After receiving the confirmation from CSP-
   2, CSP-1 sends an acknowledgment to the requesting ECS.

Where it reads ‘… downstream to CSU-2…’ it should read ‘… downstream to CSP-2…’.

Just for information. 

Kind regards / Mit freundlichen Grüßen / Met vriendelijke groeten,
 
Wouter

Wouter de Wit | Solution Architect
[email-masked] <mailto:[email-masked]>
www.iwelcome.com <http://www.iwelcome.com/>

Tel.	+31 (0)33 445 05 50 <tel:+31 33 44 50 550>
Mob.	+31 (0)62 110 88 18 <tel:+31633365489>
Skype.	wouterdewitnl <skype:maarten.stultjens?call>

The information in this Internet email is confidential and may be legally privileged. It is intended solely for the addressee. Access to this Internet email by anyone else is unauthorized. If you are not the intended recipient, any disclosure, copying, distribution or any action taken or omitted to be taken in reliance on it is prohibited and may be unlawful. When addressed to our clients any opinions or advice contained in this Internet email are subject to the terms and conditions expressed in any applicable governing iWelcome terms of business or client engagement letter. iWelcome is a registered trademark of iWelcome BV.

---

From: Leif Johansson <[email-masked]>
Date: Mon, 2 Jan 2017 17:13:02 +0100

On 2017-01-02 15:44, Wouter de Wit wrote:
> Hello,
> 
> I was going through the SCIM specs and protocol and found a typo in one
> of the examples that make it quite confusing. 
> Source location:
> https://tools.ietf.org/html/rfc7642

Why don't you submit an errata for that one

> www.iwelcome.com <http://www.iwelcome.com>
> 
> 
> The information in this Internet email is confidential and may be
> legally privileged. It is intended solely for the addressee. Access to
> this Internet email by anyone else is unauthorized. If you are not the
> intended recipient, any disclosure, copying, distribution or any action
> taken or omitted to be taken in reliance on it is prohibited and may be
> unlawful. When addressed to our clients any opinions or advice contained
> in this Internet email are subject to the terms and conditions expressed
> in any applicable governing iWelcome terms of business or client
> engagement letter. iWelcome is a registered trademark of iWelcome BV.
> 
> 
> 
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>