Subject: [scim] Unique Attributes

From: Gayan Gunawardana <[email-masked]>
Date: Sun, 5 Feb 2017 10:42:49 +0530

According to [1] userName seems to be an unique attribute where duplicate
resources identified with userName. Similarly

Is Group "displayName" an unique attribute ?

If answer is no, Does implementation have flexibility to decide uniqueness ?

[1]https://tools.ietf.org/html/rfc7644#section-3.3

Thanks,
Gayan

-- 
Gayan Gunawardana
Software Engineer; WSO2 Inc.; http://wso2.com/
Email: [email-masked]
Mobile: +94 (71) 8020933

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Mon, 6 Feb 2017 21:21:50 -0800

Sorry I missed this one earlier. 

IMO The schema in the spec sets the default expectations and what clients will typically expect. 

But yes you can change uniqueness-the uniqueness for each attribute should be discoverable in your schemas endpoint. 

Phil

> On Feb 4, 2017, at 9:12 PM, Gayan Gunawardana <[email-masked]> wrote:
> 
> According to [1] userName seems to be an unique attribute where duplicate resources identified with userName. Similarly 
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Gayan Gunawardana <[email-masked]>
Date: Tue, 7 Feb 2017 22:21:00 +0530

On Tue, Feb 7, 2017 at 10:51 AM, Phil Hunt (IDM) <[email-masked]>
wrote:

> But yes you can change uniqueness-the uniqueness for each attribute should
> be discoverable in your schemas endpoint.
>
Yes this is more logical. Thanks Phil.