Subject: [scim] Addition attributes for SCIM meta data

From: Gayan Gunawardana <[email-masked]>
Date: Tue, 28 Feb 2017 23:00:18 +0530

Hi All,

According to [1] available meta data attributes are resourceType, created,
lastModified, location and version. Is there any flexibility to define
custom meta data attributes ?

Suppose I want to put new attribute called "state" under meta data, which
says whether user is in active state or inactive state.

How can I achieve such a requirement ?

[1] https://tools.ietf.org/html/rfc7643#section-3.1
-- 
Gayan Gunawardana
Software Engineer; WSO2 Inc.; http://wso2.com/
Email: [email-masked]
Mobile: +94 (71) 8020933

---

From: Phil Hunt <[email-masked]>
Date: Tue, 28 Feb 2017 13:01:36 -0800

meta attributes are defined in the core spec as common to every object. Extension would require an RFC which would include requirements for discovery and versioning, etc.

Phil

Oracle Corporation, Identity Cloud Services & Identity Standards
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Feb 28, 2017, at 9:30 AM, Gayan Gunawardana <[email-masked]> wrote:
> 
> Hi All,
> 
> According to [1] available meta data attributes are resourceType, created, lastModified, location and version. Is there any flexibility to define custom meta data attributes ?
> 
> Suppose I want to put new attribute called "state" under meta data, which says whether user is in active state or inactive state. 
> 
> [1] https://tools.ietf.org/html/rfc7643#section-3.1 <https://tools.ietf.org/html/rfc7643#section-3.1>
> -- 
> Gayan Gunawardana
> Software Engineer; WSO2 Inc.; http://wso2.com/ <http://wso2.com/>
> Email: [email-masked] <mailto:[email-masked]> 
> Mobile: +94 (71) 8020933
>  <>_______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 28 Feb 2017 21:05:46 +0000

Can you just use the "active" attribute on User?

If not, another option is to add a schema extension that exposes a "state" attribute, but doesn't put it in the meta attribute.

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Tuesday, February 28, 2017 3:02 PM
To: Gayan Gunawardana <[email-masked]>
Cc: [email-masked]
Subject: Re: [scim] Addition attributes for SCIM meta data

Phil

Oracle Corporation, Identity Cloud Services & Identity Standards
@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On Feb 28, 2017, at 9:30 AM, Gayan Gunawardana <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

[1] https://tools.ietf.org/html/rfc7643#section-3.1
--
Gayan Gunawardana
Software Engineer; WSO2 Inc.; http://wso2.com/
Email: [email-masked]<mailto:[email-masked]>
Mobile: +94 (71) 8020933
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Gayan Gunawardana <[email-masked]>
Date: Wed, 1 Mar 2017 07:09:54 +0530

On Wed, Mar 1, 2017 at 2:35 AM, Kelly Grizzle <[email-masked]>
wrote:

> Can you just use the “active” attribute on User?
>
According to schema definition "active" attribute is a boolean. In my case
I have couple of value under attribute "state" (not only active and
inactive).

>
>
> If not, another option is to add a schema extension that exposes a “state”
> attribute, but doesn’t put it in the meta attribute.
>
Yes this seems to be a good option.

>
>
> --Kelly
>
>
>
> *From:* scim [mailto:[email-masked]] *On Behalf Of *Phil Hunt
> *Sent:* Tuesday, February 28, 2017 3:02 PM
> *To:* Gayan Gunawardana <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [scim] Addition attributes for SCIM meta data
>
>
>
> meta attributes are defined in the core spec as common to every object.
> Extension would require an RFC which would include requirements for
> discovery and versioning, etc.
>
>
>
> Phil
>
>
>
> www.independentid.com
> [email-masked]
> Mobile: +94 (71) 8020933 <+94%2071%20802%200933>
>