Subject: [scim] Does SCIM 2.0 have a compliance test suite?

From: Darshana Gunawardana <[email-masked]>
Date: Tue, 7 Feb 2017 12:06:41 +0530

Hi,

Is there a test tool that can used to check compliance with the SCIM 2.0
specification?

The site [1] specifies that there is an ongoing effort. Is this an open
source effort where someone interested can try prototype versions and
contribute for the development?

[1] http://www.simplecloud.info/
[2] "Work on SCIM 2.0 tests is under development and there are currently no
support for the enterprise extension"

Thanks,
-- 
With Regards,

Darshana Gunawardana,
Alumni : Dept. of Computer Science & Engineering,
University of Moratuwa,
Sri Lanka

---

From: Samuel Erdtman <[email-masked]>
Date: Tue, 07 Feb 2017 07:36:34 +0000

There is currently no such tool as far as I know.

That it says ongoing is a bit too optimistic, there is no ongoing work as
far as I know.

You are not the only one asking for this so maybe a few persons could do
some cooperation and create something.

On Tue, 7 Feb 2017 at 07:37, Darshana Gunawardana <[email-masked]>
wrote:

> [2] "Work on SCIM 2.0 tests is under development and there are currently
> no support for the enterprise extension"
>
> Thanks,
> --
> With Regards,
>
> Darshana Gunawardana,
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>

---

From: Darshana Gunawardana <[email-masked]>
Date: Tue, 7 Feb 2017 13:45:16 +0530

Hi Samuel,

Thanks for the response..!

My colleges from WSO2 are in the process of implementing SCIM 2.0 server
and currently people working on improving the test coverage on that.

If there is no work done on this, we can check on creating common SCIM 2.0
suite and contributing back to the community. Wanted to check whether it
would be useful to implement common SCIM 2.0 suite thing.

If this is something useful to have, we can check on possible ways of
getting interested persons...

And can I know references on the implementations on the test suite done on
SCIM 1.1? So I can get an idea on the current design and effort needed to
implement in that way.

Thanks,
Darshana

-- 
With Regards,

Darshana Gunawardana,

---

From: Samuel Erdtman <[email-masked]>
Date: Tue, 28 Feb 2017 17:47:42 +0100

The SCIM 1.1 tests where made by me and Erik Wahlström.

The code can be found here <https://github.com/erwah/scimproxy> and here
<https://github.com/erdtman/simplecloud.info>

Don´t think you should rely to much on the structure setup there.

//Samuel

---

From: Phil Hunt <[email-masked]>
Date: Tue, 28 Feb 2017 11:35:20 -0800

There has been discussion about having OpenID Foundation host some tests. However, so far, nobody has volunteered to write the tests or fund their support.  If we can generate interest, maybe we can make it happen.

Note: The IETF does not seem to handle inter-op test suites and certifications.  At least not in my experience.

Phil

Oracle Corporation, Identity Cloud Services & Identity Standards
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Feb 7, 2017, at 12:15 AM, Darshana Gunawardana <[email-masked]> wrote:
> 
> Hi Samuel,
> 
> My colleges from WSO2 are in the process of implementing SCIM 2.0 server and currently people working on improving the test coverage on that.
> 
> If there is no work done on this, we can check on creating common SCIM 2.0 suite and contributing back to the community. Wanted to check whether it would be useful to implement common SCIM 2.0 suite thing.
> 
> If this is something useful to have, we can check on possible ways of getting interested persons...
> 
> And can I know references on the implementations on the test suite done on SCIM 1.1? So I can get an idea on the current design and effort needed to implement in that way.
> 
> Thanks,
> Darshana
> 
> On Tue, Feb 7, 2017 at 1:06 PM, Samuel Erdtman <[email-masked] <mailto:[email-masked]>> wrote:
> That it says ongoing is a bit too optimistic, there is no ongoing work as far as I know.
> 
> You are not the only one asking for this so maybe a few persons could do some cooperation and create something.
> 
> 
> On Tue, 7 Feb 2017 at 07:37, Darshana Gunawardana <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
> Is there a test tool that can used to check compliance with the SCIM 2.0 specification?
> 
> The site [1] specifies that there is an ongoing effort. Is this an open source effort where someone interested can try prototype versions and contribute for the development? 
> 
> [1] http://www.simplecloud.info/ <http://www.simplecloud.info/>
> [2] "Work on SCIM 2.0 tests is under development and there are currently no support for the enterprise extension"
> 
> Thanks,
> -- 
> With Regards,
> 
> Darshana Gunawardana,
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>
> 
> 
> 
> -- 
> With Regards,
> 
> Darshana Gunawardana,
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>