Subject: [scim] Question regarding multiple User Stores

From: Gayan Gunawardana <[email-masked]>
Date: Fri, 10 Feb 2017 13:22:37 +0530

For given SCIM implementation if I have multiple user stores underneath.

Idea of multiple user stores from organizational perspective, suppose I
have LDAP for employee information and separate AD for customer
information.

How can I list or filter result from customer user store ?

Similarly how can I add a user to customer user store ?

 What is the best way to specify user store domain in the SCIM request?
-- 
Gayan Gunawardana
Software Engineer; WSO2 Inc.; http://wso2.com/
Email: [email-masked]
Mobile: +94 (71) 8020933

---

From: Gayan Gunawardana <[email-masked]>
Date: Sun, 12 Feb 2017 13:43:04 +0530

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 14 Feb 2017 18:44:27 +0000

There are different options here depending on whether it is feasible for the server to present a single /Users endpoint across both stores (for example, can you query, sort, and page between both stores when someone makes a request against /Users).

If possible, I would say that it would be preferable to include both under the /Users endpoint.  You could define a new attribute in an extended schema that indicates which store the user is a part of.

If using a single, unified /Users endpoint is not technically feasible, then you’ll probably need to create a new ResourceType for one of these.

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Gayan Gunawardana
Sent: Sunday, February 12, 2017 2:13 AM
To: [email-masked]; Phil Hunt <[email-masked]>
Subject: Re: [scim] Question regarding multiple User Stores

On Fri, Feb 10, 2017 at 1:22 PM, Gayan Gunawardana <[email-masked]<mailto:[email-masked]>> wrote:
For given SCIM implementation if I have multiple user stores underneath.

Idea of multiple user stores from organizational perspective, suppose I have LDAP for employee information and separate AD for customer information.
How can I list or filter result from customer user store ?
Similarly how can I add a user to customer user store ?

 What is the best way to specify user store domain in the SCIM request?
--
Gayan Gunawardana
Software Engineer; WSO2 Inc.; http://wso2.com/
Email: [email-masked]<mailto:[email-masked]>
Mobile: +94 (71) 8020933

--
Gayan Gunawardana
Software Engineer; WSO2 Inc.; http://wso2.com/
Email: [email-masked]<mailto:[email-masked]>
Mobile: +94 (71) 8020933

---

From: Gayan Gunawardana <[email-masked]>
Date: Sat, 18 Feb 2017 19:24:39 +0530

HI Kelly,

On Wed, Feb 15, 2017 at 12:14 AM, Kelly Grizzle <[email-masked]
> wrote:

> There are different options here depending on whether it is feasible for
> the server to present a single /Users endpoint across both stores (for
> example, can you query, sort, and page between both stores when someone
> makes a request against /Users).
>
Yes. Idea is to present single /Users endpoint across both stores.

>
>
> If possible, I would say that it would be preferable to include both under
> the /Users endpoint.  You could define a new attribute in an extended
> schema that indicates which store the user is a part of.
>
Of course this is great. Thanks Kelly.

>
>
> If using a single, unified /Users endpoint is not technically feasible,
> then you’ll probably need to create a new ResourceType for one of these.
>
>
>
> --Kelly
>
>
>
> *From:* scim [mailto:[email-masked]] *On Behalf Of *Gayan
> Gunawardana
> *Sent:* Sunday, February 12, 2017 2:13 AM
> *To:* [email-masked]; Phil Hunt <[email-masked]>
> *Subject:* Re: [scim] Question regarding multiple User Stores
>
>
>
>
>
>
>
> Mobile: +94 (71) 8020933 <+94%2071%20802%200933>
>
>
>
>
> --
>
> Gayan Gunawardana
>
> Mobile: +94 (71) 8020933 <+94%2071%20802%200933>
>