Subject: [Simple] Is it possible to receive success/failure report with overlapping byte range.

From: prasun bheri <[email-masked]>
Date: Wed, 11 Jan 2012 12:57:44 +0530

Hello Group,
While receiving success/failure reports. is it possible to
receive overlapping byte range.

for example
is it possible to receive first success report with byte range 1-200. and
second
success report with byte range 100-300.

Thanks & Regards
Prasun Bheri

---

From: Ben Campbell <[email-masked]>
Date: Wed, 11 Jan 2012 08:14:33 -0600

On Jan 11, 2012, at 1:27 AM, prasun bheri <[email-masked]> wrote:

> 
> Hello Group,
> While receiving success/failure reports. is it possible to receive overlapping byte range.
> 
> for example 
> is it possible to receive first success report with byte range 1-200. and second 

I assume you are talking about MSRP.

While it would be odd to get such a response without having actually sent overlapping chunks, it's not forbidden. Postel's maxim would suggest that an implementation should be able to handle it if they receive it. It seems reasonable to treat such reports as cumulative.

Hope this helps!

Ben.