Subject: [Simple] Multiple m= lines

From: venu Y <[email-masked]>
Date: Mon, 20 Feb 2012 13:40:33 +0530

Hi all,

Case: Client A wants to offer two file transfers(two m= lines) using MSRP
in an SIP session with client B.

Client B, on receiving the offer, displays the two file names with options
(Accept/Reject) to user and waits for his response.

If the user, accepts first file and didn't inform any thing about second
file... then how should Client B should respond?

1. Should he force the user to give response to all offers at a time..

2. Should he wait for a stipulated time, if no response is received from
user, then he should opt for a default configured behaviour.

3. Is there any provision in offer/answer model, to inform the other party
that..

one m= line status is ready and other m= line decision is in pending...

As per SIP protocol, 200 O.K should be given with in 32 seconds.

Thanks for your time.

-- 
With Regards
Venu
[email-masked]

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 20 Feb 2012 10:06:49 +0100

> As per SIP protocol, 200 O.K should be given with in 32 seconds.

Not true. MSRP is offered within an INVITE so there is "no limit"
(other than the "Expires" value in the INVITE when present, or the max
time the UAC or UAS allows during ringing/progress state).

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Saúl Ibarra Corretgé <[email-masked]>
Date: Mon, 20 Feb 2012 10:12:49 +0100

Hi,

On Feb 20, 2012, at 9:10 AM, venu Y wrote:

> Hi all,
> 
> Case: Client A wants to offer two file transfers(two m= lines) using MSRP in an SIP session with client B.
> 
> Client B, on receiving the offer, displays the two file names with options (Accept/Reject) to user and waits for his response.
> 
> If the user, accepts first file and didn't inform any thing about second file... then how should Client B should respond?
> 

What do you mean by "didn't inform anything"? How does that 200 OK look like?

> 1. Should he force the user to give response to all offers at a time..

Of course, when you send the 200 OK all offered streams must be present in the answer, if you want to reject a stream just set the port to 0.

> 2. Should he wait for a stipulated time, if no response is received from user, then he should opt for a default configured behaviour.
> 
> 3. Is there any provision in offer/answer model, to inform the other party that.. 
> 

I don't think that's possible. What you could do, for example, is learn the information (filename, hash, size) on the stream you don't want to accept right now, reject it and send a re-INVITE later, adding a new stream with that data and direction 'recvonly', thus *requesting* that the remote party sends you that file.

Regards,

--
Saúl Ibarra Corretgé
AG Projects

---

From: venu Y <[email-masked]>
Date: Mon, 20 Feb 2012 15:03:10 +0530

Thanks for quick response.

On Mon, Feb 20, 2012 at 2:42 PM, Saúl Ibarra Corretgé
<[email-masked]>wrote:

> > Client B, on receiving the offer, displays the two file names with
> options (Accept/Reject) to user and waits for his response.
> >
> Of course, when you send the 200 OK all offered streams must be present in
> the answer, if you want to reject a stream just set the port to 0.
>
> I don't think that's possible. What you could do, for example, is learn
> the information (filename, hash, size) on the stream you don't want to
> accept right now, reject it and send a re-INVITE later, adding a new stream
> with that data and direction 'recvonly', thus *requesting* that the remote
> party sends you that file.
>
>
> Regards,
>
> --
> Saúl Ibarra Corretgé
> AG Projects
>
>
>
>

-- 
With Regards
Venu
93484 89945
[email-masked]