Subject: Re: [Simple] draft-ietf-simple-msrp-cema-05 WGLC comments - Section 4 and editorials (Ben)

From: Christer Holmberg <[email-masked]>
Date: Fri, 1 Jun 2012 09:39:27 +0200

Hi,
 
>>> I don't think the definition needs to describe the entire process. could we just say "name of the peer", perhaps with a disclaimer that that the meaning of "name" is as described by the protocol?
>> 
>> So, something like:
>> 
>> 
>> 	"Name Based Authentication: An authentication method in which an 
>> 	endpoint receives an X.509 certificate from its peer as part of the 
>> 	TLS authentication. The endpoint validates that a chain of issuers exists 
>> 	from the certificate to a trusted certification authority, and that the 
>> 	certificate contains the name (as indicated in SIP/SDP) of the 
>> 	peer."
>> 
>> 
>
> Works for me.

Actually, we noted that the suggested text does not take RFC 6072 into consideration. So, what about:

	"Name Based Authentication: An authentication method in which an 
	endpoint receives an X.509 certificate from its peer as part of the 
	TLS authentication. The endpoint verifies that the identity associated 
	with the certificate corresponds to that of the peer (as indicated in SIP/SDP) 
	and that the binding of the identity to the public key was done by a party which the
	endpoint trusts. This definition includes both traditional certificates issued by a 
	well-known certification authority as well as self-signed certificates published via 
	a SIP Certificate Management Service [RFC6072] and other similar mechanisms."

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Fri, 1 Jun 2012 16:17:47 -0500

> 	a SIP Certificate Management Service [RFC6072] and other similar mechanisms."

Either version works for me.

Thanks!

Ben.