Subject: [Simple] Regarding MSRP(rfc 4975)

From: prasun bheri <[email-masked]>
Date: Mon, 27 Aug 2012 13:44:28 +0530

Hello Group,

I have two queries in regard to rfc 4975 (MSRP)

1. When a local end point receives a REPORT request that contains a message
id which is not known to local end point, what should be done?
Is it ok to respond with 400 Bad request?

2. When a Request or Response is received with unknown session id local EP
should respond with 481 transaction response.
in this case, while building 481 response should the from-path contain a
session id or not?

Thanks & Regards
Prasun Bheri

---

From: prasun bheri <[email-masked]>
Date: Mon, 27 Aug 2012 14:36:48 +0530

Hi,
Got the answer to first question. response should not be given for report.
second question. leave the session id empty in from path.

Thanks & Regards
Prasun

On Mon, Aug 27, 2012 at 1:44 PM, prasun bheri <[email-masked]>wrote:

> 1. When a local end point receives a REPORT request that contains a
> message id which is not known to local end point, what should be done?

---

From: Ben Campbell <[email-masked]>
Date: Mon, 27 Aug 2012 08:39:10 -0500

In regards to question 2--you also do not respond to a response.

Thanks!

Ben.

On Aug 27, 2012, at 4:06 AM, prasun bheri <[email-masked]> wrote:

> Hi,
> Got the answer to first question. response should not be given for report. second question. leave the session id empty in from path.
> 
> Thanks & Regards
> Prasun
> 
> 
> On Mon, Aug 27, 2012 at 1:44 PM, prasun bheri <[email-masked]> wrote:
> Hello Group,
> 
> 1. When a local end point receives a REPORT request that contains a message id which is not known to local end point, what should be done?
> 2. When a Request or Response is received with unknown session id local EP should respond with 481 transaction response. 
> in this case, while building 481 response should the from-path contain a session id or not?
> 
> Thanks & Regards
> Prasun Bheri
> 
> 
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple