Subject: Re: [Simple] nickname length

From: "Miguel A. Garcia" <[email-masked]>
Date: Tue, 2 Oct 2012 13:32:44 +0200

Hi Peter:

It is true we don't have a limit in the nickname, for the same reason we 
don't have a limit in MSRP URIs, SIP URIs, Display-Names in SIP, etc.

I don't mind setting the limit to 1023 bytes as you mentioned.

/Miguel

On 22/09/2012 5:18, Peter Saint-Andre wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> The more I think about this, the more I realize that nickname length
> is best left up to protocol specifications for MSRP and XMPP, not the
> nickname spec itself. Unless there are objections, I plan to remove
> the relevant paragraph from draft-ietf-precis-nickname.
>
> On 9/21/12 2:30 PM, Peter Saint-Andre wrote:
>> Are there any limits on the length of a nickname in
>> draft-ietf-simple-chat? I don't see any, nor do I see any on
>> quoted-string in RFC 4975. In draft-ietf-precis-nickname, I have a
>> limit of 1023 bytes, which comes from RFC 6122 and is probably
>> longer than most people will ever use. I received one comment that
>> the nickname spec is the wrong place to be imposing such limits,
>> and that makes sense (XMPP can impose one limit and MSRP can impose
>> another limit, etc.). But I figured it would be good to check here
>> before making a change to draft-ietf-precis-nickname on this
>> point.
>>
>> Thanks!
>>
>> Peter
>>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
> Comment: Using GnuPG with Mozilla - http://www.enigmail.net/
>
> iEYEARECAAYFAlBdLgMACgkQNL8k5A2w/vzpfQCdGeCGvS29+7CrMIKwzKeP4HVO
> vBUAnAgvo5gFc0Ksq7tpPL3UvybRFQh/
> =ZMK/
> -----END PGP SIGNATURE-----
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
>

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 08 Oct 2012 11:54:53 -0600

My conclusion is: let the XMPP folks set a limit of 1023 bytes in
their use of the nickname spec, and let the MSRP folks do what they
please. This really isn't a matter for the nickname spec itself, I
think...

Peter

On 10/2/12 5:32 AM, Miguel A. Garcia wrote:
> Hi Peter:
> 
> It is true we don't have a limit in the nickname, for the same
> reason we don't have a limit in MSRP URIs, SIP URIs, Display-Names
> in SIP, etc.
> 
> On 22/09/2012 5:18, Peter Saint-Andre wrote: The more I think about
> this, the more I realize that nickname length is best left up to
> protocol specifications for MSRP and XMPP, not the nickname spec
> itself. Unless there are objections, I plan to remove the relevant
> paragraph from draft-ietf-precis-nickname.
> 
>>>> quoted-string in RFC 4975. In draft-ietf-precis-nickname, I
>>>> have a limit of 1023 bytes, which comes from RFC 6122 and is
>>>> probably longer than most people will ever use. I received
>>>> one comment that the nickname spec is the wrong place to be
>>>> imposing such limits, and that makes sense (XMPP can impose
>>>> one limit and MSRP can impose another limit, etc.). But I
>>>> figured it would be good to check here before making a change
>>>> to draft-ietf-precis-nickname on this point.
>>>> 
>>>> Thanks!
>>>> 
>>>> Peter
>>>>

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Mon, 8 Oct 2012 19:56:40 +0200

Ok for me.

/Miguel

On 08/10/2012 19:54, Peter Saint-Andre wrote:
> iEYEARECAAYFAlBzE20ACgkQNL8k5A2w/vybbQCePFLYiinpbJLQGehczQMBkyhS
> IssAnRv0uJYYQehKerSMxoDwp1Dx0p6C
> =RgJe

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain

---

From: Adrian Georgescu <[email-masked]>
Date: Mon, 8 Oct 2012 20:19:35 +0200

+1

---

From: Ben Campbell <[email-masked]>
Date: Mon, 8 Oct 2012 13:55:57 -0500

> please. This really isn't a matter for the nickname spec itself, I

(as individual)

I concur.