Subject: [Simple] - MSRP peer library O.S. now available announcement

From: Joao Antunes <[email-masked]>
Date: Fri, 19 Oct 2012 13:23:28 +0100

Greetings Java developer,****

** **

After a flying start within the brilliant Google Summer of Code, having it
simmer for a while and finally polishing it up with some actual use-cases,
the MSRP project team is proud to announce version 1.0 of its' magnificent
library!****

** **

This is an open source library, implementing the Message Session Relay
Protocol (MSRP: RFC 4975), for you to deploy in any application.****

** **

Functionalities include****

- establishing MSRP sessions****

- sending and receiving instant messages (chat) using MSRP****

- sending and receiving files using MSRP****

- message/cpim wrapping to interface with other chat systems****

- nicknames (draft-ietf-simple-chat)****

- message composition indication (RFC 3994)****

** **

More information can be obtained at http://msrp.java.net****

For a quick introduction, read the tutorial:
http://msrp.java.net/tutorial.html****

The entire project is hosted here: http://java.net/projects/msrp****

** **

Build versions can be found in the central Maven repository, just include
the dependency in your projects' pom.xml buildfile and you're good to go.***
*

** **

So be our guest, use it, abuse it and send us your patches, comments,
issues, wishlists and what have you.****

** **

Happy coding!****

   The MSRP team.****

** **

Special thanks go to:****

- The Jitsi project for initiating this****

- Google summer of code for making it possible****

- Nlnet for early development sponsoring****

- ContactMakers for sponsoring the polishing.

---

From: Adrian Georgescu <[email-masked]>
Date: Fri, 19 Oct 2012 16:28:43 +0200

Hi Joao,

This is great stuff. 

Congratulations to the developer team!

Regards,
Adrian

On Oct 19, 2012, at 2:23 PM, Joao Antunes wrote:

> Greetings Java developer,
> 
>  
> 
> After a flying start within the brilliant Google Summer of Code, having it simmer for a while and finally polishing it up with some actual use-cases, the MSRP project team is proud to announce version 1.0 of its' magnificent library!
> 
>  
> 
> This is an open source library, implementing the Message Session Relay Protocol (MSRP: RFC 4975), for you to deploy in any application.
> 
>  
> 
> Functionalities include
> 
> - establishing MSRP sessions
> 
> - sending and receiving instant messages (chat) using MSRP
> 
> - sending and receiving files using MSRP
> 
> - message/cpim wrapping to interface with other chat systems
> 
> - nicknames (draft-ietf-simple-chat)
> 
> - message composition indication (RFC 3994)
> 
>  
> 
> More information can be obtained at http://msrp.java.net
> 
> For a quick introduction, read the tutorial: http://msrp.java.net/tutorial.html
> 
> The entire project is hosted here: http://java.net/projects/msrp
> 
>  
> 
> Build versions can be found in the central Maven repository, just include the dependency in your projects' pom.xml buildfile and you're good to go.
> 
>  
> 
> So be our guest, use it, abuse it and send us your patches, comments, issues, wishlists and what have you.
> 
>  
> 
> Happy coding!
> 
>    The MSRP team.
> 
>  
> 
> Special thanks go to:
> 
> - The Jitsi project for initiating this
> 
> - Google summer of code for making it possible
> 
> - Nlnet for early development sponsoring
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple