Subject: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wg draft

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Feb 2012 13:11:32 -0500

SIPCORE group:

There has been general agreement on the proxy-feature requirements, so 
now we have a basis to work on a corresponding mechanism. Robert has 
agreed that sipcore is the proper place to do this work. The document 
draft-holmberg-sipcore-proxy-feature-04 has been proposed as a mechanism.

I am requesting that discussion begin, on the sipcore list, on the 
suitability of this draft as a basis for a wg mechanism document that 
will meet the requirements expressed in 
draft-ietf-sipcore-proxy-feature-reqs-03.txt.

One issue that remains fuzzy is distinguishing what is and is not a 
valid proxy-feature. We have a few examples from the use cases, but 
little clarity beyond that on any guidelines for what would qualify and 
what would not. However it seems likely that few, if any, of the 
existing defined feature tags (even those in the sip tree) would be 
appropriate.

So one thing I will be looking for in the mechanism before it is 
finalized is a way to resolve this. This might be a set of criteria that 
can be applied to any new candidate proxy-feature. Or if that proves 
impossible to define, then we can fall back on requiring standards 
action for a feature to be defined. So I encourage discussion of this issue.

(Currently the draft proposes to build on RFC 3840 and its use of the 
feature-tag definition mechanisms specified in RFC 2506. That 
registration mechanism has multiple categories of features with 
differing approval mechanisms for each category. Some require an RFC, 
some expert review, and some no approval at all. Whether this can be 
made to work for proxy-features remains to be seen.)

	Thanks,
	Paul (as co-chair)

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 28 Feb 2012 09:01:00 +0100

Hello,

As co-author of the draft-holmberg-sipcore-proxy-feature, and working with features where the mechanism is needed, I obviously support adopting the draft as wg document and will continue contributing to its progress.

Kind regards 

Ivo Sedlacek 

Ericsson
Technology and Portfolio Management, Terminal Standardization
Sweden
Office: +46 10 711 9382
[email-masked]
www.ericsson.com

We only send and receive email on the basis of the term set out at www.ericsson.com/email_disclaimer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 27. února 2012 19:12
To: SIPCORE
Subject: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wg draft

SIPCORE group:

There has been general agreement on the proxy-feature requirements, so now we have a basis to work on a corresponding mechanism. Robert has agreed that sipcore is the proper place to do this work. The document
draft-holmberg-sipcore-proxy-feature-04 has been proposed as a mechanism.

I am requesting that discussion begin, on the sipcore list, on the suitability of this draft as a basis for a wg mechanism document that will meet the requirements expressed in draft-ietf-sipcore-proxy-feature-reqs-03.txt.

One issue that remains fuzzy is distinguishing what is and is not a valid proxy-feature. We have a few examples from the use cases, but little clarity beyond that on any guidelines for what would qualify and what would not. However it seems likely that few, if any, of the existing defined feature tags (even those in the sip tree) would be appropriate.

So one thing I will be looking for in the mechanism before it is finalized is a way to resolve this. This might be a set of criteria that can be applied to any new candidate proxy-feature. Or if that proves impossible to define, then we can fall back on requiring standards action for a feature to be defined. So I encourage discussion of this issue.

(Currently the draft proposes to build on RFC 3840 and its use of the feature-tag definition mechanisms specified in RFC 2506. That registration mechanism has multiple categories of features with differing approval mechanisms for each category. Some require an RFC, some expert review, and some no approval at all. Whether this can be made to work for proxy-features remains to be seen.)

	Thanks,
	Paul (as co-chair)

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Leis, Peter (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 28 Feb 2012 09:24:16 +0100

Hello,

working in 3GPP IMS area, where we need this mechanism, I support
adopting the draft as wg document. 

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Paul Kyzivat
Sent: Monday, February 27, 2012 7:12 PM
To: SIPCORE
Subject: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a
wgdraft

SIPCORE group:

There has been general agreement on the proxy-feature requirements, so 
now we have a basis to work on a corresponding mechanism. Robert has 
agreed that sipcore is the proper place to do this work. The document 
draft-holmberg-sipcore-proxy-feature-04 has been proposed as a
mechanism.

can be applied to any new candidate proxy-feature. Or if that proves 
impossible to define, then we can fall back on requiring standards 
action for a feature to be defined. So I encourage discussion of this
issue.

	Thanks,
	Paul (as co-chair)

---

From: <[email-masked]>
Date: Tue, 28 Feb 2012 14:06:47 +0100

Not only from 3GPP work also seen form our own use cases I fully support the adoption of the draft as wg document.

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Leis, Peter (NSN - DE/Munich)
Gesendet: Dienstag, 28. Februar 2012 09:24
An: ext Paul Kyzivat; SIPCORE
Betreff: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

Hello,

working in 3GPP IMS area, where we need this mechanism, I support adopting the draft as wg document.

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Paul Kyzivat
Sent: Monday, February 27, 2012 7:12 PM
To: SIPCORE
Subject: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

SIPCORE group:

So one thing I will be looking for in the mechanism before it is finalized is a way to resolve this. This might be a set of criteria that

can be applied to any new candidate proxy-feature. Or if that proves impossible to define, then we can fall back on requiring standards action for a feature to be defined. So I encourage discussion of this issue.

        Thanks,
        Paul (as co-chair)

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 28 Feb 2012 13:21:26 +0000

AT&T supports the mechanism for WG adoption 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, February 28, 2012 8:07 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Leis, Peter (NSN - DE/Munich)
Gesendet: Dienstag, 28. Februar 2012 09:24
An: ext Paul Kyzivat; SIPCORE
Betreff: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

Hello,

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Paul Kyzivat
Sent: Monday, February 27, 2012 7:12 PM
To: SIPCORE
Subject: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

SIPCORE group:

        Thanks,
        Paul (as co-chair)

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 28 Feb 2012 09:08:21 -0500

> Not only from 3GPP work also seen form our own use cases I fully support the adoption of the draft as wg document.

Since many of us have struggled to  understand the uses of this 
mechanism, it would be great if those of you who have uses would 
describe them.

Are the uses you see ones that would have proprietary feature tags? Or 
are they of general use that should have a public tag?

	Thanks,
	Paul

---

From: Laura Liess <[email-masked]>
Date: Tue, 28 Feb 2012 16:12:55 +0100

I  support the adoption of the draft as wg document.

Thank you
Laura

---

From: <[email-masked]>
Date: Tue, 28 Feb 2012 15:27:56 +0000

Hi,

Orange supports the adoption of this draft as WG document.

Marianne

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Laura Liess
Envoyé : mardi 28 février 2012 16:13
À : [email-masked]
Objet : Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

Thank you
Laura

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

---

From: Li Shitao <[email-masked]>
Date: Wed, 29 Feb 2012 01:42:06 +0000

Hi all
I also support this draft as a WG document.

shitao

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Leis, Peter (NSN - DE/Munich)
发送时间: 2012年2月28日 16:24
收件人: ext Paul Kyzivat; SIPCORE
主题: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

Hello,

Peter

-----Original Message-----

SIPCORE group:

	Thanks,
	Paul (as co-chair)

---

From: <[email-masked]>
Date: Wed, 29 Feb 2012 08:18:54 +0000

I also support adopting this draft as a WG item.

Cheers,
Krisztian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Leis, Peter (NSN - DE/Munich)
Sent: Tuesday, February 28, 2012 00:24
To: ext Paul Kyzivat; SIPCORE
Subject: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

Hello,

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Paul Kyzivat
Sent: Monday, February 27, 2012 7:12 PM
To: SIPCORE
Subject: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

SIPCORE group:

	Thanks,
	Paul (as co-chair)

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 29 Feb 2012 16:00:20 +0100

Christian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext [email-masked]
Sent: Wednesday, February 29, 2012 9:19 AM
To: [email-masked]
Subject: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature
asa wgdraft

Cheers,
Krisztian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Leis, Peter (NSN - DE/Munich)
Sent: Tuesday, February 28, 2012 00:24
To: ext Paul Kyzivat; SIPCORE
Subject: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature
as a wgdraft

Hello,

Peter

-----Original Message-----

SIPCORE group:

	Thanks,
	Paul (as co-chair)