Subject: Re: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

From: <[email-masked]>
Date: Thu, 1 Mar 2012 10:08:34 +0100

Hi Paul,
Due to the fact that I got only the *STRONG SUPPORT* feedback from my deployment guys looking on draft-holmberg-sipcore-proxy-feature  and the related use cases. I unfortunately cannot give more details at this point, but I think there will be a general use.
My goal is not use proprietary feature tags.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: Paul Kyzivat [mailto:[email-masked]]
Gesendet: Dienstag, 28. Februar 2012 15:08
An: Jesske, Roland
Cc: [email-masked]; [email-masked]
Betreff: Re: AW: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as a wgdraft

On 2/28/12 8:06 AM, [email-masked] wrote:
> Not only from 3GPP work also seen form our own use cases I fully support the adoption of the draft as wg document.

Since many of us have struggled to  understand the uses of this mechanism, it would be great if those of you who have uses would describe them.

Are the uses you see ones that would have proprietary feature tags? Or are they of general use that should have a public tag?

        Thanks,
        Paul

> Roland
>
> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im
> Auftrag von Leis, Peter (NSN - DE/Munich)
> Gesendet: Dienstag, 28. Februar 2012 09:24
> An: ext Paul Kyzivat; SIPCORE
> Betreff: Re: [sipcore] Adoption of
> draft-holmberg-sipcore-proxy-feature as a wgdraft
>
> Hello,
>
> working in 3GPP IMS area, where we need this mechanism, I support adopting the draft as wg document.
>
> Peter
>
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of ext Paul Kyzivat
> Sent: Monday, February 27, 2012 7:12 PM
> To: SIPCORE
> Subject: [sipcore] Adoption of draft-holmberg-sipcore-proxy-feature as
> a wgdraft
>
> SIPCORE group:
>
> There has been general agreement on the proxy-feature requirements, so
> now we have a basis to work on a corresponding mechanism. Robert has
> agreed that sipcore is the proper place to do this work. The document
> draft-holmberg-sipcore-proxy-feature-04 has been proposed as a mechanism.
>
> I am requesting that discussion begin, on the sipcore list, on the suitability of this draft as a basis for a wg mechanism document that will meet the requirements expressed in draft-ietf-sipcore-proxy-feature-reqs-03.txt.
>
> One issue that remains fuzzy is distinguishing what is and is not a valid proxy-feature. We have a few examples from the use cases, but little clarity beyond that on any guidelines for what would qualify and what would not. However it seems likely that few, if any, of the existing defined feature tags (even those in the sip tree) would be appropriate.
>
> So one thing I will be looking for in the mechanism before it is
> finalized is a way to resolve this. This might be a set of criteria
> that
>
> can be applied to any new candidate proxy-feature. Or if that proves impossible to define, then we can fall back on requiring standards action for a feature to be defined. So I encourage discussion of this issue.
>
> (Currently the draft proposes to build on RFC 3840 and its use of the
> feature-tag definition mechanisms specified in RFC 2506. That
> registration mechanism has multiple categories of features with
> differing approval mechanisms for each category. Some require an RFC,
> some expert review, and some no approval at all. Whether this can be
> made to work for proxy-features remains to be seen.)
>
>          Thanks,
>          Paul (as co-chair)
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 01 Mar 2012 12:58:32 -0500

> My goal is not use proprietary feature tags.

Roland,

> Not only from 3GPP work also seen form our own use cases I fully support the adoption of the draft as wg document.

That seems to say you had some use cases other than the 3GPP ones.
But there are no feature tags defined for this use other than ones 
defined by 3GPP. So I guess they would either be proprietary or else 
would be new ones that you think will be standardized. That is what I 
was looking for.

	Thanks,
	Paul