Subject: [sipcore] Editorial comment on draft-barnes-sipcore-rfc4244bis-callflows-02

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Tue, 20 Mar 2012 12:00:28 +0000

Mary,

For History-info examples with reason header, the delimiter between hname and hvalue is shown as escaped character (%3B) instead of "=". The exact ABNF as per RFC 3261 is as follows:

headers         =  "?" header *( "&" header )
header          =  hname "=" hvalue

In sec 3.1, F4, F5, F6, F7, F8 messages has

History-Info: <sip:[email-masked]?Reason%3BSIP%3Dcause%3B302>;\
                  index=1.1
Has to be changed as:
History-Info: <sip:[email-masked]?Reason=SIP%3Dcause%3B302>;\
                  index=1.1

Similar usage is seen in Sec 3.3 of F4,F5,F6, F7 messages:

History-Info: <sip:[email-masked]?Reason%3BSIP%3Dcause%3B302>;\
                      index=1.1;rc=1
History-Info: <sip:[email-masked]?Reason%3BSIP%3Dcause%3B408>;\
                      index=1.2.1;rc=1.2

has to be changed as:

History-Info: <sip:[email-masked]?Reason=SIP%3Dcause%3B302>;\
                      index=1.1;rc=1
History-Info: <sip:[email-masked]?Reason=SIP%3Dcause%3B408>;\
                      index=1.2.1;rc=1.2

Could you please let me know your opinion about these editorial comments.

Thanks
Partha

---

From: Shida Schubert <[email-masked]>
Date: Sun, 25 Mar 2012 22:36:23 +0200

These are errors and we are aware of them and they have 
been addressed in the version I have in hand. I just haven't 
got around to submit the revised draft I have in hand.. 

 Many thanks for pointing it out, never the less.

 Regards
  Shida

On Mar 20, 2012, at 1:00 PM, Ravindran, Parthasarathi wrote:

> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Mon, 26 Mar 2012 07:45:48 +0000

Shida,

Thanks for the information & closure.

Thanks
Partha

>-----Original Message-----
>From: Shida Schubert [mailto:[email-masked]]
>Sent: Monday, March 26, 2012 2:06 AM
>To: Ravindran, Parthasarathi
>Cc: 'Mary Barnes'; Kuwabara, Yoshikazu; [email-masked]
>Subject: Re: [sipcore] Editorial comment on draft-barnes-sipcore-
>rfc4244bis-callflows-02
>
>
> These are errors and we are aware of them and they have been addressed
>in the version I have in hand. I just haven't got around to submit the
>revised draft I have in hand..
>
>> For History-info examples with reason header, the delimiter between
>hname and hvalue is shown as escaped character (%3B) instead of "=". The
>exact ABNF as per RFC 3261 is as follows:
>>