Subject: [sipcore] Confirming Consensus: WebSockets

From: Adam Roach - SIPCORE Chair <[email-masked]>
Date: Wed, 28 Mar 2012 11:26:18 +0200

[as chair]

During the face-to-face meeting yesterday, the chairs asked for a feel 
of the room to gauge support for working on the WebSockets transport for 
SIP. Consensus among those present was strongly in favor.

Based on this impression, the SIPCORE chairs plan to take the following 
actions unless objections are raised on this email list prior to Friday, 
April 6th:

- We will add a new milestone to our charter: "WebSockets SIP
   Transport to IESG (PS)"

- We will adopt draft-ibc-sipcore-sip-websocket-01 as the basis
   for fulfilling the new milestone, and request that the authors
   submit a new version with a filename reflecting this adoption.

Thank you.

/a

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Wed, 28 Mar 2012 07:33:29 -0500

> submit a new version with a filename reflecting this adoption.

Should this wait until -02, with the portions that caused controversy 
moved to non-normative?

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
Jabber: [email-masked] | SIP: [email-masked] | Skype: kpfleming
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at www.digium.com & www.asterisk.org

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 28 Mar 2012 14:37:12 +0200

Hi,

There was no agreement regarding GRUU, but as far as I know we decided not to mandate Outbound, but rather go for Option 2. Unless I'm wrong, I guess it would be good to mention that in the minutes.

Regards,

Christer 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kevin P. Fleming
Sent: 28. maaliskuuta 2012 15:33
To: [email-masked]
Subject: Re: [sipcore] Confirming Consensus: WebSockets

On 03/28/2012 04:26 AM, Adam Roach - SIPCORE Chair wrote:
> of the room to gauge support for working on the WebSockets transport 
> for SIP. Consensus among those present was strongly in favor.
>
> Based on this impression, the SIPCORE chairs plan to take the 
> following actions unless objections are raised on this email list 
> prior to Friday, April 6th:
>
> - We will adopt draft-ibc-sipcore-sip-websocket-01 as the basis for 
> fulfilling the new milestone, and request that the authors submit a 
> new version with a filename reflecting this adoption.

Should this wait until -02, with the portions that caused controversy moved to non-normative?

--
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
Jabber: [email-masked] | SIP: [email-masked] | Skype: kpfleming
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA Check us out at www.digium.com & www.asterisk.org _______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Wed, 28 Mar 2012 14:38:29 +0200

> Should this wait until -02, with the portions that caused controversy moved

The new version of the draft will address the topics discussed in the
IETF meeting. I expect that this new version should be renamed to
draft-sipcore-sip-websocket-00 and submitted to the IETF.

Please correct me if I'm wrong.

Thanks a lot.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Wed, 28 Mar 2012 07:46:32 -0500

> There was no agreement regarding GRUU, but as far as I know we decided not to mandate Outbound, but rather go for Option 2. Unless I'm wrong, I guess it would be good to mention that in the minutes.

Given the general direction of the conversation, I'd expect there would 
be consensus that it's acceptable to mention the usage of GRUU in the 
document as a mechanism that may be employed under some circumstances 
(again, in the new 'informative' section). I could be wrong though, some 
people really don't like GRUU much :-)

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 28 Mar 2012 14:56:43 +0200

Hi, 

> Given the general direction of the conversation, I'd expect there would be consensus that it's acceptable to mention the usage of GRUU in the document as a mechanism that may be employed under some circumstances (again, in the new 
> 'informative' section). I could be wrong though, some people really don't like GRUU much :-)

I went to the microphone, to verify that we had made no decision regarding GRUU :)

Regards,

Christer

---

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 28 Mar 2012 14:54:13 +0000

On Mar 28, 2012, at 2:46 PM, Kevin P. Fleming wrote:

> Given the general direction of the conversation, I'd expect there would be consensus that it's acceptable to mention the usage of GRUU in the document as a mechanism that may be employed under some circumstances (again, in the new 'informative' section). I could be wrong though, some people really don't like GRUU much :-)

You just *know* I'm going to respond to that, right?  :)

It's not that I don't like GRUU - it's actually a very nice concept.  The problem is people think it will *work*, and that it's going to magically make things work.  It absolutely would work, I think, if (1) all SIP domains followed an email policy model, and if (2) SIP were universally interoperable up and down the stack (ie at all layers), and if (3) SIP was the only protocol used on the path between any two parties.  But we know not all of those are the case, and arguably none are the case.

I'm planning to submit a straw-man draft for a possible solution, for next IETF.  I have the acronym, so now I'm just trying to figure out what the acronym stands for, which is really the hard part of any draft. :)

-hadriel

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 28 Mar 2012 22:56:12 +0200

Hadriel,

Please correct me if I'm wrong, but I *think* what you are trying to say 
is that out of dialog requests to the contact address from a dialog will 
mostly never work, unless somebody puts the phone-number-style URI in 
the contact address, or if the contact is one that was substituted by 
the last SBC.

I would think, *if they wanted to*, SBCs could make whatever 
substitution is necessary to make a gruu that they receive in a contact 
address be usable on the other side. This would be in their traditional 
role of fixing all the interop problems of the networks they connect.

	Thanks,
	Paul

On 3/28/12 4:54 PM, Hadriel Kaplan wrote:
> _______________________________________________
> sipcore mailing list
> [email-masked]

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 29 Mar 2012 17:40:33 +0000

On Mar 28, 2012, at 10:56 PM, Paul Kyzivat wrote:

> Please correct me if I'm wrong, but I *think* what you are trying to say is that out of dialog requests to the contact address from a dialog will mostly never work, unless somebody puts the phone-number-style URI in the contact address, or if the contact is one that was substituted by the last SBC.

I'm not quite sure what *you're* saying, so I can't tell if it's what I'm also trying to say. :)

> I would think, *if they wanted to*, SBCs could make whatever substitution is necessary to make a gruu that they receive in a contact address be usable on the other side. This would be in their traditional role of fixing all the interop problems of the networks they connect.

Sort of.  There are some folks in the IETF who don't want the SBCs to change them at all if they're GRUUs.  And there are also other SDOs/groups that seem to think they will be getting GRUUs, that they MUST get GRUUs, and that it will somehow make things magically work. 

-hadriel