Subject: Re: [sipcore] Some considerations on draft-ibc-sipcore-sip-websocket (Outbound and more) - GRUU

From: Adam Roach <[email-masked]>
Date: Mon, 02 Apr 2012 11:08:46 -0500

On 3/26/12 3:46 PM, Hadriel Kaplan wrote:
> On Mar 26, 2012, at 2:25 PM, Kevin P. Fleming wrote:
>
>> For nearly *all* WebSocket use cases (that we've agreed to address with this draft), SIP endpoints will have this issue. Since the WebSocket transport is being documented *after* the creation of the solution (GRUU), it seems reasonable to me for the WebSocket transport document to refer to that solution as the preferred mechanism. It shouldn't be mandated, but preferring it seems practical and useful.
> I would agree, if it weren't for that I wrote a draft of problems with using GRUUs.  :)
>
> See here:
> http://tools.ietf.org/html/draft-kaplan-dispatch-gruu-problematic-00
>
> And before Paul says anything, the draft is NOT blaming GRUUs.  It's not their fault the Internet is a nasty place. ;)
>

Well, be honest about the contents of the document, though. It boils 
down to: (a) here are some poorly-thought-out things that B2BUAs can do 
to ruin the beneficial properties of GRUUs, and (b) broken deployments 
are broken.

It's more of a "worst common practices" document than an indictment of 
GRUUs. The solution to pretty much all the issues that draft highlights 
is: "don't do that, then." It's not the GRUUs that are broken -- it's 
the deployments and poorly-designed B2BUAs.

/a

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Mon, 2 Apr 2012 18:37:09 +0200

2012/4/2 Adam Roach <[email-masked]>:
> Well, be honest about the contents of the document, though. It boils down
> to: (a) here are some poorly-thought-out things that B2BUAs can do to ruin
> the beneficial properties of GRUUs, and (b) broken deployments are broken.
>
> GRUUs. The solution to pretty much all the issues that draft highlights is:
> "don't do that, then." It's not the GRUUs that are broken -- it's the
> deployments and poorly-designed B2BUAs.

Completely agreed. I don't understand why we should discuss here about
the fact that non standard devices (B2BUAs, SBCs) do not play well
with real standard specifications (Outbound, GRUU). Neither we should
consider here (when talking about standards) the fact that some SIP
servers implement their proprietary "version" of Outbound and/or
Connection Reuse.

Outbound and GRUU do work in well designed standard networks.

Regards.

-- 
Iñaki Baz Castillo
<[email-masked]>