Subject: Re: [sipcore] Call for Adoption: draft-ibc-sipcore-sip-websocket-02

From: Adam Roach - SIPCORE Chair <[email-masked]>
Date: Fri, 04 May 2012 15:38:58 -0500

[as chair]

Based on the significant positive feedback on the mailing list and the 
lack of any explicit objections to adoption, I am declaring consensus 
for using draft-ibc-sipcore-sip-websocket as the basis for the working 
group document to satisfy our Websockets transport milestone.

Authors: Please submit a draft-ietf-sipcore-sip-websocket-00 document as 
soon as is convenient. There is no need to wait for document content 
changes to submit the document.

Thank you.

/a

On 4/16/12 1:02 PM, Adam Roach - SIPCORE Chair wrote:
> [as chair]
>
> SIPCORE Working Group:
>
> This is a call for adoption of the draft-ibc-sipcore-sip-websocket-02 
> document to satisfy our recently added milestone to define a 
> WebSockets transport for the SIP protocol. Interested parties should 
> voice their support and/or concerns on the SIPCORE mailing list. The 
> chairs plan to make a determination of consensus on Friday, April 27th.
>
> Thank you. The draft announcement follows.
>
> /a
>
> -------- Original Message --------
> Subject: [sipcore] New Version Notification for 
> draft-ibc-sipcore-sip-websocket-02.txt
> Date: Mon, 16 Apr 2012 18:49:38 +0200
> From: Iñaki Baz Castillo <[email-masked]>
> To: SIPCORE WG <[email-masked]>
>
> A new version of I-D, draft-ibc-sipcore-sip-websocket-02.txt has been
> successfully submitted by Iñaki Baz Castillo and posted to the IETF
> repository.
>
> Filename:        draft-ibc-sipcore-sip-websocket
> Revision:        02
> Title:           The WebSocket Protocol as a Transport for the Session
> Initiation Protocol (SIP)
> Creation date:   2012-04-16
> WG ID:           Individual Submission
> Number of pages: 20
>
> Abstract:
>   The WebSocket protocol enables two-way realtime communication between
>   clients and servers.  This document specifies a new WebSocket sub-
>   protocol as a reliable transport mechanism between SIP (Session
>   Initiation Protocol) entities and enables usage of the SIP protocol
>   in new scenarios.
>
>
> - http://tools.ietf.org/html/draft-ibc-sipcore-sip-websocket-02
> - http://tools.ietf.org/id/draft-ibc-sipcore-sip-websocket-02.txt
>
>
> This new version incorporates improvements and changes based on the
> comments and reviews on the previous version, along with the consensus
> got in IETF 83 Paris.
>
>
> As usual, comments are welcome. Thanks a lot.
>
>

---

From: Dean Willis <[email-masked]>
Date: Tue, 8 May 2012 12:14:04 -0500

On Apr 25, 2012, at 11:09 AM, Vijay K. Gurbani wrote:

> On 04/25/2012 09:55 AM, Paul Kyzivat wrote:
>> I agree with Saúl here. I don't really understand what it is that Partha
>> is proposing.
>> 
>> As I already stated, I think sips turned out to be a mistake - that it
>> doesn't provide enough of a guarantee to be able to promise anything to
>> an end user. But we investigated this ad nauseum and couldn't come up
>> with anything substantially better.
> 
> Time for institutional memory, perhaps?  The long discussions (May -
> June 2006) on why sips failed and ideas to come up with new URI schemes
> to replace it and attendant problems (upcasting URIs, downcasting URIs
> without user consent, hop-by-hop semantics versus end-to-end, etc.) is
> summarized in
> http://www.ietf.org/mail-archive/web/sip/current/msg24047.html

Right, we CAME UP with something substantially better. We just didn't standardize it, because operations regimes really want to have the ability to mess with the signaling.  The thing we came up with was making SIP proxies work like HTTP proxies when "security" is invoked; HTTP proxies do not decrypt/recrypt secured traffic. They just pass it through. Vijay (mostly) wrote a paper on the resulting idea, built a test harness, and demonstrated MUCH improved proxy throughput using end-to-end security. Technically, the solution was brilliant.

BUT THE OPERATORS REALLY DON'T WANT END-TO-END PRIVACY AND IN MANY COUNTRIES IT WOULD BE ILLEGAL!

So, we are left with the hop-by-hop "please don't spill my beans" request that is SIPS.

It is all a crock of political fertilizer.

I'm reminded of the Hitchhiker's Guide passage on the elimination of "future perfect" tense, because the advent of time travel proved the future not to will have been perfectable. The promise of SIPS is much like that.

--
Dean