Subject: Re: [sipcore] draft-lavers-sipcore-immersive-capability-00.txt

From: dave Cruse <[email-masked]>
Date: Tue, 1 May 2012 07:12:57 +0000

Hello Glen,

I have some few basic questions here:

Q1. Does this feature support TLS UDP OR just TCP only?

Q2. What if Endpoint support only FAX but not Video?

Regards
- Dave

> Date: Mon, 5 Mar 2012 13:36:52 -0800
> From: [email-masked]
> To: [email-masked]
> CC: [email-masked]; [email-masked]
> Subject: [sipcore] draft-lavers-sipcore-immersive-capability-00.txt
> 
> Folks,
> I have submitted a new draft to define an 'immersive' media feature tag. The draft is posted at: http://tools.ietf.org/html/draft-lavers-sipcore-immersive-capability 
> 
> The authors would appreciate feedback  and or detailed comments. 
> 
> Many thanks,
> Glen 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "Paul E. Jones" <[email-masked]>
Date: Tue, 01 May 2012 07:26:12 -0400

Dave,

I think the IETF largely rejected this proposal, so what I will say is 
probably of little value.

Q1) The proposal is transport independent.
Q2) The "immersive" concept could be applied to voice, video, or other 
media type.  I don't think anyone would think of fax as immersive, but 
there are no limits on interpretation.  The reason I say this is that 
the "immersive" tag is a SIP header value, not an SDP value.  Therefore, 
it is largely divorced from the media types used in a call.

At a high level, the proposal merely defined a way for a device to 
indicate that it would like to make a call to a device that is 
"immersive" or to advertise the fact that a device is "immersive".  It 
fits into the "caller preferences" framework defined by the IETF.

Unfortunately, the IETF did not like it, citing that "immersive" is not 
well-defined and also admitting that the whole "caller preferences" work 
is not specified very well.  As we understood the intent of caller 
preferences,  we believed that "immersive" would be a valuable addition, 
for example, to allow me to make a call to you and indicate that I want 
an "immersive" device.  What "immersive" might mean to me and you might 
be different, but the thinking was that if you have a desk phone and an 
HD video terminal, then you would mark the HD video terminal as 
"immersive".  This would allow me to call you from my HD video terminal 
to your.  Without this addition to SIP, then if I call you, both your 
desk phone and HD video terminal might ring.  You might answer my HD 
video call on your phone.  That's a bit of a waste, right?  So, SIP will 
remain "dumb" in this regard, I guess.

Paul

On 5/1/2012 3:12 AM, dave Cruse wrote:
> > I have submitted a new draft to define an 'immersive' media feature 
> tag. The draft is posted at: 
> http://tools.ietf.org/html/draft-lavers-sipcore-immersive-capability
> >

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 1 May 2012 14:49:00 +0200

The key objection was that based on the submitted text, the sender and receiver would not necessarily have the same understanding of what the feature tags mean. Come back with something much more specific on the capabilities supported and it would stand a better chance of success.

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul E. Jones
Sent: 01 May 2012 12:26
To: dave Cruse
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [sipcore] draft-lavers-sipcore-immersive-capability-00.txt

Dave,

I think the IETF largely rejected this proposal, so what I will say is probably of little value.

Q1) The proposal is transport independent.
Q2) The "immersive" concept could be applied to voice, video, or other media type.  I don't think anyone would think of fax as immersive, but there are no limits on interpretation.  The reason I say this is that the "immersive" tag is a SIP header value, not an SDP value.  Therefore, it is largely divorced from the media types used in a call.

At a high level, the proposal merely defined a way for a device to indicate that it would like to make a call to a device that is "immersive" or to advertise the fact that a device is "immersive".  It fits into the "caller preferences" framework defined by the IETF.

Unfortunately, the IETF did not like it, citing that "immersive" is not well-defined and also admitting that the whole "caller preferences" work is not specified very well.  As we understood the intent of caller preferences,  we believed that "immersive" would be a valuable addition, for example, to allow me to make a call to you and indicate that I want an "immersive" device.  What "immersive" might mean to me and you might be different, but the thinking was that if you have a desk phone and an HD video terminal, then you would mark the HD video terminal as "immersive".  This would allow me to call you from my HD video terminal to your.  Without this addition to SIP, then if I call you, both your desk phone and HD video terminal might ring.  You might answer my HD video call on your phone.  That's a bit of a waste, right?  So, SIP will remain "dumb" in this regard, I guess.

Paul

Hello Glen,

Regards
- Dave
> From: [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>
> CC: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

sipcore mailing list

[email-masked]<mailto:[email-masked]>

---

From: Dean Willis <[email-masked]>
Date: Tue, 8 May 2012 12:43:05 -0500

> Unfortunately, the IETF did not like it, citing that "immersive" is not well-defined and also admitting that the whole "caller preferences" work is not specified very well.  As we understood the in…

This sounds more like a combination of a Q-value-like weighting for the "media richness" of a contact, and a caller preferences modifier that would shift the request to the media-richest contact.

 And yeah, media richness is a sloppy term too.

But without hard transition points or multiple axes in ratings, how does the called party know whether the "hologram screen with no sound" or the "planet rumbling sound system with no screen" is the better choice for a given call? That's why I think we're talking about a general preference for the proxy to engage in priority-weighting the contacts based on their ability to service the preferred offer and then sequential-fork across those contacts in priority order, rather than just parallel-forking all to all the contacts and letting the first contact to respond get the call.

I can see this being useful. The other day I had something like 16 SIP devices in my house registered to my AOR, and it was pretty deafening every time a call came in. If the "video" calls could have been routed to my PC, that would have been nice. But it wouldn't always work, because I might have stepped out into the back yard with only an audio device in-hand, and the proxy would not have known it.

Maybe something that would be presented to me at ring time saying "The caller is offering video, think it is important, but can go without it" so I'd know to answer on the PC if I could?

I think there's a real use case hiding in the "immersive" idea, but we haven't really teased it out yet.

--
dean

---

From: "Paul E. Jones" <[email-masked]>
Date: Tue, 08 May 2012 21:33:08 +0200

Dean,

I agree. My original understanding was that caller preferences was for this sort of thing, not for merely mapping based in concrete things like video, but the more subjective things like immersive.

Anyway, you appreciate the problem, but I don't have the perfect solution. I suspect there is no perfect solution.

Paul

_____________________________________________
From: Dean Willis <[email-masked]>
Sent: Tue May 08 19:43:05 CEST 2012
To: "Paul E. Jones" <[email-masked]>
Cc: [email-masked], [email-masked], dave Cruse <[email-masked]>, [email-masked]
Subject: Re: [sipcore] draft-lavers-sipcore-immersive-capability-00.txt

--
dean

_____________________________________________

sipcore mailing list
[email-masked]