Subject: Re: [sipcore] WGLC for draft-ietf-sipcore-proxy-feature-02 - Shida's comments

From: Christer Holmberg <[email-masked]>
Date: Fri, 1 Jun 2012 12:22:08 +0200

Hi,

>>>> What does the following sentence to above mean? Are you saying that 
>>>> you could in fact define a way to convey the address of the entity which indicated support of feature/capabilities by defining a method to do so in the sip feature-cap spec?
>>>
>>> It means that the Feature-Caps header field itself does not contain a header field parameter for conveying the address, but that an individual feature cap can have an address value if needed.
>>>
>>> Example:
>>>
>>> myFeatureCaps="address=x.y.z.w"
>>
>>The paragraph is still a bit confusing. How about:
>>
>>    NOTE: It is not possible to convey the address of the SIP entity as a
>>    Feature-Caps header field parameter.  Each feature that requires
>>    address information to be conveyed need to define a way to convey
>>    that information as part of the associated SIP feature cap value.
>>
>>    NOTE: If data is needed about a feature, such as the address of the
>>    sip entity, then the feature definition must define a way to convey
>>    that information as part of the associated SIP feature cap value.
>
> Looks good.

When starting to implement this change, I realized that the notes could be combined into a single note. I also added some clarification words:

	"NOTE: It is not possible to, as a Feature-Caps header field value, convey 
	the address of the SIP entity that inserted the Feature-Caps header field. 
 	If additional data about a supported feature needs to be conveyed, such 
	as the address of the SIP entity that indicated support of the feature, then 
	the feature definition needs to define a way to convey that information as 
	a value of the associated feature cap."

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 1 Jun 2012 12:51:09 +0200

Hi,

>> 	o  - The SIP entity acts as a SIP proxy.
>> 	o  - The SIP entity acts as a SIP registrar.
>> 	o  - The SIP entity acts as a B2BUA, where the Contact header field
>> 	URI represents another SIP entity.
>>
>> 	This specification also defines a new SIP header field, Feature-Caps,
>> 	to convey feature caps in SIP messages."
>
> Yes.

I am not sure if the suggestion was to remove the last paragraph of the original text, but I suggest to keep it as a note:
				
	"NOTE: Unlike media feature tags, feature caps are intended to only be 
	used with the SIP protocol."
		
Regards,

Christer