Subject: [sipcore] Proxy-feature: Suggested changes/additions based on IESG review

From: Christer Holmberg <[email-masked]>
Date: Fri, 12 Oct 2012 20:46:39 +0200

Hi,

Based on comments during the IESG review, there are a couple of suggested changes/additions to draft-ietf-sipcore-proxy-feature that we want to bring to the attention of the WG.

First, it has been suggested that all 2119 uppercase words in section 5.3 (Feature Capability Indicator Specification Requirements) and section 8 (Feature Capability Indicator Registration Template) are changed to lowercase. The reason is because the sections are about documentation, not interoperability.

Second, it was suggested to clarify whether an entity can remove or re-order Feature-Caps header fields within a SIP message. We suggest the following paragraph to be added to section 4.2.1:

      "Based on features and policies, a SIP entity MAY remove a Feature-
      Caps header field from a SIP message. Also, a SIP entity MAY remove
      a feature capability indicator from a Feature-Caps header field
      within a SIP message. A SIP entity SHOULD NOT re-order the Feature-
      Caps header fields within a SIP message."

Please indicate if you object to these suggested changes/additions.

Thanks!

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Oct 2012 13:08:16 -0400

(as co-chair)

We are now post-WGLC and finishing up IESG comments on this draft.
The following changes that were requested by the IESG can be considered 
more than editorial. So please review these in and comment if you are 
opposed to any of these changes. Please be quick, we want to finish this 
up.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 15 Oct 2012 13:33:53 -0400

(now responding as individual)

> First, it has been suggested that all 2119 uppercase words in section 5.3 (Feature Capability Indicator Specification Requirements) and section 8 (Feature Capability Indicator Registration Template…

I disagree with this change.

*Some* of the usage is probably gratuitous and unnecessary, but there is 
some of it that is *intended* to be normative. Yes, these are 
requirements about the "documentation", but without this information 
interoperation in the use of particular feature capability indicators is 
impossible. Media feature tags make this information optional. That was 
one of the motivations for setting up a separate registry - so that we 
could make this information mandatory.

My opinions per section:

- 5.3.1: retain 2119 language
- 5.3.2: "
- 5.3.3: "
- 5.3.4: "
- 5.3.5: "
- 5.3.6: "
- 5.3.7: need not be normative
- 5.3.8: need not be normative
- 8: use of 2119 language is redundant

Regarding section 8:

It already says: "Instructions are preceded by '|'.  All fields are 
mandatory." So using MUST within those is redundant and can be omitted.

>        Caps header fields within a SIP message."

I'm ok with this.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Oct 2012 18:15:41 +0000

Hi, 

>> Based on comments during the IESG review, there are a couple of suggested changes/additions 
>> to draft-ietf-sipcore-proxy-feature that we want to bring to the attention of the WG.
>>
>> First, it has been suggested that all 2119 uppercase words in section 5.3 (Feature Capability 
>> Indicator Specification Requirements) and section 8 (Feature Capability Indicator Registration 
>> Template) are changed to lowercase. The reason is because the sections are about documentation, not interoperability.
>
> *Some* of the usage is probably gratuitous and unnecessary, but there is some of it that is *intended* to be normative. 
> Yes, these are requirements about the "documentation", but without this information interoperation in the use of 
> particular feature capability indicators is impossible. Media feature tags make this information optional. That was 
> one of the motivations for setting up a separate registry - so that we could make this information mandatory.
>
> My opinions per section:
>
> It already says: "Instructions are preceded by '|'.  All fields are mandatory." So using MUST within those is redundant and can be omitted.

I am ok with you suggestion.

-------------------------------

>>        Caps header fields within a SIP message."

Good :)

Regards,

Christer