Subject: [sipcore] (no subject)

From: Dale R Worley <[email-masked]>
Date: Wed, 10 Oct 2012 16:52:29 -0400 (EDT)

([email-masked])
Subject: Re: [sipcore] draft-ietf-sipcore-rfc4244bis-10: question and
comment
--text follows this line--
> From: Brett Tate <[email-masked]>
> 
> Based upon sections 6.1 and 9.2, it looks like the UAC MUST include
> History-Info within the initial INVITE.

That's true.  It is a change from earlier versions.

> However since section 5.1
> and some (not all) draft-ietf-sipcore-rfc4244bis-callflows-01
> examples do not include it, I thought that I'd ask.

Well, section 5.1 is "Acknowledgements".  But "History-Info:" is
missing from:

case 3.6 message F1
case 3.7 message F1
case 3.11 message F1

and "Supported: histinfo" is missing from:

case 3.8 messages F3 and F4
case 3.11 message F1

assuming I've not made any mistakes.

Dale

---

From: Brett Tate <[email-masked]>
Date: Thu, 11 Oct 2012 10:05:33 +0000

> > Based upon sections 6.1 and 9.2, it looks like the 
> > UAC MUST include History-Info within the initial INVITE.
> 
> > However since section 5.1 and some (not all) 
> > draft-ietf-sipcore-rfc4244bis-callflows-01
> Well, section 5.1 is "Acknowledgements".

The section 5.1 reference/comment was for draft-ietf-sipcore-rfc4244bis-10 section 5.1.

Thanks for the response,
Brett