Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-00.txt

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 3 Jan 2017 22:16:47 +0000

The automaton has been dropped and only human agency is implied. Not sure what happens when the grand child of Alexa or Siri answers phone calls - see http://motherboard.vice.com/read/ai-professor-proposes-turing-red-flag-law for one option...

From: DOLLY, MARTIN C [mailto:[email-masked]]
Sent: Monday, December 19, 2016 4:44 PM
To: Henning Schulzrinne <[email-masked]>
Cc: Paul Kyzivat <[email-masked]>; [email-masked]
Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-00.txt

Greetings

Small issue with Paul's comments.

The user needs to make a "clear" decision on 666 being sent. So the user pressing a button is clear, whether pre/post answer, but an application scenario is not

Need to fully understand the consequences of initiating trace back and a fraud report

Regards
Martin C. Dolly
Lead Member of Technical Staff
Core & Government/Regulatory Standards
AT&T
Cell: +1.609.903.3360<tel:+1.609.903.3360>
Email: [email-masked]<mailto:[email-masked]>

On Dec 19, 2016, at 4:29 PM, Henning Schulzrinne <[email-masked]<mailto:[email-masked]>> wrote:

Thank you for the comments. -01 will include the text suggestions you made.

I would like to "ship" -01 before the holidays, so please wrap up your holiday comment gifts and express-mail them so that only robocallers will find coal in their stockings.

Henning

________________________________
From: sipcore <[email-masked]<mailto:[email-masked]>> on behalf of Paul Kyzivat <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, December 13, 2016 3:13:43 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-00.txt

I reviewed this new version. I have a couple of suggestions for small
wording changes:

* Section 1:

The wording of the following:

    ... The called party or a automata acting on her behalf uses this
    to indicate that future calls from the same caller are also unwanted.

is odd. AFAIK, the "called party" here is a person who interacts with
the called UA to indicate that the call is unwanted. The called party
doesn't use the 666 response code - the called UA uses it, based on some
(unspecified) stimulus provided by the called party. Or the called UA,
acting as an automata, may generate the response without a stimulus from
the called party.

I suggest the following to replace the above:

    ... The called user agent (UAS), based on input from the called
    party or internal logic, uses this code to indicate that this call
    and future calls from the same caller are unwanted.

* Section 2:

This section has some text having a similar issue:

    None of the existing 4xx, 5xx or 6xx response codes allow the called
    party to convey that they not only reject this call, e.g., using 480
    (Temporarily Unavailable), 486 (Busy Here), 600 (Busy Everywhere),
    603 (Decline) or 606 (Not Acceptable), but that the caller is
    unwanted.

I suggest:

    None of the existing 4xx, 5xx or 6xx response codes signify that
    calls from this caller are unwanted by the called party.

Otherwise I like it.

        Thanks,
        Paul

On 12/12/16 4:50 PM, [email-masked]<mailto:[email-masked]> wrote:
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Session Initiation Protocol Core of the IETF.
>
>         Title           : A SIP Response Code for Unwanted Calls
>         Author          : Henning Schulzrinne
>        Filename        : draft-ietf-sipcore-status-unwanted-00.txt
>        Pages           : 6
>        Date            : 2016-12-12
>
> Abstract:
>    This document defines the 666 (Unwanted) SIP response code, allowing
>    called parties to indicate that the call was unwanted.  The
>    terminating SIP entity may use this information to adjust future call
>    handling behavior for this called party or more broadly.
>
>
> The IETF datatracker status page for this draft is:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted_&d=DgICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=ra_qnaAY_CJxlY2iaBLZoJX4c-Z8WkEZo1RlHtBd0tM&s=0RGC_RjQLE0D4e1MF8JTEvWKRNFsrY_6wj__iKqw8lQ&e=
>
> There's also a htmlized version available at:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted-2D00&d=DgICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=ra_qnaAY_CJxlY2iaBLZoJX4c-Z8WkEZo1RlHtBd0tM&s=v2Iwj1kwSfluBGM44GaF1yEWLsRiOymrdGvqmN07_P8&e=
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=DgMFAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=Plum9_zaCsWU_39hBK1212bQzM2dM1gdd6gCGUNfPvo&s=hL3gdCySxzTHfn4d70jppme09ghKMiGjvA12VnXTwao&e=>.
>
> Internet-Drafts are also available by anonymous FTP at:
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DgICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=ra_qnaAY_CJxlY2iaBLZoJX4c-Z8WkEZo1RlHtBd0tM&s=qnHOAe3aYl8FZOnL0WUWcgF3wE1RYztyGZhov8k3nLY&e=
>
> _______________________________________________
> sipcore mailing list
> [email-masked]<mailto:[email-masked]>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sipcore&d=DgICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=ra_qnaAY_CJxlY2iaBLZoJX4c-Z8WkEZo1RlHtBd0tM&s=0LtCsPJ8E9s1apz4RoWgc9Id1UpeWe25EOFNeSGgejY&e=
>

_______________________________________________
sipcore mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sipcore&d=DgICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=ra_qnaAY_CJxlY2iaBLZoJX4c-Z8WkEZo1RlHtBd0tM&s=0LtCsPJ8E9s1apz4RoWgc9Id1UpeWe25EOFNeSGgejY&e=
_______________________________________________
sipcore mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sipcore<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sipcore&d=DgMFAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=Plum9_zaCsWU_39hBK1212bQzM2dM1gdd6gCGUNfPvo&s=Y9-llHqF6qIDm49cvjT6nkRpak97oqSrZxuzYNjXl-A&e=>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 3 Jan 2017 22:26:46 +0000

Agreed, there is going to be a learning period with education of the consumer and carriers adjusting actions taken

Regards

Martin C. Dolly

On Jan 3, 2017, at 5:16 PM, Henning Schulzrinne <[email-masked]<mailto:[email-masked]>> wrote:

The automaton has been dropped and only human agency is implied. Not sure what happens when the grand child of Alexa or Siri answers phone calls – see http://motherboard.vice.com/read/ai-professor-proposes-turing-red-flag-law for one option...

From: DOLLY, MARTIN C [mailto:[email-masked]]
Sent: Monday, December 19, 2016 4:44 PM
To: Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>
Cc: Paul Kyzivat <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-00.txt

Greetings

Regards
Martin C. Dolly

Henning

* Section 1:

* Section 2:

I suggest:

Otherwise I like it.

        Thanks,
        Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 3 Jan 2017 23:51:57 -0500

On 1/3/17 5:16 PM, Henning Schulzrinne wrote:

> *From:*DOLLY, MARTIN C [mailto:[email-masked]]
> *Sent:* Monday, December 19, 2016 4:44 PM
> *To:* Henning Schulzrinne <[email-masked]>
> *Cc:* Paul Kyzivat <[email-masked]>; [email-masked]
> *Subject:* Re: [sipcore] I-D Action:
> draft-ietf-sipcore-status-unwanted-00.txt
>
> The user needs to make a "clear" decision on 666 being sent. So the user
> pressing a button is clear, whether pre/post answer, but an application
> scenario is not

I expect we are in violent agreement here, but just in case...

I agree the user needs to make an active decision to press the button 
(or whatever). And to do so thoughtfully the user must understand the 
implications of doing so. But most users will *not* know that pushing 
the button results in a 666 being sent. Rather they associate the button 
with the actions taken elsewhere as a result of the 666 being sent.

	Thanks,
	Paul

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Wed, 4 Jan 2017 10:58:47 +0000

Correct, we are in agreement

Martin C. Dolly

On Jan 3, 2017, at 11:52 PM, Paul Kyzivat <[email-masked]<mailto:[email-masked]>> wrote:

*From:*DOLLY, MARTIN C [mailto:[email-masked]]
*Sent:* Monday, December 19, 2016 4:44 PM
*To:* Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>
*Cc:* Paul Kyzivat <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
*Subject:* Re: [sipcore] I-D Action:
draft-ietf-sipcore-status-unwanted-00.txt

I agree the user needs to make an active decision to press the button (or whatever). And to do so thoughtfully the user must understand the implications of doing so. But most users will *not* know that pushing the button results in a 666 being sent. Rather they associate the button with the actions taken elsewhere as a result of the 666 being sent.

   Thanks,
   Paul

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 4 Jan 2017 11:48:20 +0000

I think clear decision != pressing a button (at least not necessarily). For example, I can envision some UI, which lets the user enter some numbers it considers as spam (based on previous experience) and a 666 reply is generated without even ringing the phone/user not pressing a button if a call is received from such a number. This would satisfy the "clear decision" criterion (the user enters the number/ID to the list) but does not require the user to press a button for subsequent calls.

Thanks,
Tolga

From: sipcore [mailto:[email-masked]] On Behalf Of DOLLY, MARTIN C
Sent: Wednesday, January 04, 2017 5:59 AM
To: Paul Kyzivat <[email-masked]>
Cc: [email-masked]; Henning Schulzrinne <[email-masked]>
Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-00.txt

   Thanks,
   Paul