Subject: [sipcore] draft-jesske-sipcore-reason-q850-loc-00.txt

From: <[email-masked]>
Date: Mon, 27 Mar 2017 22:39:44 +0000

Dear all,
today I have presented the draft-jesske-dispatch-reason-loc-q850 in the DISPATCH meeting.
The decision was to dispatch the draft to SIPCORE.
Thus I have now an update of this draft solving the comments already made on the dispatch email list and changing it to sipcore.

https://www.ietf.org/internet-drafts/draft-jesske-sipcore-reason-q850-loc-00.txt

This draft adds a location value parameter to the reason-extension parameter in [RFC3326] so that the [Q.850] location value can be interworked from the PSTN.

Comments are welcome.

Thank you and Best Regards

Roland Jesske

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Mar 2017 23:31:11 -0400

I have a couple of comments:

The value for "location" is defined as just a string, which allows 
pretty much any value. But then the draft goes on to say "The values to 
be used as location are:" and a list of values. There is no normative 
language here. So its not at all clear if this is intended to be an 
exhaustive list with other values being forbidden, or if this is just a 
list of suggested values with others being permitted. If others are 
permitted, no mechanism is provided for agreeing on what other values mean.

IMO the list of values ought to be normative. And if it is expected that 
other values may be added in the future then some sort of extension 
mechanism should be specified.

	Thanks,
	Paul

On 3/27/17 6:39 PM, [email-masked] wrote:
> Thus I have now an update of this draft solving the comments already
> made on the dispatch email list and changing it to sipcore.
>
> _https://www.ietf.org/internet-drafts/draft-jesske-sipcore-reason-q850-loc-00.txt_
>
> This draft adds a location value parameter to the reason-extension
> parameter in [RFC3326] so that the [Q.850] location value can be
> interworked from the PSTN.
>
> Comments are welcome.
>
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: <[email-masked]>
Date: Tue, 28 Mar 2017 10:21:15 +0000

Hi Paul,
Thank you for your comment.
You are right. I assume that ITU-T will not touch Q.850 anymore.
So I will change the wording and make the values normative.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: sipcore [mailto:[email-masked]] Im Auftrag von Paul Kyzivat
Gesendet: Montag, 27. März 2017 22:31
An: [email-masked]
Betreff: Re: [sipcore] draft-jesske-sipcore-reason-q850-loc-00.txt

The value for "location" is defined as just a string, which allows pretty much any value. But then the draft goes on to say "The values to be used as location are:" and a list of values. There is no normative language here. So its not at all clear if this is intended to be an exhaustive list with other values being forbidden, or if this is just a list of suggested values with others being permitted. If others are permitted, no mechanism is provided for agreeing on what other values mean.

IMO the list of values ought to be normative. And if it is expected that other values may be added in the future then some sort of extension mechanism should be specified.

	Thanks,
	Paul

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Tue, 28 Mar 2017 10:36:29 +0000

Hi Roland,
A few review comments: 

Abstract
I think the following sentence from the Introduction should be added to the end of the abstract: "This document adds a location value parameter to the reason-extension parameter in [RFC3326] so that the [Q.850] location value can be interworked from the PSTN". 

1. Introduction 
I think that the sentence "[RFC3326] does specify that a ISUP [Q.850] cause code can be carried within a SIP response." makes more sense if it says "[RFC6432] does specify that a ISUP [Q.850] cause code can be carried within a SIP response". I notice that the [RFC6432] reference is not currently used in the body of the draft. 

3. Rationale
I think the sentence "The ISDN location is defined in [Q.850]." might be misleading as [Q.850] is an informative reference and the location values are defined within the draft. I prefer "The ISDN location is described in [Q.850] and defined in this document". 

4. Mechanism
Also says "ISUP location value defined in [Q.850]", I prefer "ISUP location value described in [Q.850] and defined in this document."

9. Acknowledgments
Thanks for the acknowledgment, I noticed that my name is missing an 'e' :-)

Regards,
Peter

> -----Original Message-----
> From: sipcore [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: 28 March 2017 11:21
> To: [email-masked]; [email-masked]
> Subject: Re: [sipcore] draft-jesske-sipcore-reason-q850-loc-00.txt
> 
> Hi Paul,
> The value for "location" is defined as just a string, which allows pretty much
> any value. But then the draft goes on to say "The values to be used as
> location are:" and a list of values. There is no normative language here. So its
> not at all clear if this is intended to be an exhaustive list with other values
> being forbidden, or if this is just a list of suggested values with others being
> permitted. If others are permitted, no mechanism is provided for agreeing
> on what other values mean.
> 
> IMO the list of values ought to be normative. And if it is expected that other
> values may be added in the future then some sort of extension mechanism
> should be specified.
> 
> 	Thanks,
> 	Paul
>