Subject: [sipcore] Draft new: draft-mohali-sipcore-originating-cdiv-parameter-00

From: <[email-masked]>
Date: Sun, 12 Mar 2017 21:22:09 +0000

Hi all,

Please find hereafter a new version of I-D, draft-mohali-sipcore-originating-cdiv-parameter-00 (was draft-mohali-dispatch-originating-cdiv-parameter-03).
https://www.ietf.org/internet-drafts/draft-mohali-sipcore-originating-cdiv-parameter-00.txt

Based on ADs and Chairs guidance, this draft is moved from DISPATCH to SIPCORE following the new charter of sipcore WG.

Abstract:
   This specification defines a new parameter of the P-Served-User
   header field in the Session Initiation Protocol (SIP).  This new
   "orig-cdiv" parameter defines the session case used by a proxy when
   handling an originating session after Call Diversion (CDIV) services
   has been invoked for the served user.  The P-Served-User header field
   is defined in RFC5502 to convey the identity of the served user and
   the session case that applies to this particular communication
   session and application invocation.  This document updates RFC5502 to
   add the "originating after CDIV" session case and to provide more
   guidance for using the P-Served-User header field in IP networks that
   were missing in RFC5502.

>From the discussion in DISPATCH, in this version of the draft, the syntax of the header could be improved as shown below:

 sessioncase-param        = ("sescase" EQUAL ("orig" / "term")) / "orig-cdiv"
 registration-state-param = "regstate" EQUAL ("unreg" / "reg")

This draft is not in the agenda for IETF 98 but comments are welcomed anyway.

Best regards,
Marianne

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Thu, 30 Mar 2017 17:21:56 -0500

Hi all,

I mentioned this draft during the WG session today. Does anyone have any 
comments on the draft? Should it become a WG document?

Thanks!

Jean

On 3/12/17 4:22 PM, [email-masked] wrote:
> Hi all,
>
> Please find hereafter a new version of I-D,
> draft-mohali-sipcore-originating-cdiv-parameter-00 (was
> draft-mohali-dispatch-originating-cdiv-parameter-03).
>  Based on ADs and Chairs guidance, this draft is moved from DISPATCH
> to SIPCORE following the new charter of sipcore WG.
>
> Abstract: This specification defines a new parameter of the
> P-Served-User header field in the Session Initiation Protocol (SIP).
> This new "orig-cdiv" parameter defines the session case used by a
> proxy when handling an originating session after Call Diversion
> (CDIV) services has been invoked for the served user.  The
> P-Served-User header field is defined in RFC5502 to convey the
> identity of the served user and the session case that applies to this
> particular communication session and application invocation.  This
> document updates RFC5502 to add the "originating after CDIV" session
> case and to provide more guidance for using the P-Served-User header
> field in IP networks that were missing in RFC5502.
>
>> From the discussion in DISPATCH, in this version of the draft, the
>> syntax of the header could be improved as shown below:
>
> sessioncase-param        = ("sescase" EQUAL ("orig" / "term")) /
> "orig-cdiv" registration-state-param = "regstate" EQUAL ("unreg" /
> "reg")
>
> Best regards, Marianne
>  Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> que les pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or
> privileged information that may be protected by law; they should not
> be distributed, used or copied without authorisation. If you have
> received this email in error, please notify the sender and delete
> this message and its attachments. As emails may be altered, Orange is
> not liable for messages that have been modified, changed or
> falsified. Thank you.
>
> _______________________________________________ sipcore mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 31 Mar 2017 02:23:52 +0000

Hi,

I support it becoming a WG document, and I will participate in the work by reviewing and commenting.

Regards,
Christer 

Sent from my iPhone

> On 30 Mar 2017, at 17.22, A. Jean Mahoney <[email-masked]> wrote:
> 
> Hi all,
> 
> I mentioned this draft during the WG session today. Does anyone have any comments on the draft? Should it become a WG document?
> 
> Thanks!
> 
> Jean
> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 31 Mar 2017 03:09:30 +0000

AT&T Supports

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Thursday, March 30, 2017 10:24 PM
To: A. Jean Mahoney <[email-masked]>
Cc: [email-masked]
Subject: Re: [sipcore] Draft new: draft-mohali-sipcore-originating-cdiv-parameter-00

Hi,

Regards,
Christer 

Sent from my iPhone

>> _____________________________________________________________________
>> ____________________________________________________
>>

---

From: Andrew Allen <[email-masked]>
Date: Fri, 31 Mar 2017 06:21:28 +0000

I also support this becoming a WG document.

Sent from my BlackBerry - the most secure mobile device
From: [email-masked]
Sent: March 30, 2017 9:24 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [sipcore] Draft new: draft-mohali-sipcore-originating-cdiv-parameter-00

Hi,

Regards,
Christer

Sent from my iPhone

---

From: Atle Monrad <[email-masked]>
Date: Fri, 31 Mar 2017 07:19:29 +0000

Hi
I also support the draft becoming a WG document.

/atle

Sent from my Android phone using Symantec TouchDown (www.symantec.com)

-----Original Message-----
From: Andrew Allen [[email-masked]]
Received: fredag, 31 mar. 2017, 8:22
To: A. Jean Mahoney [[email-masked]]; Christer Holmberg [[email-masked]]
CC: sipcore [[email-masked]]
Subject: Re: [sipcore] Draft new: draft-mohali-sipcore-originating-cdiv-parameter-00

Hi,

Regards,
Christer

Sent from my iPhone

---

From: <[email-masked]>
Date: Fri, 31 Mar 2017 12:29:25 +0000

Hi Jean,
I have read Marianne's draft and support the draft to become a WG document.
Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: sipcore [mailto:[email-masked]] Im Auftrag von A. Jean Mahoney
Gesendet: Donnerstag, 30. März 2017 17:22
An: [email-masked]
Betreff: Re: [sipcore] Draft new: draft-mohali-sipcore-originating-cdiv-parameter-00

Hi all,

Thanks!

Jean

On 3/12/17 4:22 PM, [email-masked] wrote:
> ______________________________________________________________________
> ___________________________________________________
>
> received this email in error, please notify the sender and delete this 
> message and its attachments. As emails may be altered, Orange is not 
> liable for messages that have been modified, changed or falsified. 
> Thank you.
>

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore