Subject: Re: [sipcore] Last Call: <draft-ietf-sipcore-status-unwanted-04.txt> (A SIP Response Code for Unwanted Calls) to Proposed Standard

From: Souma Badombena <[email-masked]>
Date: Sun, 2 Apr 2017 07:47:12 -0700

"unwanted" as opposed to "blocked" -- "unwanted" is an enhancing
functionality and allowing possible flexibility

I just wanted to mention a relevant aspect where the "Unwanted" concept
addresses a shortcoming and may be improved upon with subsequent parameters
enrichments.
For some SIP calling and messaging application there exists the concept of
"contact blocking", "user blacklisting" or "personal blocking" where a user
can select specific contacts or undersired identities (phone numbers,
usernames, aliases etc...) to be blocked and therefore allowing the
blocking user to reject calls or messages from a given blocked user. This
very method or technique consists in maintaining a resource list of blocked
contact and applying restrictive or rejection filters to them either a
local (client) level or at network level. So in a parallel with the "SIP
666 - unwanted" solution, I notice that on one hand the  "unwanted" method
may be equivalent to the method or concept of blocking, but on the other
hand it does potentially offer an extensible flexibility for particular
cases, provided that the appropriate enhancement work is done in the
future. For example in particular cases where a user may want to add more
selectivity to the how the "unwanted" call instances and originators are
treated, such as setting a time window or period for which the calls are
unwanted or associating a geolocation aspect to calls that need to be
treated as unwanted. etc.. There are several scenarios available provided
that the specification provides for further extensibility combined to
programmatic mechanisms or machine learning pattern building procedures. So
with that being said, should we agree that the proposed SIP response code
could be further extended to bear multiple contextual reason codes?

Thanks.
-- 
Souma Badombena-Wanta

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 3 Apr 2017 01:29:33 +0000

This seems to be related to the previous comment. I agree that users should have the ability to specify, either within an app or via a web interface controlling a carrier or third-party operated service, how calls are treated. As you say, this could be fairly complex in its details, such as depending on the time of day. ("Don't mind survey calls, but not after 7 pm.")

I will note that many a moon ago, we actually developed a flexible XML-based language for call handling purposes (RFC 3880, CPL). Wouldn't be hard to extend it for this purpose, but I suspect CPL is not among the commonly-implemented SIP-related RFCs...

Henning

________________________________
From: sipcore <[email-masked]> on behalf of Souma Badombena <[email-masked]>
Sent: Sunday, April 2, 2017 10:47:12 AM
To: [email-masked]
Subject: Re: [sipcore] Last Call: <draft-ietf-sipcore-status-unwanted-04.txt> (A SIP Response Code for Unwanted Calls) to Proposed Standard

"unwanted" as opposed to "blocked" -- "unwanted" is an enhancing functionality and allowing possible flexibility

I just wanted to mention a relevant aspect where the "Unwanted" concept addresses a shortcoming and may be improved upon with subsequent parameters enrichments.
For some SIP calling and messaging application there exists the concept of "contact blocking", "user blacklisting" or "personal blocking" where a user can select specific contacts or undersired identities (phone numbers, usernames, aliases etc...) to be blocked and therefore allowing the blocking user to reject calls or messages from a given blocked user. This very method or technique consists in maintaining a resource list of blocked contact and applying restrictive or rejection filters to them either a local (client) level or at network level. So in a parallel with the "SIP 666 - unwanted" solution, I notice that on one hand the  "unwanted" method may be equivalent to the method or concept of blocking, but on the other hand it does potentially offer an extensible flexibility for particular cases, provided that the appropriate enhancement work is done in the future. For example in particular cases where a user may want to add more selectivity to the how the "unwanted" call instances and originators are treated, such as setting a time window or period for which the calls are unwanted or associating a geolocation aspect to calls that need to be treated as unwanted. etc.. There are several scenarios available provided that the specification provides for further extensibility combined to programmatic mechanisms or machine learning pattern building procedures. So with that being said, should we agree that the proposed SIP response code could be further extended to bear multiple contextual reason codes?

Thanks.
--
Souma Badombena-Wanta

---

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 3 Apr 2017 10:57:19 +0000

This certainly would be something completely outside of the scope of "status-unwanted" AFAICT.

I think we should consider how all this would work "in real life" from an "end-user perspective". For blocking decisions, they most probably would rely on some web-portal. I don't see CPL (or anything else) to be utilized for this either. One may argue, why not use a web-based interface for reporting that a call is "unwanted"? That would require the user to logs-in, enter some information about the call for correlation purposes, e.g. Calling-Party-Id as seen by him, time of the call etc.., all after the call and nobody would do that. The only viable way this information can be provided by end-users is just by pressing a button during the call IMHO. And that, is the raison d'etre for "status unwanted".

Let's keep things practically useful and simple.

Thanks,
Tolga

From: sipcore [mailto:[email-masked]] On Behalf Of Henning Schulzrinne
Sent: Sunday, April 2, 2017 9:30 PM
To: Souma Badombena <[email-masked]>; [email-masked]
Subject: Re: [sipcore] Last Call: <draft-ietf-sipcore-status-unwanted-04.txt> (A SIP Response Code for Unwanted Calls) to Proposed Standard

Henning

________________________________
From: sipcore <[email-masked]<mailto:[email-masked]>> on behalf of Souma Badombena <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, April 2, 2017 10:47:12 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [sipcore] Last Call: <draft-ietf-sipcore-status-unwanted-04.txt> (A SIP Response Code for Unwanted Calls) to Proposed Standard

Thanks.
--
Souma Badombena-Wanta