Subject: [sipcore] Mirja Kühlewind's No Objection on draft-ietf-sipcore-status-unwanted-05: (with COMMENT)

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 24 Apr 2017 04:14:22 -0700

Mirja Kühlewind has entered the following ballot position for
draft-ietf-sipcore-status-unwanted-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-status-unwanted/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I actually have one mostly technical question: It is not fully clear to
me if the Unwanted response code always indicates a user action or if the
same code is used when an automated system declines the call? My
understanding is that the idea is that this could also be automated if
the user has some kind of control of the system (which is probably hard
to verify). Or would it make sense to distinct between the cases where
the user actively rejects a call or an automated system is generating the
response code (on behalf of the user)?

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 24 Apr 2017 14:29:55 +0000

There was an extensive discussion on the "who is responsible" issue on the list. My take is that there's just no good way to know whether the 'unwanted' response was generated by a button press or something semi-automated (e.g., the system pops up a "you hung up very quickly. Was this a spam call?" dialog box) or automated fancy-machine-learning algorithm implemented on the end system. My guess is that manual will be, by far, the most common usage. If I implement ML on the end system for call classification, I probably want to control the experience and thus not muddy the waters by having the network filter, too.

Practically-speaking, I don't see a good way to enforce any distinction, even leaving aside the possibilities between a fully-manual and invisibly-automatic mechanism. It is also not clear how the network would make use of such a distinction - both humans and machines make mistakes.

Thus, I think the intent is to use it for human feedback, but without trying to be overly prescriptive.

That said, the call-info draft may need an extension for the kind of "backward" indication so that an automated call recipient can tell the network how it classified the call.

Henning

-----Original Message-----
From: Mirja Kühlewind [mailto:[email-masked]] 
Sent: Monday, April 24, 2017 7:14 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; Adam Roach <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Mirja Kühlewind's No Objection on draft-ietf-sipcore-status-unwanted-05: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_iesg_statement_discuss-2Dcriteria.html&d=DwIDaQ&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=pxuO3nw6kw9wO2J3VMaOn96WscW6Xfx0rezXBVrB6MA&s=MG-50-smFxU54QYl1KNrnRaos5nVAFoDKpM_Fm2l2Ds&e=
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted_&d=DwIDaQ&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=pxuO3nw6kw9wO2J3VMaOn96WscW6Xfx0rezXBVrB6MA&s=wU_pnKWunwKpQ87EJo62tgb6DuObf2NsKXmx1SME6N8&e=

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 27 Apr 2017 15:54:35 +0200

Hi Henning,

yes I understand that there is no good way to enforce one or the other. I was 
mainly wondering a) what you want to emphasize in the document and make sure 
the receiver makes the right assumptions about this, and b) if it would make 
sense to provide a way to distinguish those two cases. Of course that would 
not guarantee that is would always be indicated correctly but some systems 
may indicate it if is there is a use cases where this information can be 
valuable...

Mirja

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 27 Apr 2017 14:51:56 +0000

I think the intent was exclusively for the human agent to press a button. Granted, there is no way to police this but this has been the scenario under consideration in the past. Anything other than that, e.g. human agent exclusively blacklisting certain AoRs, is supposed to be handled by other mechanisms, e.g. a web portal.

The semantics for 607 is: "I don’t want this call", nothing more, at least AFAIU and advocated so far. Actually we really should spell this out very clearly. Folks who did not participate during the evolution of this document keep having confusions on this issue.

Thanks,
Tolga

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
Sent: Thursday, April 27, 2017 9:55 AM
To: Henning Schulzrinne <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [sipcore] Mirja Kühlewind's No Objection on draft-ietf-sipcore-status-unwanted-05: (with COMMENT)

Hi Henning,

yes I understand that there is no good way to enforce one or the other. I was mainly wondering a) what you want to emphasize in the document and make sure the receiver makes the right assumptions about this, and b) if it would make sense to provide a way to distinguish those two cases. Of course that would not guarantee that is would always be indicated correctly but some systems may indicate it if is there is a use cases where this information can be valuable...

Mirja

> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted_&d=DwIDaQ&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK…

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 27 Apr 2017 14:52:17 +0000

Mirja,

One of my concerns is simplicity - I want to keep the mechanisms as minimal and straightforward as possible, to encourage rapid implementation. Since we are at the beginning of consumer-level unwanted call filtering, my take is to gain some experience and then add mechanisms. For example, for any automated mechanisms, you'd probably want more details as to the "why", primarily to deal with mis-classification and to ensure deliverability of calls. ("This good call was just classified as spam - what made that happen?") This is somewhat similar to the email problem, where the good guys need information to avoid accidentally tripping spam filters ("fix your SPF entry", "make sure that the header format is up to current standards rather than the 1980s version", "check why you ended up on this blacklist").

But I don't think we understand well enough how to provide such feedback for VoIP at this point.

Henning

-----Original Message-----
From: Mirja Kühlewind [mailto:[email-masked]] 
Sent: Thursday, April 27, 2017 9:55 AM
To: Henning Schulzrinne <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked]; Adam Roach <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: Mirja Kühlewind's No Objection on draft-ietf-sipcore-status-unwanted-05: (with COMMENT)

Hi Henning,

Mirja

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 27 Apr 2017 17:43:58 +0200

Okay. I have to say that sounds a little like this should be experimental. 
But I guess that's not that much on an issue. Still these open questions 
could be documented in the draft eventually.

Mirja

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 27 Apr 2017 17:42:38 +0200

Yes, making this more clear would be good.

Thanks!

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 27 Apr 2017 17:34:48 +0000

Note that the current draft is about human feedback (with the usual caveat that we can't police robots pretending to be humans), so the "don't understand" part would apply to providing automated feedback, not the draft under discussion.

-----Original Message-----
From: Mirja Kühlewind [mailto:[email-masked]] 
Sent: Thursday, April 27, 2017 11:44 AM
To: Henning Schulzrinne <[email-masked]>; The IESG <[email-masked]>
Cc: [email-masked]; Adam Roach <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: Mirja Kühlewind's No Objection on draft-ietf-sipcore-status-unwanted-05: (with COMMENT)

Okay. I have to say that sounds a little like this should be experimental. 
But I guess that's not that much on an issue. Still these open questions could be documented in the draft eventually.

Mirja

On 27.04.2017 16:52, Henning Schulzrinne wrote:
> Cc: [email-masked]; Adam Roach 
> <[email-masked]>; [email-masked]; [email-masked]
> Subject: Re: Mirja Kühlewind's No Objection on 
> draft-ietf-sipcore-status-unwanted-05: (with COMMENT)
>
> Hi Henning,
>
>> Cc: [email-masked]; Adam Roach 
>> <[email-masked]>; [email-masked]; [email-masked]; 
>> [email-masked]
>> Subject: Mirja Kühlewind's No Objection on 
>> draft-ietf-sipcore-status-unwanted-05: (with COMMENT)
>>
>> email addresses included in the To and CC lines. (Feel free to cut 
>> this introductory paragraph, however.)
>>
>>
>> Please refer to 
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_ies
>> g_statement_discuss-2Dcriteria.html&d=DwIDaQ&c=y0h0omCe0jAUGr4gAQ02Fw
>> &r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=pxuO3nw6kw9wO2J3VMaO
>> n96WscW6Xfx0rezXBVrB6MA&s=MG-50-smFxU54QYl1KNrnRaos5nVAFoDKpM_Fm2l2Ds
>> &e= for more information about IESG DISCUSS and COMMENT positions.
>>
>>
>> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf
>> .org_doc_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted_&d=DwIDaQ&c=y0h0o
>> mCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=pxu
>> O3nw6kw9wO2J3VMaOn96WscW6Xfx0rezXBVrB6MA&s=wU_pnKWunwKpQ87EJo62tgb6Du
>> Obf2NsKXmx1SME6N8&e=
>>
>>
>>
>> I actually have one mostly technical question: It is not fully clear 
>> to me if the Unwanted response code always indicates a user action or 
>> if the same code is used when an automated system declines the call? 
>> My understanding is that the idea is that this could also be 
>> automated if the user has some kind of control of the system (which 
>> is probably hard to verify). Or would it make sense to distinct 
>> between the cases where the user actively rejects a call or an 
>> automated system is generating the response code (on behalf of the user)?
>>
>>