Subject: Re: [sipcore] Proposal to revise the dual stack milestone

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 1 May 2017 07:18:14 +0000

I think that is a good idea with a few caveats:

i- Connectionless transports should be covered as well (possibly by making use of OPTIONS)
ii- Use of multiple interfaces/transport protocols should be mentioned as well. I think this can be done just by adding a few sentences along the lines of:
All IP Address Family/Transport Family/Interface triplet combinations should be tried simultaneously. Some headstart may be provided for certain combinations depending on local policy.

Otherwise I think it is the right approach not to dive into details of the algorithm to use. 

Thanks,
Tolga

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Dale R. Worley
Sent: Sunday, April 30, 2017 4:46 PM
To: [email-masked]
Subject: [sipcore] Proposal to revise the dual stack milestone

The Sipcore working group has the following milestone listed (at
https://datatracker.ietf.org/wg/sipcore/about/):

Dec 2017        Request publication of mechanisms for rapid dual-stack
                protocol selection in SIP

The draft draft-johansson-sip-he-connection is listed for this milestone.  However, that draft covers only a narrow subset of the overall problem.

Over the past month or so, I have been canvassing Sipcore members to find out if there is any practical demand for a dual-stack solution for SIP.  With the exception of a particular case, I have found no interest.

Because of this, I propose that we narrow the scope of this milestone to the one case for which I have found interest:

        Request publication of a mechanism for rapid dual-stack
        protocol selection in SIP when the destination has multiple,
        unprioritized targets for connection-oriented protocols

Conveniently, draft-johansson-sip-he-connection describes such a mechanism.  Its mechanism closely parallels that of RFC 6555 ("Happy Eyeballs"), and the text is essentially complete.  Because there are no unresolved technical issues, the text is complete, and there are known implementation instances where this mechanism is needed, I urge the approval of this draft even if its scope is narrow.

Dale

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: "A. Jean Mahoney" <[email-masked]>
Date: Mon, 15 May 2017 14:30:01 -0500

Hi everyone,

Does anyone else have any thoughts on modifying the milestone?

As the WG finishes up some of the current milestones and adds new WG 
documents, we'll need to update our milestone list.

Thanks!

Jean

On 5/1/17 2:18 AM, Asveren, Tolga wrote:
> i- Connectionless transports should be covered as well (possibly by
> making use of OPTIONS) ii- Use of multiple interfaces/transport
> protocols should be mentioned as well. I think this can be done just
> by adding a few sentences along the lines of: All IP Address
> Family/Transport Family/Interface triplet combinations should be
> tried simultaneously. Some headstart may be provided for certain
> combinations depending on local policy.
> 
> Thanks, Tolga
> -----Original Message----- From: sipcore
> [mailto:[email-masked]] On Behalf Of Dale R. Worley Sent:
> Sunday, April 30, 2017 4:46 PM To: [email-masked] Subject:
> [sipcore] Proposal to revise the dual stack milestone
> 
> Dec 2017        Request publication of mechanisms for rapid
> dual-stack protocol selection in SIP
> 
> The draft draft-johansson-sip-he-connection is listed for this
> milestone.  However, that draft covers only a narrow subset of the
> overall problem.
> 
> Over the past month or so, I have been canvassing Sipcore members to
> find out if there is any practical demand for a dual-stack solution
> for SIP.  With the exception of a particular case, I have found no
> interest.
> 
> Because of this, I propose that we narrow the scope of this milestone
> to the one case for which I have found interest:
> 
> Request publication of a mechanism for rapid dual-stack protocol
> selection in SIP when the destination has multiple, unprioritized
> targets for connection-oriented protocols
> 
> Conveniently, draft-johansson-sip-he-connection describes such a
> mechanism.  Its mechanism closely parallels that of RFC 6555 ("Happy
> Eyeballs"), and the text is essentially complete.  Because there are
> no unresolved technical issues, the text is complete, and there are
> known implementation instances where this mechanism is needed, I urge
> the approval of this draft even if its scope is narrow.
> 
> Dale
> 
> _______________________________________________ sipcore mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/sipcore
> 
> _______________________________________________ sipcore mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 15 May 2017 20:35:13 +0000

Hi Jean -

There are two distinct sub-milestones for this milestone, in my opinion.  The first one is narrower and can be scoped as Dale indicated:

I think draft-johansson-sip-he-connection can be adopted for this.

Subsequently we hope to provide a more comprehensive dual-stack solution for SIP along the lines of draft-worley-sipcore-happy-earballs. My preference is we give the latter its due rigor and focus, so I don’t think they should be done in parallel, rather in series.

Thanks,

Gonzalo

On May 15, 2017, at 3:30 PM, A. Jean Mahoney <[email-masked]<mailto:[email-masked]>> wrote:

Hi everyone,

As the WG finishes up some of the current milestones and adds new WG documents, we'll need to update our milestone list.

Thanks!

Jean

Otherwise I think it is the right approach not to dive into details
of the algorithm to use.
Sunday, April 30, 2017 4:46 PM To: [email-masked]<mailto:[email-masked]> Subject:
The Sipcore working group has the following milestone listed (at https://datatracker.ietf.org/wg/sipcore/about/):
_______________________________________________ sipcore mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/sipcore
_______________________________________________ sipcore mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/sipcore

_______________________________________________
sipcore mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sipcore