Subject: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-06.txt

From: [email-masked]
Date: Wed, 10 May 2017 10:58:20 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core of the IETF.

        Title           : A SIP Response Code for Unwanted Calls
        Author          : Henning Schulzrinne
	Filename        : draft-ietf-sipcore-status-unwanted-06.txt
	Pages           : 8
	Date            : 2017-05-10

Abstract:
   This document defines the 607 (Unwanted) SIP response code, allowing
   called parties to indicate that the call or message was unwanted.
   SIP entities may use this information to adjust how future calls from
   this calling party are handled for the called party or more broadly.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-status-unwanted/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-status-unwanted-06
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-status-unwanted-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-status-unwanted-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 15 May 2017 11:02:19 +0000

Looks good to me with just a few comments (or rants, if you will): 

i-  
"The user agent of
   the called party, based on input from the called party or some UA-
   internal logic, uses this to indicate that this call is unwanted and
   that future attempts are likely to be similarly rejected."

FWIW, I really feel uneasy about the "or some UA-internal logic" part of the first sentence.

ii-
"As discussed in Section 6, reversing
   the 'unwanted' labeling is beyond the scope of this mechanism, as it
   will likely require a mechanism other than call signaling."

This could be a great place to add a statement that this response code pertains only to a single call and does not mean that the end-user has a desire for blocking the called party permanently. This really would add great value to prevent misinterpretation of 607 IMHO.

Thanks,
Tolga

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 10, 2017 1:58 PM
To: [email-masked]
Cc: [email-masked]
Subject: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-06.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
sipcore mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sipcore

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 15 May 2017 19:29:25 +0000

Tolga,

Given that both points have been discussed many times before, I'm reluctant to open those issues again.

On the second issue, 607 is useless if it is has no (potential, statistical, etc.) influence on future calls. The called party indicates that they didn't want to receive that call and don't want to be called again by the same party, either. I won't repeat the usual caveats we discussed about phone number changes and such, as those are covered in the document.

Henning

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Asveren, Tolga
Sent: Monday, May 15, 2017 7:02 AM
To: [email-masked]
Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-06.txt

i-  
"The user agent of

ii-

Thanks,
Tolga

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 10, 2017 1:58 PM
To: [email-masked]
Cc: [email-masked]
Subject: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-06.txt

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted_&d=DwICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=3y_KHNXo2fq8US-YtsrOVp8ZLkP5SpfX9k73qs25vwE&s=d8nMGqUjgAnZr_F7bIVtTr4QNXYDwuKhpd6reLMfaFI&e= 

There are also htmlized versions available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted-2D06&d=DwICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=3y_KHNXo2fq8US-YtsrOVp8ZLkP5SpfX9k73qs25vwE&s=4ftlZWWq_Hroo1UNfrl1kVXt9I3mDp51YByQsyroCuQ&e= 
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted-2D06&d=DwICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=3y_KHNXo2fq8US-YtsrOVp8ZLkP5SpfX9k73qs25vwE&s=aWXdzCCYLm7gAYjKWeWD6xmTkVdy1I3tFq-3Gny_FzI&e= 

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dsipcore-2Dstatus-2Dunwanted-2D06&d=DwICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=3y_KHNXo2fq8US-YtsrOVp8ZLkP5SpfX9k73qs25vwE&s=Ihmck2y6dNA28nzmCASmi7n6k1_hXxgBHjNW4bzKygg&e= 

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=3y_KHNXo2fq8US-YtsrOVp8ZLkP5SpfX9k73qs25vwE&s=XldJkTgvhflTtLhcALaRywRr9dfZ4EMWx8lz7DvBVxg&e= 

_______________________________________________
sipcore mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sipcore&d=DwICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=3y_KHNXo2fq8US-YtsrOVp8ZLkP5SpfX9k73qs25vwE&s=_turveVqD0DjvCoQs9ycbZrozjiAWjtJK3Jsl0uT13k&e= 

_______________________________________________
sipcore mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sipcore&d=DwICAg&c=y0h0omCe0jAUGr4gAQ02Fw&r=FJcVoDkWM5EiVcV0ReX8lDU1XeHIYRHfarpk4MK59RE&m=3y_KHNXo2fq8US-YtsrOVp8ZLkP5SpfX9k73qs25vwE&s=_turveVqD0DjvCoQs9ycbZrozjiAWjtJK3Jsl0uT13k&e=

---

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 16 May 2017 08:49:55 +0000

Henning,

I am not claiming that there are disagreements about these topics within active participants. I merely was stating that some clarifications in the text could be beneficial for future readers -as we have seen during recent reviews by non-insiders that some confusion arose-.

Having said that, I wouldn't consider the current version as "requires some fixes". It can proceed to become a RFC IMHO even if you prefer not to add any clarifications. 

Thanks,
Tolga

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Monday, May 15, 2017 3:29 PM
To: Asveren, Tolga <[email-masked]>; [email-masked]
Subject: RE: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-06.txt

Tolga,

Henning

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Asveren, Tolga
Sent: Monday, May 15, 2017 7:02 AM
To: [email-masked]
Subject: Re: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-06.txt

i-  
"The user agent of

ii-

Thanks,
Tolga

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 10, 2017 1:58 PM
To: [email-masked]
Cc: [email-masked]
Subject: [sipcore] I-D Action: draft-ietf-sipcore-status-unwanted-06.txt

Abstract: