Subject: [sipcore] Adam Roach's Yes on draft-ietf-sipcore-content-id-07: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Wed, 05 Jul 2017 08:06:01 -0700

Adam Roach has entered the following ballot position for
draft-ietf-sipcore-content-id-07: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-content-id/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I'm a little surprised that the document didn't end up with any text detailing
the historical context for formally adding this mechanism.

I would expect to see some discussion explaining that the use of Content-ID as
a SIP header field has been inferred as acceptable for years, and that so many
IETF participants had taken it as given that Content-ID was *already* a
registered SIP header field that it appears in examples in (for example) RFCs
5368 and 6080.

While I think the document would serve its intended purpose as-is, I believe
that more explanatory text in the Introduction section to clarify that this is
an attempt to formalize already-assumed (and likely deployed) behavior --
rather than simply casting it as a minor optimization -- would go a long way
towards dealing with Eric's concerns.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 5 Jul 2017 18:33:56 +0000

Hi Adam,

I agree that there should be text about existing assumptions/usages (RFC 5368 and 6080) of Content-ID as a SIP header field. We'll add text about that.

Regards,

Christer

-----Original Message-----
From: Adam Roach [mailto:[email-masked]] 
Sent: 05 July 2017 17:06
To: The IESG <[email-masked]>
Cc: [email-masked]; Jean Mahoney <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Adam Roach's Yes on draft-ietf-sipcore-content-id-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I'm a little surprised that the document didn't end up with any text detailing the historical context for formally adding this mechanism.

I would expect to see some discussion explaining that the use of Content-ID as a SIP header field has been inferred as acceptable for years, and that so many IETF participants had taken it as given that Content-ID was *already* a registered SIP header field that it appears in examples in (for example) RFCs
5368 and 6080.

While I think the document would serve its intended purpose as-is, I believe that more explanatory text in the Introduction section to clarify that this is an attempt to formalize already-assumed (and likely deployed) behavior -- rather than simply casting it as a minor optimization -- would go a long way towards dealing with Eric's concerns.