Subject: [smartpowerdir] FW: [Netconf] NETCONF on Constrained Devices (NETCONF Light)

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 16 Jun 2011 12:08:43 +0200

Hi All,

below is a draft on "Network Configuration for Constrained Devices".

There will be most likely another discussion on "Network Management for
Smart Objects" in the OPSAREA open meeting in Quebec (s. attachment).

Cheers, 
Mehmet 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Juergen Schoenwaelder
Sent: Monday, June 06, 2011 8:50 AM
To: [email-masked]
Subject: [Netconf] NETCONF on Constrained Devices (NETCONF Light)

Hi,

at the last IETF, we demoed some work to fit NETCONF on small embedded
resource constrained devices running Contiki. We have meanwhile made
some more progress and we started to write up an I-D that defines what
we currently call 'NETCONF Light'.

/js

---8<---8<---

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Network Configuration Protocol for Constrained
Devices (NETCONF Light)
	Author(s)       : Vladislav Perelman
                          Juergen Schoenwaelder
                          Mehmet Ersue
	Filename        : draft-schoenw-netconf-light-00.txt
	Pages           : 12
	Date            : 2011-06-05

   This document describes a profile of the NETCONF protocol for
   resource constrained devices, called NETCONF Light.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-schoenw-netconf-light-00.txt 

---8<---8<---

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 16 Jun 2011 12:19:25 +0200

w/ attachment

-----Original Message-----
From: Ersue, Mehmet (NSN - DE/Munich) 
Sent: Thursday, June 16, 2011 12:09 PM
To: [email-masked]'
Cc: 'Juergen Schoenwaelder'; Tschofenig, Hannes (NSN - FI/Espoo)
Subject: FW: [Netconf] NETCONF on Constrained Devices (NETCONF Light)

Hi All,

Cheers, 
Mehmet 

-----Original Message-----

Hi,

/js

---8<---8<---

---8<---8<---

Subject: Re: Network Management for Smart Objects
From: "ext Peter Saint-Andre" <[email-masked]>
To: "Romascanu, Dan (Dan)" <[email-masked]>
Cc: "Juergen Schoenwaelder" <[email-masked]>, "Pete Resnick" <[email-masked]>, "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>, "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>, "Jari Arkko" <[email-masked]>, "Ronald Bonica" <[email-masked]>
Date: Wed, 15 Jun 2011 18:48:03 +0200

Yes, I am happy to reach out to folks in the CORE WG about this.

On 6/15/11 2:22 AM, Romascanu, Dan (Dan) wrote:
> 
> 
> Pete and Peter, 
> 
> See the following exchange of messages and Juergen's question. 
> 
> Your opinion? 
> 
> 
> Thanks and Regards,
> 
> Dan 
> 
>> From: Juergen Schoenwaelder [mailto:j.schoenwaelder@jacobs-
>> university.de]
>> Sent: Wednesday, June 15, 2011 11:17 AM
>> To: Romascanu, Dan (Dan)
>> Cc: [email-masked]; [email-masked]; Jari Arkko; Ronald
>> Bonica
>> Subject: Re: Network Management for Smart Objects
>>
>> On Tue, Jun 14, 2011 at 06:27:43PM +0200, Romascanu, Dan (Dan) wrote:
>>>
>>>
>>> Juergen, Mehmet,
>>>
>>> See the following message from Hannes and Jari following up the smart
>>> object workshop and your contributions there. They suggest that you
>>> continue the discussion - possibly in the OPSAREA open meeting in
>> Quebec
>>> City. What is your response to this suggestion?
>>>
>>
>> There is meanwhile also this I-D:
>>
>>   V. Perelman, J. Schönwälder, M. Ersue: Network Configuration
>>   Protocol for Constrained Devices (NETCONF Light). Internet-Draft
>>   <draft-schoenw-netconf-light-00.txt>, June 2011.
>>
>> I believe there is a more general question how networks made of
>> contrained devices should be managed and if we spent time on this in
>> OPS-AREA, we should also get CORE/COAP folks, that is parts of the APP
>> area, into this since they might have a different view.
>>
>> /js
>>
>> --
>>> -----------
>>> From: Hannes Tschofenig [mailto:[email-masked]]
>>> Sent: Friday, June 10, 2011 12:19 PM
>>> To: Romascanu, Dan (Dan)
>>> Cc: Hannes Tschofenig; Jari Arkko
>>> Subject: Network Management for Smart Objects
>>>
>>> Hi Dan,
>>>
>>> as discussed on IM a few minutes ago I send you the material that was
>>> proposed for discussion at the smart object workshop.
>>>
>>> In this position paper Mehmet talks at a high level about the need to
>>> look into network management in the smart object space:
>>> http://www.iab.org/wp-content/IAB-uploads/2011/03/Ersue.pdf
>>>
>>> Juergen then goes into more details with his position paper with a
>>> focus on SNMP:
>>> http://www.iab.org/wp-content/IAB-uploads/2011/03/Schoenwaelder.pdf
>>>
>>> There is also an IETF draft available:
>>> http://www.ietf.org/internet-drafts/draft-hamid-6lowpan-snmp-
>>> optimizations-03.txt
>>>
>>> I would suggest to ping Mehmet & Juergen to put a talk together for
>>> your open area meeting to see whether others have also looked into
>> the
>>> topic.
>>>
>>> Ciao
>>> Hannes
> 

-- 
Peter Saint-Andre
https://stpeter.im/