Subject: [Spasm] Fwd: New Version Notification for draft-housley-lamps-cms-sha3-hash-00.txt

From: Russ Housley <[email-masked]>
Date: Mon, 27 Mar 2017 11:44:26 -0400

Since people wanted to talk about SHA3 in certificates and S/MIME …

Russ

> From: [email-masked]
> Subject: New Version Notification for draft-housley-lamps-cms-sha3-hash-00.txt
> Date: March 27, 2017 at 11:42:43 AM EDT
> To: "Russ Housley" <[email-masked]>
> 
> 
> A new version of I-D, draft-housley-lamps-cms-sha3-hash-00.txt
> has been successfully submitted by Russ Housley and posted to the
> IETF repository.
> 
> Name:		draft-housley-lamps-cms-sha3-hash
> Revision:	00
> Title:		Use of the SHA3 One-way Hash Functions in the Cryptographic Message Syntax (CMS)
> Document date:	2017-03-27
> Group:		Individual Submission
> Pages:		7
> URL:            https://www.ietf.org/internet-drafts/draft-housley-lamps-cms-sha3-hash-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-housley-lamps-cms-sha3-hash/
> Htmlized:       https://tools.ietf.org/html/draft-housley-lamps-cms-sha3-hash-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-housley-lamps-cms-sha3-hash-00
> 
> 
> Abstract:
>   This document describes the conventions for using the four one-way
>   hash functions in the SHA3 family with the Cryptographic Message
>   Syntax (CMS).

---

From: "Dang, Quynh (Fed)" <[email-masked]>
Date: Mon, 27 Mar 2017 20:38:00 +0000

Hi Russ and all,

Why don't we just specify SHAKE128/256 and SHAKE256/512 ? If we would like 224 and 384 bit hashes, we can add SHAKE128/224 and SHAKE256/384 respectively.

Those 4 SHAKEs have better performances than the 4 SHA3s and are also NIST-approved hash functions.

I could assign new OIDs for those 4 SHAKEs above with their fixed output lengths if desired.

Regards,
Quynh.

________________________________
From: Spasm <[email-masked]> on behalf of Russ Housley <[email-masked]>
Sent: Monday, March 27, 2017 11:44:26 AM
To: SPASM
Subject: [Spasm] Fwd: New Version Notification for draft-housley-lamps-cms-sha3-hash-00.txt

Russ

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-housley-lamps-cms-sha3-hash-00.txt
Date: March 27, 2017 at 11:42:43 AM EDT
To: "Russ Housley" <[email-masked]<mailto:[email-masked]>>

Abstract: