Subject: Re: [Spasm] Spasm Digest, Vol 13, Issue 20

From: Viktor Dukhovni <[email-masked]>
Date: Tue, 25 Apr 2017 17:01:07 -0400

> On Apr 25, 2017, at 3:00 PM, [email-masked] wrote:
> 
>>   * It incorrectly asserts that SMTPUtf8Name is only for addresses
>>     with a non-ASCII localpart, while in fact even ASCII localparts
>>     at UTF-8 domains can be used with SMTPUtf8Name, whenever the
>>     relevant email address employs a UTF-8 domain name.
>> 
>> [JLS] Based on previous mails on the list.  It is my understanding that the
>> WG position is correctly reflected in the document.  
> 
> Right.  If the email address can be represented in a form that can be carried in rfc822Name, then it should be carried there.  Otherwise, it should be carried in SmtpUTF9Name.

Well, but not right, because the text seems to imply that
with an ASCII localpart and a UTF-8 domain the email address
SAN is to be presented as an rfc822Name, but that would require
conversion from U-labels to A-labels.  Is that the intent?  I
recall that earlier discussion suggested a desire to normalize
to U-labels...

Mind you, using A-labels for all domains in the certificate
matches current practice for DNSID, so I would not object to
that, and might even prefer it, but I don't recall any overt
discussion of this new approach.

-- 
	Viktor.

---

From: Russ Housley <[email-masked]>
Date: Tue, 25 Apr 2017 17:08:48 -0400

> On Apr 25, 2017, at 5:01 PM, Viktor Dukhovni <[email-masked]> wrote:
> 
> 
> to U-labels…

The conclusion for the discussion in Chicago was to do just that.

> discussion of this new approach.

You are correct that SmtpUTF8Name is the first use of U-Labels in the certificate.

Russ