Subject: [lamps] Fwd: New Version Notification for draft-belyavskiy-certificate-limitation-policy-02.txt

From: Dmitry Belyavsky <[email-masked]>
Date: Sun, 2 Jul 2017 20:45:46 +0300

Hello,

I've uploaded a document decribing a proposal of changing the certificate
validation process for application needs.
It provides more flexible way of trust limitations than CRL does.

Does the suggested document match a possible LAMPS rechartered profile?

Thank you!

---------- Forwarded message ----------
From: <[email-masked]>
Date: Sun, Jul 2, 2017 at 8:35 PM
Subject: New Version Notification for draft-belyavskiy-certificate-l
imitation-policy-02.txt
To: Dmitry Belyavskiy <[email-masked]>

A new version of I-D, draft-belyavskiy-certificate-limitation-policy-02.txt
has been successfully submitted by Dmitry Belyavskiy and posted to the
IETF repository.

Name:           draft-belyavskiy-certificate-limitation-policy
Revision:       02
Title:          Certificate Limitation Policy
Document date:  2017-07-01
Group:          Individual Submission
Pages:          6
URL:            https://www.ietf.org/internet-drafts/draft-belyavskiy-certif
icate-limitation-policy-02.txt
Status:         https://datatracker.ietf.org/doc/draft-belyavskiy-certifica
te-limitation-policy/
Htmlized:       https://tools.ietf.org/html/draft-belyavskiy-certificate-li
mitation-policy-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-belyavskiy-cert
ificate-limitation-policy-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-belyavskiy-certific
ate-limitation-policy-02

Abstract:
   The document provides a specification of the application-level trust
   model.  Being provided at the application level, the limitations of
   trust can be distributed separately using cryptographically protected
   format instead of hardcoding the checks into the application itself.

The IETF Secretariat

-- 
SY, Dmitry Belyavsky

-- 
SY, Dmitry Belyavsky

---

From: Russ Housley <[email-masked]>
Date: Mon, 3 Jul 2017 09:25:57 -0400

Dmitry:

This I-D is not complete enough for a working group to adopt it, but the nugget of your idea does come through.

A couple of things need clarification: Who would issue the CLP?  What set of applications pay attention to that issuer?

The LAMPS WG has alway had criteria that implementers are interested in deploying the work item.  Can you share any news on support for this approach?

Russ

> On Jul 2, 2017, at 1:45 PM, Dmitry Belyavsky <[email-masked]> wrote:
> 
> Hello,
> 
> I've uploaded a document decribing a proposal of changing the certificate validation process for application needs. 
> From: <[email-masked] <mailto:[email-masked]>>
> Subject: New Version Notification for draft-belyavskiy-certificate-limitation-policy-02.txt
> To: Dmitry Belyavskiy <[email-masked] <mailto:[email-masked]>>
> 
> 
> 
> URL:            https://www.ietf.org/internet-drafts/draft-belyavskiy-certificate-limitation-policy-02.txt <https://www.ietf.org/internet-drafts/draft-belyavskiy-certificate-limitation-policy-02.txt>
> Status:         https://datatracker.ietf.org/doc/draft-belyavskiy-certificate-limitation-policy/ <https://datatracker.ietf.org/doc/draft-belyavskiy-certificate-limitation-policy/>
> Htmlized:       https://tools.ietf.org/html/draft-belyavskiy-certificate-limitation-policy-02 <https://tools.ietf.org/html/draft-belyavskiy-certificate-limitation-policy-02>
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-belyavskiy-certificate-limitation-policy-02 <https://datatracker.ietf.org/doc/html/draft-belyavskiy-certificate-limitation-policy-02>
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-belyavskiy-certificate-limitation-policy-02 <https://www.ietf.org/rfcdiff?url2=draft-belyavskiy-certificate-limitation-policy-02>
> 
> Abstract:
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Dmitry Belyavsky <[email-masked]>
Date: Mon, 3 Jul 2017 16:39:51 +0300

Dear Russ,

Thank you for your attention!

On Mon, Jul 3, 2017 at 4:25 PM, Russ Housley <[email-masked]> wrote:

> A couple of things need clarification: Who would issue the CLP?  What set
> of applications pay attention to that issuer?
>

Any application vendor can issue the CLP. I expect that each vendor will
issue CLPs for the purpose of his applications, though I suspect that, for
example, if Google starts to issue CLPs, they will be widely used.

>
> The LAMPS WG has alway had criteria that implementers are interested in
> deploying the work item.  Can you share any news on support for this
> approach?
>

Unfortunately no. If the draft is accepted in this or that way, I'll do my
best to make it implemented in OpenSSL.

> URL:            https://www.ietf.org/internet-
> drafts/draft-belyavskiy-certificate-limitation-policy-02.txt
> Status:         https://datatracker.ietf.org/
> doc/draft-belyavskiy-certificate-limitation-policy/
> Htmlized:       https://tools.ietf.org/html/d
> raft-belyavskiy-certificate-limitation-policy-02
> Htmlized:       https://datatracker.ietf.org/
> doc/html/draft-belyavskiy-certificate-limitation-policy-02
> Diff:           https://www.ietf.org/rfcdiff?
> url2=draft-belyavskiy-certificate-limitation-policy-02
>
> Abstract:

-- 
SY, Dmitry Belyavsky