Subject: [lamps] Fwd: New Version Notification for draft-housley-cms-mix-with-psk-00.txt

From: Russ Housley <[email-masked]>
Date: Mon, 13 Nov 2017 10:15:40 -0500

People on this list may find this new I-D interesting,

Russ

> From: [email-masked]
> Subject: New Version Notification for draft-housley-cms-mix-with-psk-00.txt
> Date: November 13, 2017 at 10:14:32 AM EST
> To: "Russell Housley" <[email-masked]>, "Russ Housley" <[email-masked]>
> 
> 
> A new version of I-D, draft-housley-cms-mix-with-psk-00.txt
> has been successfully submitted by Russell Housley and posted to the
> IETF repository.
> 
> Name:		draft-housley-cms-mix-with-psk
> Revision:	00
> Title:		Using Pre-Shared Key (PSK) in the Cryptographic Message Syntax (CMS)
> Document date:	2017-11-13
> Group:		Individual Submission
> Pages:		11
> URL:            https://www.ietf.org/internet-drafts/draft-housley-cms-mix-with-psk-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-housley-cms-mix-with-psk/
> Htmlized:       https://tools.ietf.org/html/draft-housley-cms-mix-with-psk-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-housley-cms-mix-with-psk-00
> 
> 
> Abstract:
>   The invention of a large-scale quantum computer would pose a serious
>   challenge for the cryptographic algorithms that are widely deployed
>   today.  The Cryptographic Message Syntax (CMS) supports key transport
>   and key agreement algorithms that could be broken by the invention of
>   such a quantum computer.  By storing communications that are
>   protected with the CMS today, someone could decrypt them in the
>   future when a large-scale quantum computer becomes available.  Once
>   quantum-secure key management algorithms are available, the CMS will
>   be extended to support them, if current syntax the does not
>   accommodated them.  In the near-term, this document describes a
>   mechanism to protect today's communication from the future invention
>   of a large-scale quantum computer by mixing the output of key
>   transport and key agreement algorithms with a pre-shared key.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Mon, 13 Nov 2017 21:53:44 +0000

Hi Russ,
This is a useful doc. It resembles the IPSECME work for IKEv2 as a temporary solution until NIST comes up with new public key crypto algos. I would suggest to be more prescriptive on the KDFs, the entropy and the key sizes so they are long enough (at least 256-bits as you are suggesting with AES-256) to be resistant against a quantum computer.
Panos

From: Spasm [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: Monday, November 13, 2017 10:16 AM
To: SPASM <[email-masked]>
Subject: [lamps] Fwd: New Version Notification for draft-housley-cms-mix-with-psk-00.txt

Russ

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-housley-cms-mix-with-psk-00.txt
Date: November 13, 2017 at 10:14:32 AM EST
To: "Russell Housley" <[email-masked]<mailto:[email-masked]>>, "Russ Housley" <[email-masked]<mailto:[email-masked]>>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat