Subject: [Syslog] Doubts on definitions

From: "Glenn M. Keeni" <[email-masked]>
Date: Wed, 10 Jan 2007 15:05:15 +0900

Hi,

I am trying to understand the defnitions of syslog-proto.

Is "sender" the complement of "receiver" or "collector" ?

>   The following definitions are used in this document:
>   o  An application that can generate a syslog message is called a
>      "sender".

Is "sender" same as "originator" ?
In other words, since
>   o  An application that can receive syslog messages and forward them
>      to another receiver is called a "relay".
A "relay" is not necessarily a "sender" ( unless it generates messages
too) ?

Glenn

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "Rainer Gerhards" <[email-masked]>
Date: Wed, 10 Jan 2007 14:42:51 +0100

Hi Glenn,

Good catch - I wonder why we overlooked this all the time. The term
"Originator" is even never defined although it is used in the document.
I guess that's something for IETF last call. Will add it to the list.
What actually was meant is

* An application that *sends* a syslog message is called a "sender"
[UPDATE]
* The initial sender of a syslog message is called an "originator" [NEW]

With these definitions, a relay is necessarily a sender (even though it
just forwards messages) but it is not necessarily an originator.

Does this clarify? Does the rest of the WG agree to this propsed change?

Rainer

> -----Original Message-----
> From: Glenn M. Keeni [mailto:[email-masked]] 
> Sent: Wednesday, January 10, 2007 7:05 AM
> To: [email-masked]
> Subject: [Syslog] Doubts on definitions
> 
> Hi,
>

---

From: "Glenn M. Keeni" <[email-masked]>
Date: Fri, 12 Jan 2007 09:41:04 +0900

Rainer,
  The comments are inline.
> Does this clarify? Does the rest of the WG agree to this propsed change?
  I agree. We have basically have Senders, Receivers and Relays. Some
  Senders are Originators and some Receivers are Collectors. A Relay can
  forward messages. It is a Sender and a Receiver.  That looks neat.

Glenn