Subject: RE: initial window size

From: Vernon Schryver <[email-masked]>
Date: Thu, 29 Mar 2001 16:26:36 -0700 (MST)

> From: "Oleg Vishnepolsky" <[email-masked]>

> Since TCP stack does not have direct knowledge of the speed

As Joe Touch implied, that may be often true, but it is not always true.

>                                  the MTU gives a good starting point.

I don't see what the MTU has to do with link speed.
Yes, I know by heart a bunch of MTU's for various links, but ...

> A while back the reasonable ratio was for the window to be about 6-8 times the MTU size for the
> local connections (slow start algorithm for non-local).
> Is it still the case these days ? 

I doubt it was ever true that 6-8 times the interface MTU was the right
window size.  TCP stacks I've touched have not used anything that tiny
since the mid-1980's, when I jacked up one UNIX vendor's default windows
size to 30K, and that was partly because 32K or more hit sign-bit bugs in
some other vendors' systems.  At the time, my UNIX employer had real support
for only 10 MHz Ethernet.

Disclaimer: my definition of "right" has long been tainted by "goes
fastest according to various benchmarks."

Vernon Schryver    [email-masked]

---

From: "Oleg Vishnepolsky" <[email-masked]>
Date: Thu, 29 Mar 2001 19:26:14 -0500

The stack has to determine the initial window size, and all it has is the address of the other host, and MSS 
derived from MTU.
Practically speaking, most stacks use a hard-wired default (32k or 8k or whatever). They could a better
job taking MSS into account. 
To your other point, MTU definitely  has to do with the speed and memory on the adaptor. That's why
you will see higher MTUs with higher speeds. 
As far as 6-8 times the MTU being from mid 80s is not correct either. In fact, BSD 4.3 Reno had 2k windows
for local communications, which is even less than that ratio.
6-8 figure is based on my own experiments and measurements done in the early 90s.
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Vernon Schryver
Sent: Thursday, March 29, 2001 6:27 PM
To: [email-masked]
Subject: RE: initial window size