Subject: Re: [Tsvwg] Re: Why use Slow Start when destination is local?

From: "Jeremy Harris [RU-UK]" <[email-masked]>
Date: Tue, 9 Oct 2001 13:10:30 +0100 (BST)

> From: Alan Cox <[email-masked]>
> 
> > Vernon Schryver wrote:
> > 
> > > by the time you get the window slow-started-open, many TCP transfers
> > > are finished.
> > > 
> > > Vernon Schryver    [email-masked]
> > 
> > Maybe it would make sense to track good window size by peer 
> > rather than by connection?
> 
> What makes you think that different ports go via the same path or even to
> the same host ? Both are routinely untrue (bulk routing via satellite with
> interactive traffic going landlink, web caches by inktomi and friends)

So, by peer+port ?

-Jeremy

---

From: Alan Cox <[email-masked]>
Date: Tue, 9 Oct 2001 13:44:25 +0100 (BST)

> > interactive traffic going landlink, web caches by inktomi and friends)

Look at it from both ends view points. Its peer and port pair - otherwise
known as "by connection"

---

From: Alan Cox <[email-masked]>
Date: Tue, 9 Oct 2001 13:44:25 +0100 (BST)

---

From: David Nicol <[email-masked]>
Date: Wed, 10 Oct 2001 17:29:46 -0500

> Look at it from both ends view points. Its peer and port pair - otherwise

peer+foreign_port

would mean, that if I need to get open five connections to

204.152.189.113:80

I would only need to do slow start on the first one; the other
four would inherit the settings.

10.1.2.3:9773 <--> 204.152.189.113:80	slow start
10.1.2.3:9774 <--> 204.152.189.113:80	cached
10.1.2.3:9775 <--> 204.152.189.113:80	cached
10.1.2.3:9776 <--> 204.152.189.113:80	cached
10.1.2.3:9776 <--> 204.152.189.113:80	cached

-- 
                                           David Nicol 816.235.1187
                                            1,3,7-trimethylxanthine

---

From: David Nicol <[email-masked]>
Date: Wed, 10 Oct 2001 17:29:46 -0500

peer+foreign_port

204.152.189.113:80

-- 
                                           David Nicol 816.235.1187
                                            1,3,7-trimethylxanthine

---

From: Alan Cox <[email-masked]>
Date: Tue, 9 Oct 2001 13:44:25 +0100 (BST)