Subject: interface/route deletion

From: Saurabh Shrivastava <[email-masked]>
Date: Mon, 15 Oct 2001 20:44:14 -0700 (PDT)

hi!,
Q1   when an interface goes down, and there are still,
tcp sessions going thru it what happens ?
Q2   when a TCP session is using a route (struct route
* stored in in_pcb) and that router gets removed, id
the route pointer reset.

can someone please point me to the code which handles
these events in TCP.

thanks!
-saurabh

__________________________________________________
Do You Yahoo!?
Make a great connection at Yahoo! Personals.
http://personals.yahoo.com

---

From: Saurabh Shrivastava <[email-masked]>
Date: Mon, 15 Oct 2001 21:11:53 -0700 (PDT)

hi!,
Q1   when an interface goes down, and there are
still tcp sessions going thru it, what happens ?
Q2   when a TCP session is using a route (struct
route * stored is in in_pcb) and that route gets
removed, what happens ?

can someone please point me to the code which
handles these events in TCP.

thanks!
-saurabh